CyberLink Community Forum
where the experts meet
| Advanced Search >
Thank you, Steven G. I will try one video and test it for WhatsApp.
Appreciate.
Ina
I use PD 17 to edit and produce video's for our YouTube channel. We plan a new series of 5 minutes video's for our channel but simultaneously for distribution on WhatsApp.
Included in the file attatched is the rendering info I normally use for YouTube video's. (H.264 AVC)
Question:
1) What is the best way to produce the video's for WhatsApp? Should I first render a video for YouTube and afterwards do a second rendering for WhatsApp? What is the best route to follow?

I do not wish to merely post the video on YouTube and send a link to WhatsApp. The idea is to make the video's available on WhatsApp in smaller files for people who do not have access to YouTube and do not have much data.

Please advise.

Ina
Quote


Jeff is correct, PowerDirector uses SubRip format, unfortunatelly YouTube does not support the additional style information (formatting).
https://support.google.com/youtube/answer/2734698?hl=en


I finally had time to report this issue to Cyberlink Support.
Here is the question ID CS002048763

Thank you once more for all the advice.
Ina
Quote

There are no changes to any of the timings or to your original text, as you can see in this side-by-side comparison from the middle of the files. You can scroll up and down from beginning to end, and there are no differences between the two files at all other than the unwanted formatting being removed:




If you use the online converter ynotfish suggested, you should get the exact same results as with the cleaned file.

Since YT wasn't able to accept the original file, this is the first chance you've had to see how the timing looks, and I imagine you'd just need to tweak the time settings where appropriate.

To file a support request with Cyberlink, please go to this page and provide them the URL of this forum thread in your description of the problem. They don't monitor anything here, and you definitely want them to see everything that's happened so far. Please post back with the ticket number (it will start with "CS") to close the loop.

Once again, so grateful Optadata and everyone who contributed and brought enlightenment to this problem! Sincerely appreciated! I am amazed at the trouble you took, Optadata, once again to compare the two srt files. You did convince me. Thank you. I will certainly report this issue as you suggested. Ina
Quote

Probably not. Keep in mind for PD17 CL posted:
"Enhanced SRT subtitle support with more text options available." in the PD17 release docs

And a few users over the years requested these improvements:
https://forum.cyberlink.com/forum/posts/list/20968.page#post_box_111243
https://forum.cyberlink.com/forum/posts/list/46709.page#post_box_242368

Looks like CL adapted what is perhaps the unofficial approval of subrip format,
https://en.wikipedia.org/wiki/SubRip

Which is compatible with many players. I guess CL never provided a means to write the non txt formated srt file so one would need to use a srt editor, sed, txt editor, virtually anything to manually remove when desired.

Jeff


Thanks JL-JL.

It seems that PD has ongoing subtitle problems since many years ago.

I also noticed that I am unable to copy Word text into the PD 17 subtitle tool. It seems to allow no copying. This was another reason why I have been preferring the direct YT Transcription tool. I could copy directly from the Word document to their tool.
I do type fast, but this PD shortcoming of not being able to copy text has another more important drawback: In my native language, Afrikaans, we use many symbols, symbols I normally insert in the Word text. I cannot copy those symbols into the PD subtitle tool. The result is confusiong language. In Afrikaans, eg the word "se" has a completely different meaning when the word "se" is changed with at least three possible different symbols added above the e. ( I cannot paste the symbols into this forum either! Haha)

I enjoy working with PD and have been upgrading from PD 14 yearly. But this is a definate drawback. Do I have to change to another editing programme?
When will PD pay attention to this subtitle tool?
Quote Thanks for the info! That's certainly a viable explanation, and if every playback device or service was compatible with the newer format, this wouldn't have even come up as an issue.

Since not everyone/everything else is on board, however, it does seem like an oversight (if not a bug) on CL's part to not retain the original/vanilla formatting as an option. Seems to me like a service request would still be in order.


Thank you so much for all the reactions to my post. I appreciate the trouble. I did try the corrected sample that optodata kindly provided and inserted it in the YT video.

(However, i did not mention that I have been forced to revert to the PD 17 srt facility purely because I have been experiencing a transcription bug also on YouTube Studio Beta and Classic for the past month. Normally I have no problems adding transcriptions directly in YT). It did not seem necessary to mention this in my first post, but now it does. I found that the timing has to be adjusted in this cleaned version orf my srt file, although I took great care with the timings in the original srt. Why would that be???The additional transcription bug on YouTube is preventing me from correcting timings in the cleaned srt file, since the YT pause and play buttons jerks and freezes erratically. I have been sending YouTube many feedbacks about this to no avail and also unsuccessfully reported this on the YT forum. So I am still stuck).

By the way, the reason why I have so far preferred the YouTube transcription facitlity has been exactly because it normally is much more convenient and easier and faster to use than the PD 17 subtitle option!!! Until last month, when I started experiencing transcription bug problems in YT itself. Then, yesterday, I was forced to revert back to PD 17 transcription option. (I have been doing transcriptions directly in YT to my video's weekly.

I may also mention that the only previous time I tried to use the PD 17 subtitle tool for YT, I also experienced problems uploading it and gave up because this tool is much more time consuming, and less friendly to use than the direct YT tool.)

Thank you, ynotfish, for the remark posted while I was typing this post: (I will try the subtitle cleaner, thank you.) It does is a disappointment though, that it is necessary to revert to a second tool and that PD 17 cannot deliver the correct srt files. How do one go about reporting this problem and requesting a corrective update/service request?
I use PD 17. When I uploaded a srt file to a YouTube video, all the formatting instructions are visibly included in the subtitles. I cannot publish these subtitles without the formatting info showing. What do I do wrong?
Quote


I normally wait like and hour to give youtube time to do the main translation which is english for me. Then I download the file youtube and head over to http://www.syedgakbar.com/projects/dst to make any language I want. Then I submit it to youtube.

Keep in mind if I convert to French I also need to do the title and desciption and keywords in french for that language set which I simply use google translater to do this.

Hope this helps


Thank you for this advice. I will visit this out web adress.

However, I still have a problem with my original 2 questions. Do I have to embed the subtitles or can I export .srt separately? And NB why does PD 17 not accept my downloaded YT .srt file?

While I was waiting for an answer I started experimenting on PD 17 with subtitles for a new project. I normally do my YT captions on YT's excellent transcription facility. And I do like their auto timing provided. It certainly eases my work and shortens the time it takes to do the transcriptions.

I noticed that PD 17 do not provide auto suggested timings. A pity.

It therefore seems logical to rather do my subtitles on the YT facility than on PD 17? But that means I have to stay online to do this. For my long YT projects I would have preferred to be able to do it on PD 17 with auto suggested timings and then export the .srt file and upload to YT.
1) Can PD 17 create .srt subtitle/captions files that can be exported separately wihout embedding it into the project itself?

2) Can I import .srt files from YouTube's transcription page? PD 17 does not seem to recognize .srt files downloaded from YT?

It seems not possible?

Will apprecate help.
Quote OK, take a backup of your project .pds for safety.

Delete out the nested project.

Re-insert the same project and it should re-insert as an expanded one.

The change in default will only act on new insertions, it won't change already nested projects to expanded ones, or vice versa.

Cheers
PowerDirector Moderator


Voila!!! Thank you. This has solved my problem. I am overjoyed!!!
Much obliged.
Ina
Quote Hi,

As far as I understand your requirement - if your default insert project is selected "as expanded project" the inserted project should be inserted just as in PDR16, with all assets, timelines etc. available for normal editing.

It works as expected on my system, just as Tony outlined.

If that isn't happening, please check the default again.

Cheers
PowerDirector Moderator


Thank you for taking time to attend to my problem.
No, unfortunately, the situation is still the same. See 2 attachments: Nr 1 shows my correct default editing settings: Expanded.
Nr 2 shows my timeline, still with the inserted sequence shown as a nested project between the first part of the current project and the next part of the project.

What to do now?
Quote Hi Philippina -

In PD 16 I could insert these previously edited intro sequence and closing sequence to a new project and could also edit those sequences, because these projects were inserted with all their tracks and individual shots visible.


If you want PDR17 to behave just as PDR16 does, all you need to do is set your preferences to "Expanded", as shown in Nigel's screenshot.

In PD 17 when I try to insert a PD project (an opening intro sequence) PD inserts this PD project as one "video": a produced/mixed pdf file on 2 tracks only (sound and video). No waveform is visible on this audio track and no individual shots used in the intro sequence is visible. Only one sound track and one video track.


When you import a project as "Nested", it appears on a single track. If you double click it, all the tracks will be visible & you can edit as you wish.

Cheers - Tony


Thank you, Jeff and Tony who followed up on Nigel's advice. All three of you really have helped me. I did change the default editing settings to expanded inserts.

However, as I explained to Nigel, I would like to be able to simultaneously have the various segments/pdf files active and available for editing "in one timeline" to be able to do overlaps, etc. It is handy to be able to click on all the pdf files individually and edit the individual files on "seperate timelines" or individual projects. I need to edit them as a normal part of the new project. This is the way PD 16 behaves and I have been editing daily new video's with no problem. Suddenly I am stuck without that option in PD 17.

What shall I do? At the moment it still seems to be an either/or case. Either edit the new project or edit the inserted pdf sequence. This handicap is preventing me from editing easily. I prefer the uncomplicated PD 16 function so far.

Please, I need futher help.
Quote When I insert nested projects they appear as additional tabs in the timeline pane.
They ALSO appear in the master project tab as a video/audio clip with a "pds" icon at the bottom left however they CANNOT be edited here, they can only be edited by switching to the nested project tab which btw can NOT be selected if you have the master project timeline locked so must unlock 1st.

If your behaviour is different check your nested project setting in prefs (see attached pic) since it can be changed from the default of "Nested" to "Expanded". I'm not sure what "Expanded" means as there is no doc explaining it and I haven't tried it.


Thank you, Nigel. You introduced me to a new default editing setting that I overlooked. I now do understand the difference between nested and expanded. In the nested version the clip is shown as 2 tracks only. Expanded enable me to edit the inserted clip/intro sequence.
Hoewever, even when all the tracks are unlocked, I am only able to edit the various parts of the video separately: above the timeline two buttons appear. I can select the hook/teaser of the video or I can select the inserted intro sequence, or the next main part of the video, the body.

I would like to be able to simultaneously have the various segments available for editing, because I would like to overlap the music of the inserted intro backwards to the last few frames of the hook/teaser. And I would also like to overlap and fade out the music under the voice in the 3rd segment of the video, the body of the video.

But thank you for setting me into the right direction!
I normally edit my YouTube video's in the following manner: I start with a teaser: a short extract from the video to entice viewers to continue watching. Then I insert one of my previously edited PD intro sequences. Then the rest of the video follows and right at the end of the video I again insert another previously edited PD sequence, a closing or exit sequence.
In PD 16 I could insert these previously edited intro sequence and closing sequence to a new project and could also edit those sequences, because these projects were inserted with all their tracks and individual shots visible.
In PD 17 when I try to insert a PD project (an opening intro sequence) PD inserts this PD project as one "video": a produced/mixed pdf file on 2 tracks only (sound and video). No waveform is visible on this audio track and no individual shots used in the intro sequence is visible. Only one sound track and one video track.
Even the titles I have added to these intro and closing sequences is incorporated/mixed onto the video track.
This causes problems when I want to edit these inserted sequences in the existing project, for example when I try to move the music to overlap the shot just before the inserted intro.
I therefore cannot edit the titles in these intro and closing sequences to update info of my new project.
IWhy is there no option that I can still insert a PD project into the currently edited project with all the tracks of the inserted project visible and editable?
This is rendering PD inserts into currently edited projects almost impossible to edit.

Please help.

(PS to my computor info: I have installed a second hard drive to this computor)
Quote Hi,

I suppose it may be up to you in the end. It may be that some part of the project is damaged, or causing the issue, and to find it might be as much work as your suggested method. It might be a specific asset or an edit that is causing the issue so "re-using" that asset might still cause the issue in your new project??

In the absence of sequential backups, which might get you to a point before the problem arose, there is a well tried process for troubleshooting this type of thing - applicable in many contexts.

Take 2 backup copies of the .pds file

Open backup1 of the project.
Cut out half - probably the last half might be best, unless you've worked on the first half more recently.
See if the problem shows itself on the half that is left. If it doesn't - then that half is probably OK.

Open up backup2.
Now do the same, but take out the first half which is OK. The problem should then be in the remaining last half. If it is, then the same technique can be used again - split the remaining half and check which bit causes the issue.

You might have to do this splitting and testing of halves several times and eventually you might be able to narrow it down sufficiently to cure it!?

Whether it's worth it is over to you!

Cheers
PowerDirector Moderator

Thank you. I will definately keep that in mind in future. Good advice, much appreciated.
Quote Hi,
In these types of instances the primary aim is to protect as much of the project as you can.

As a first step, locate your project .pds file in windows explorer and copy it to a new name and new location as a backup.

Next, open your original project and see if you can do a Save As to a new location and new file name?

Then open this "new" project file and see if the error persists on a Save command.

The Autosave location might have been changed, or become corrupted, so check that, and, if necessary, change it to another/new location and see if that helps.

For example, when I'm testing something for someone, my autosave is changed to C:\USERS\NAME\DESKTOP\PD16AUTOSAVE\
so that it doesn't mix things up with other personal project autosaves.

It may be that PDR has tried to save but failed, and therefore reports that the project might be corrupted as a result. Of course it may not be, and, as you report, everything seems to be there. Personally, I manually save to a sequential project .pds as often as I can remember, to minimise any chances of corruption or disk error etc.

Cheers,
PowerDirector Moderator

I am really thankful for the interest in my problem. Thank you for all the suggestions. I followed all the steps you recommended and changed the autosave to the new file location. At first it seemed to solve the problem. I was able to save the "new" project. But soon the original error message returned.
The only alternative that I could think of was to produce what I have edited up to this point, and import it into a new project and continue from there. I will have to checkerbord the "clips" to be able to shorten some and do transitions, as well as to be able to eventually colour grade and do sound mixing. Time consuming, but I can think of nothing else. Do you agree?
Quote where do you save your project? The error message says something about MSOCache. That is a MS Office Folder where you don't have access to as a normal user.
Start PD16 as an administrator and try again. If it works, it seems, that your project or PD16 tries to save files to folder, where no access is granted. Change to save folder to an other folder.

Hatti

Thank you, Hatti,
Appreciate your interest in my problem. I do not know why I received the second error message re MSOCahe. It occurred only once. See the rest of my answer to the PD Moderator.
PD version 16.0.2524.0
SR Number VDE171213-07

I am editing a documentary of 45 minutes. Current length of rough cut approx 25 minutes. Using stills and mp4 clips and interviews and AAC m4a sound. 1920x1080 HD. Last night I received an error message: Error saving. Project might be corrupted. I have no idea what caused it. I tried saving the project under a new name, tried Pack Product Materials, etc. When I re open the project it is possible to view all the material on the timeline. Nothing seems to be missing, but when the project tries to auto save after 5 minutes I repeatedly receive the error message. I have an urgent deadline but am afraid of the consequences should I continue editing and ignoring this error message.
At the time I received the first error message I was more or less doing the following:
a) Using Magic motion on a still. I tried to ease in and out.
b)Went back to YouTube to the How to tutoring lessons.
c) Tried to change the clone display (my computor screen and external Dell screen) to multiple displays to be able to follow and apply the steps of the lesson. Encountered a problem to change to multiple displays, although I have used it in the past.
d) Encountered a problem to enable my mouse on both screens. Have not experienced this before.
e) Inserted a small PD project of an interview.
Could any of these steps have caused the error message? Please help.
I am also unsure whether the settings for shadow files is correct, which resolution I should use and where to store the shadow files.
Currently 720x480. I had my setting to auto delete every 30 days, byt have changed it to manually delete
Some PD programme and other files are on the OS drive; some on the D drive. Preview cache files on D drive, as well as project and all materials in on master library file. During editing I use the High preview resolution. During my previous drama project of 55 minutes I could easitly use the Full HD Preview resolution, since the computor has the ability to do so.
Quote
Quote I normally use the function Pack product materials when I have finished editing a project. Then I could store this file anywhere and re-use at a later date. Lately I have found that clips are missing when I re open the project. Please help. I thought that the function Pack product materials as a safeguard operates to conserve the clips in one place.
Various intro sequences that I use regularly are now unavailable.


Are you opening the project file "name" .pds, which is in the same folder?

YES
I normally use the function Pack product materials when I have finished editing a project. Then I could store this file anywhere and re-use at a later date. Lately I have found that clips are missing when I re open the project. Please help. I thought that the function Pack product materials as a safeguard operates to conserve the clips in one place.
Various intro sequences that I use regularly are now unavailable.
Go to:   
Powered by JForum 2.1.8 © JForum Team