Announcement: Our new CyberLink Feedback Forum will launch in a few months, providing a better experience to our users. Once launched, posting new topics or replying to old topics on the CyberLink Community Forum will no longer be available.
CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote Previously, I could click on a clip and jump right to the begining of it. This is important to me because I make videos with lots of short clips and getting right to the start of a specific clip is helpful for editing quickly. However, now I get the following pop up when I click on a clip:

"The playhead will not automatically jump to a clip you select. You need to drag the playhead to the clip to start playback."

Basically, I want the "playhead" to automatically jump to a clip I select. Is there a way to do this in the new version?

Thankfully this is one feature that has returned in the latest update
Quote I wouldn't count on anyone at CL with the ability to make changes seeing discussions here on the forum. Maybe they look here once in awhile, but I think the best approach is to use the "official" feedback channel of Rate Us & Provide Suggestions under PhD's Help menu.

Nobody here asked for the recent changes, and I don't know how much user testing they ever do before they make significant alterations to a product's workflow, so telling them you really don't like the new layout is probably the only tool us end users have.

Thanks optodata, sounds like the best idea.

It is unusual for Cyberlink to make such bad ly thought out changes as it does appear to be no one asked for them !

Quote I agree totally. This workflow takes additional time and you cannot edit a photo modified in guided or expert without saving as a new file. Does not make sense. Hope you address this.


Bill Byrnes

Hi Bill Byrnes
Thanks for your reply.

I really Hope Cyberlink are listening

Quote Is the f: disk (always) online? Is that where you have defined your working folders for PhD?
what I suggest you do is, (temporarily) change the name of the folder showing in your image, such that PhD is not able to discover it, hence not checking it again.
It may also be worth it while to look at what there is in this project? Would it be possible that you have (too) many images, or deleted images, or images on a disk that is not online... would it be possible to check the project yourself, to see whether something obviously is wrong?
by renaming you effectively delete the project from PhD without loosing it. ....
My two cents ....

Hi Warry - Many thanks for your suggestings. I'll follow through your ideas later on today and post back any findings.

Quote I have tested and I don’t see this behaviour. When I close PhotoDirector and the annoying splash screen, I don’t see any PD14 activities in the background. It may be that PD14 is scanning your library e.g. to select faces or the like? I don’t use that functionality.
Maybe check with the same resource manager what files it is accessing if any; or network activities? This might give you an idea of any activity/purpose?

B.t.w. I agree that this splash windows is very annoying, but I like the layout of the screens “behind” it.

Hi Warry, thanks for your reply.
I've added a few more screen grabs, but this time there's a "PDR is checking project" before PDR launches !
There is no network or disk activity after PDR has closed down, memory usage reduces until it reaches what is shown on the screen grab. In the Services tab, RichVideo64 is showing Cyberlink RichVideo64 Services(CRVS) is still running. PDR is using 639.7MB while running in the background !
I closed PDR by using Task Manager again, while watching CPU Processes in the Resource Monitor, PDR was greyed out but showed that it was still using just one thread for a few moments then it dissapeared off screen. No futher indictioins of Cyberlink Photodirector could be found working in the background !

I re-launched PhotoDirector again and after clicking on that Splash screen again I was shown that "PDR is checking project" yet again! Could this be the problem as PDR needs to keep checking project ?

Thanks for you help in this matter.

I thought I'd start another thread with even though it maybe a similar issue.
I frequently (!) use the Microsoft Task Manager when/if I think I may have a PC problem and while I was using PowerDirector to edit my latest video, I noticed that my PC was not running as smoothly as it should. Checking thru Task Manager I noticed that PhotDirector was still running in the background even though I'd closed it down after using it. several hours ago. I then used Task Manager to close the "back ground "program".

After finishing my edit in PowerDirector, it closed fully! I tried running PhotoDirector again, it launched as in the new fashion, selected a random image to adjust, saved it, closed the progam and then closed the very annouying splash screen.
Acording to Task Manager, Cyberlink Photodirector was now running in the "Background Processes" even though the program was closed down, I tried to launch PhotoDirector by clicking on the link on my PC, it didn't launch!

Only by using Task Manager to close the background process could I then re-launch PhotoDirector.

Anyone else having this issue?

Quote I agree, the previous version was easier in normal use.

Thanks Koen41 for your responce

Quote I totally agree, it was so simple that you had a choice to go to full edit or quick edit and it would remember your preference. You could work systematically going from left to right.

What I hate is when you exit the program you have that stupid launcher still in the middle of your screen.

This is funny. I had to reset my computer and when I downloaded again, I thought there was a glitch and contacted support for help.

Hi Grant, thanks for your reply

I've also noticed something similar while using the "Task Manager" to check on things! The new version of the Cyberlink Photodirector tends to "hang on" in the background processes, even though you've closed the programme! I've had to click on End Task to be able to relaunch Photodirector, if that didn't work I've had to re-boot my PC !

What have Cyberlink done ?

PLEASE, PLEASE , can you get rid of this dumb down version and go back to launching just "The One" Photodirector ?
It's so much easier when you want to jump from edit screen to the re-touch/remove screen and then perhaps the Edit screen rather than having to go back to the Dum Guided / Pro screen and using far too much edit time & PC resources !

Please keep all the edit stages in one package, you've gone from a quite slick edit system that was far easier & simpler to move between different edit screens, to a one with more pretty, time wasting icons asking you dumb questions " Do you want to edit your phots?" of course I do that's why I'm here !!!!

I do not like it !

Cyberlink What Are You doing ?
Quote G'day Dave -

Something similar happened here when I first attempted to use a LUT in PDR365 21.0.2123.0

Firstly, all the thumbnails were blank (generic greyscale icon). I downloaded a LUT to apply it & PDR went white (not responding).

Since that incident, it's been working smoothly. I hope the same is true in your case.

Cheers - Tony

G'day Tony, how are you doing?
Thanks for adding your info, my experiance has been very similar but with carshing as well as a white out ! After starting anew project with one video clip, then adding a LUT, I found the it all worked. Happy days cool

Thanks agian for your comments.



Seems to work fine on my system but I'm running PDR365 Business 21.0.2121.0 - just for completeness which version are you on?

PowerDirector Moderator

Many thanks for your reply. Sorry about my late reply as I've been trying out different ideas!
The version of PowerDirector 365 that I'm using is 21.0.2123.0, updated on the 26th September 2022.

I went onto open several different projects just to see if I could add/change a LUT to any video, but this became a bit tiresome!
I then went onto starting anew project in PowerDirector 365, adding any video to the timeline and then trying to add a LUT. On the first atempt, this caused PowerDirector to crash ! However on the second atempt, it worked, PowerDirect 365 was stable and didn't crash! I did not save this as a project, I couldn't see the point. I went back to my present edit project and found that, to my amazement, I could now add LUTS without PoweDirector crashing!
Here is a link to the video if anyone is interested It's the first time that I've tried using 3 cameras, 2 of them are fixed so I've used quite abit of the Crop/Zoom and Pan Tool. The third camera is quite old and no longer records sound so it was back to the old syncing up by eye from my days of using 16mm film with no clapper boards ! Great fun, huh.
I've since stated another project and tried using a LUT straight away finding that it does work and that PowerDirector was stable with no crashing. Maybe it was adding a LUT onto a "bit" of video that fixed this issue, who Knows, but thank you for asking.

Is anyone else having problems when trying to use LUTS since downloading the latest 365 update?
I've finished the edit, selected FX, from All Content, I've selected Color Lut, then PowerDirector 365 just hangs!
Clicking again, a windows error message "PowerDirector Is Not Responding" with the usual instructions.
I've realsied that I must save my project before trying to get to the Color Lut as I have already lost one of my edits, most unusual.


I've just had a new PC built for me using the AMD Ryzen 7 3700X Gen3 8 Core AM4, very slick. It's about £290:00 at the moment.
I'm still using my old NVidia GPU as I needed to save some cash by keeping the GPU and spending money on the CPU. Now, I think that the time has come to replace my old GPU as it's struggling with 4K and two streams of video in the timeline plus video corrections. Also the other video editor I have, now requires GPUs with over 5 GB ram !
I'm using a Intel 660p 1TB M.2 PCIe QLC 3D QLC NVMe SSD/Solid State Drive, the difference between this and the old drive is astounding. however it's been superceded by a 1TB Intel 665p Series, M.2 (2280) PCIe 3.0 (x4) NVMe SSD, QLC 3D3 NAND, 2000MB/s Read, 1925MB/s Write, 160k/250k @ £89:80 Black Friday deal. I might buy it !
Ram used is Corsair Vengeance LPX Black 32GB 3600MHz 2x16GB DDR4 Memory Kit
It's a very quiet set up .

Good luck
Quote Hello Kyle 40,

As Jeff pointed out, the integration of PDR & ADR is the same as in previous versions. There are some differences with PDR19/ADR11, one of which is the ability to export your whole PDR timeline audio to ADR rather than separate clips muliple times.

The PDR Help file does actually cover what you need:

Editing Audio in CyberLink AudioDirector

Latest Features


Hi Pix, many thanks for you reply.

Thank you, this is quite amazing ! I haven't had too much time to try it out but on my my first effort, it took around 9 mins to load a 14 min project into ADR. I'll do a screen grab to show the task manager.
So far I've only tried the last option Remove Applied Audio Effects and Volume Keyframes: but any audio edits I tried couldn't be undone using the Undo buttons + the audio faders had no effect on the time line. I'll try and do a demo and post later on when I've tried it out.

P.S. this is the edit where I've had problems with my older camera !

Quote Same as prior, right click on clip in PD timeline > Edit Audio > AudioDirector...

Changes made in AudioDirector are reflected in PD timeline.


Hi Jeff, thanks for replying. Yes, that's the "old" way of loading your clips into AudioDirector but I'm afraid it's different to how we did it before.

Any advice on how to use the new intergration ?

I can't find any info in the How To Do It guides .

Quote Hello Kyle 40,

Like optodata, I'm not seeing the playback issues you seem to be having. Playback of UHD clips (60Mbps) is instant, though not completely fluid. CPU is running at ~40% & GPU at ~10-15% with adjusted clips.

About the Scope/Histogram/Waveform monitors: Could you post an example of the sort of display you're after? Perhaps something like that shown below? We each have different requirements & yours may be greater then mine, but I wouldn't have said "unusable for colour correcting".

You make a fair point about having to work with one clip at a time when round-tripping with PDR. You may have noticed that CL has introduced a feature in PDR where the whole project can be exported to ADR11, so the engineers' thinking might eventually align with yours with regard to CDR.


Hi Pix

Thank you for your reply to my moan. I must admit that I was hoping/expecting to have scopes that are standard for colour correcting, just as your image depicts. I do find that the Parade and Vectorscope are essential for correcting! I hope they' appear in another update to CDR.

Don't know if you've had a chance to read my reply to Optodata, but it appears that it's my video clip that's at fault ! It was taken with an old camera which has since proved to be unreliable. I've delved into 10 other projects and all the clips played with minimum fuss, I've even taken the oppertunity to create some more presets .

Many thanks for your help once again.

Quote I haven't spent much time with the new CDR, but I don't see any delay at all after placing a clip on the storyboard and clicking Play.

In all fairness I have a new and very powerful 16 core CPU so my experience may not be typical, and so I wonder if the duration or encoding of your particular clips might play a role. Trying out different source clips might allow you to determine if there are any particular clips that CDR has more difficulty processing.

I haven't used the scope/waveform tool before, but it seems to accurately reflect the dynamic changes as made by each control. I'm glad the window is detachable so I can set it big enough to see all the details:

As for CD9 being "integrated" into PDR (obviously CD9 is fully integrated with itself ), this is the same approach used with ADR and I'd suggest that the ability to call up CDR, make the change and return to PDR without having to produce the clip first is actually a timesaver.

On the other hand, if you're going to be working with many clips at once, I agree that building the timeline in CDR and producing there is probably quicker, especially if you're dealing with entire clips rather than small sections like you'd likely be working with in PDR.

Hi Optodata, thanks for replying.
You're quite correct in that the scopes do reflect the actual dynamic changes of the video. I was hoping for/expecting maybe praying for ( nah, don't think I'd go that far ! ) Vectorscope or better still a Parade scope (as in Pix reply) to really get to grips with getting the best out of colour correcting!

Now I've had a bit more of a play with different video clips, I've found the adjustment sliders to be fairly responsive. It turns out that the clip I was using during my first "moan" was recorded with an old camera which is producing problems ! I've gone through the same procedure now, using video from 10 different projects and they've all responded fairly well. At least better than the previous version of CDR ! It appears to be just the video from this old camera that I used for this shoot, that is causing problems! But I've nearly finished this particular edit.

Just been trying out the new CDR 9 - 365. after watching the Cyberlink video about all the new "bits", I must say that I'm very disappointed with it!

1,Once the clip is placed in the CDR Storyboard, it takes a while before it plays even after you've pressed play. At that point the software appears to "hang" but there is hardly any CPU OR GPU performance taking place even though RAM usage is around 7 GB. After clicking on "STOP" even before the clip has started to play, takes a while for the stop command to work.

2. I was expecting to have usable SCOPE/WAVEFORM monitors but we've ended up with something which can only be called "insufficient" almost unusable for colour correcting!

3. CDR9 Is still NOT "integrated" into ColorDirector, you have a timewasting switching back and forth between the programmes just for one clip. You then have to wait to view the correction in place with the rest of the timeline. Quite a waste of time. Yes, I could wait until the programme is finished before jumping into CDR-9 BUT it's still only a clip at a time, you can't import the full ColorDirector Timeline.
No doubt there are other irregularities I’ve still to find out, but this has taken too long out my day so far just to try this out!
I'll just wait with baited breath or have another coffee and a piece of GF cake

Quote Hello
Please could someone tell me the way to get the day to night effect.
Thank you

Hi Dazzmos

I know someone has answered your question, but I've been off line for a while, so I thought I'd still reply with a link to my "Day to Night" settings in my Director Zone. The video preset has been downloaded over 1800 times so it must be helping some people .innocent . Of course, you can always tweak the settings to suite your needs.
Go to:   
Powered by JForum 2.1.8 © JForum Team