CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote I searched for hardware-related questions but didn't see any. I built my i7-4790 based system several years ago and am thinking about an upgrade. I"m hitting 100% at points during rendering so I plan on a new system because I've maxed out this motherboard. My graphics card - Nvidia GTX 980 - needs an update as well. I often process 4K video so the system has to handle that. Don't want to buy too much higher than my need. Not going to be processing video higher than 4K. I also drive 3 screens - 2 4K and 1 1080p - using TDAmeritrade's Thinkorswim stock trading software and usually have 10 charting windows open at once. The number of choices is a little daunting. I'm hardware agnostic. Any suggestions? Oh, and I have the 365 Director Suite subscription that is up to date. Thanks.

I think your Maxwell NV GPU is really out of date and definitely not enough for 4K gaming or video editing.
It might be OK for 4K video playback though.

The price of NVIDIA GPU has dropped significantly, and the prevoius 20 series has ceased shipping by NVIDIA already.
If you are going to puchase a new PC for editing 4K videos, you may consider 30 series or above directly.
But, the latest 40 series might still be too expensive.

RAM size is also very important for processing 4K videos. 16 GB is the minimum, and 32 GB or above is receommended (no matter you chose DDR4 or DDR5).

By the way, the new 12th generation Intel CPU has quite good reputation for its performance improvement over all previous generations. You should also consider the upgrade on CPU as well.

Your i7-4790 has released for nearly a decade and not even capable than the new and low end Intel 12th core i3.

For more information, you can consult your PC vendors for what they have now or it might need you to wait for the arrival.
Quote I spent an entire day editing movie information including setting cover art, changing matching movie information, editing movie information, etc.

In fact, I have 3 computers all equipped with powerdvd 22, and had the same exact problems with movie matching information on all 3. I went through the same exercise to correct the matching errors on all 3 systems.

Much to my dismay, the changes I made are gradually being reverted to the original bad information on all 3 systems. As soon as I change the information to what I want in there, it goes back to default on the next restart.


Evidently powerdvd 22 is not saving the changes, or is saving them in volatile memory. As this is 3 different systems. it is not an isolated case. I have about 1300 movies stored on 16TB disks, and Powerdvd 22 is turinng out to be more of a problem than a solution. I see this often enough to believe it is a systemic problem with storing changes to movies information inherent in Powerdvd 22.

What is Cyberlink's explanation of this

It seems you host your movie library on a NAS or network drive, right?
Or, you really have 16TB hard drives installed on all 3 different platforms?

I do not encounter the same issue after set custom movie info for my movies that are stored on my local hard drive.

The possible cause that your custom movie info reset is because a normal network drive reonnection might reset the library linking status, and powerdvd rescan and treated your movies that you've previously edited as new imported movies from scratch.

You can try that if you moved some of your movies to local hard drive, import the movies from local, and change movie info of them in powerdvd movie library. Then, check if the info still got reset for those local movie titles.
Quote I have a professional music studio, which includes a standard MIDI setup routed through an ASIO device. So here I sit, trying to get SR4 to record the MIDI output. The options seem rather anemic for selecting various input methods.

I've read several forum posts related to system audio, how to make sure the right buttons are clicked, and so forth. Nothing seems to work.

Is there anyone in the community experienced with MIDI issues?

I'm not sure your whether your professional setup can be operated in this screen recording tool or not.

But, if it is similar with Line-in recording, what I can imagine is that you can just select the correct audio input device interface in screen recorder, and make sure the Line-in input is operate-able in your Windows system in advance.

Then, check the slider of the audio mix bar is at balanced position in screen recorder > audio settings, but not lean to neither of the speaker nor microphone side solely.

The above setup should work for general recording cases I guess.
Quote The new perpetual patch, build 2220 11/2/2022, attempts to auto install immediately after download. It used to give you like a 10 or 15 second window to just save the download and postpone immediate auto install. The new patch no longer does this which makes things rather inconvenient if you simply want to download to save and install latter.


I just downloaded the new patch to update my old version audiodirector that is not updated for months.
IMO, the new flow is less troublesome because the prompts are less. I even don't like the counting down of asking where to save the patch but I understood it is required for some users that want to have full control on every step.
Quote Is it possible in Photodirector to create a glow effect on an object and have the light cast on the surrounding environment like in this youtube video?

What I can find that the effect is close to the manual one you show in the photoshop video is the "Light Ray" tool in photodirector's guided room.

You can try that if the light ray added result is good.
Quote I've already disabled my antivirus (Windows Defender) while installing with the same result. I've attached my DxDiag.txt file here, because I'm still waiting on my most recent support case for this. Everyone says the same thing for this, which is that the C++ Redist needs to be installed, but I've literally installed every x86 and x64 package from 2005 to 2022, and I still have the same results. What exact C++ redist is used for PowerDVD22? Because I can uninstall the other distros and install just that one to see if there is some sort of overlap issue with this.

AFAIK, the most common one is 2012 but I'm not sure if powerdvd also uses others. FYI.
Quote I primarily use LIghtroom/Photoshop for image editing, but I haven't found anything better than PhotoDirectors "deblur" feature. Anyone else use this? I use this tool often. My workflow ends up being in Lightroom, choosing "Edit copy w/lightroom adjustments" in PHD. Then I run deblur from Guided. Then I do a Save As, and have to rename it because for some reason Cyberlink thinks the .TIFF I loaded is already in use (although it works fine using Adobe products). Then in LR I have to synchronize the folder to see my new file with edits, so I end up with 3 files. The original, the exported .TIFF that I loaded in PHD to run deblur, and the 3rd copy I created using "save as" from PHD. Then I delete the second copy.

Kind of cumbersome, but I haven't figured out a better way to use the deblur function. I guess I could manually load the image in PHD first, run deblur, then take it into Lightroom and run my edits.

Just curious if anyone else uses this tool as much as I do and what your workflow looks like.


I'm not sure why you didn't directly import the original photo into photodirector to adjust colors or use layer editing features on your photos all in photodirector. It could be the fastest way.
If you need to use LR and PS for some reasons, I think you already found the fastest flow to edit the photos between photodirector and adobe LR.
Quote I get it's a variable bit rate, and the actual size is a guess.

What doesn't make sense is the random change in quality that's not reflected in the settings. And if I choose 'high' then the dual layer size jumps to 4Gb, so it's clearly not maximising the bit rate at 2.3Gb.

where does it show the actual bit rate?
If I'm happy with the quality at 1.7Gb, where can you set the same quality for the dual layer setting?

Again, where's the logic in changing the bit rate behind the scenes between single layer and dual layer?

As you already knew the actual bitrate is variable. your logic may make perfect sense for contant bitrate (CBR) profile (which is not offered in power2go), but it might not be applicable for variable bitrate encoding.

The profile you selected that still labelled with a bitrate in number is just a compression level reference and the profile won't give you an absolute bitrate because the actual bitrate is not available before the video really got encoded and compressed that are based on vidoe scene complexity and other graphic processing factors scientifically.

Technical wise, video compression (encoding) is very complicated in mechanism and it is a big topic, and variable bitrate encoding does not act on 100% precise or contant number basis.
You may consider the profiles a general quality level reference.

For example, if your video is just full of purely black or white static scene for an entire hour, you can try selecting a profile that labelled with extremely high bitrate, the produced video won't be encoded with the high bitrate you selected.

In my own test, the dual layer DVD that produced from a short source video (less than 10 minutes) via power2go, the maximum bitrate of the produced VOB videos is a bit higher than videos in single layer DVD folder, but the average bitrate is the same between these two disc folders.

To save your time and effort to dig in the bitrate differences, produce your project into disc folder first, then burn the folder into discs. Or, use smartfit to produce your DVD discs.
But, if you really need a disc production tool that produced video disc in precise and contant bitrate, you may need to look for other software. The file size will be precisely measured before the disc produced, and the produced bitrate will be identical to what you selected.

For what I know so far, Cyberlink's power2go or powerdirector all act on variable bitrate basis to encode or produce videos.
Quote So what's the point of the quality setting?

There is 'high', 'SP' and 'LP', with the bit rate beside it, and if I change the bit rate too 'high', then the size on disc changes accordingly. Changing to 'high' sets it at 9.5Mb/s and almost doubles the size on disc.

And if there is only one video of 1-hour on a single layer 4.7Gb disc, why would it not also increase the bit rate, since there's lots of free space unused?
When burning 2 videos to a single layer disc, then it uses 3.2 - 3.4Gb, leaving wasted space. It seems a flawed logic here.

It seems you are going to make your case become a mess here.

Most of video editing tools produced videos in "variable bitrate" and any specificed bitrate user (you) selected will act as an average and approximate configuration or number.

I consider the moderator suggested above that the bitrate will be higher is about the real time bitrate, but the average bitrate is still about 9.5 mbps.

As it acts in variable form, it is not technically possible to produce your video in 9.5 mbps bitrate on every second using a video editor software.

In my opinion, the file size shown in power2go production window is just an safely-estimated value in case the video disc burning task break your discs or disc writer physically because of incorrectly over-burn.

Just select an preferred profile to produce your videos into video disc folder first on hard drives, and you can get the precise video disc folder size before your burn discs.

You can then produce the disc folder on dual layer discs physcially without worrying the estimated file size number.

I've attached snips if this helps. The hosts file is empty and MS firewall turned off. I found a stray Cyberlink service that would fail immeditately after starting. I removed it thinking V22 needed to install it (PDVD12 did). It was not reinstalled during a fresh install of V22.




It did attempt to make connections to several remote hosts. But, it also attempted to connect to a service running locally which failed (timed out).



I did get one error during install with the MS Edge logo. I'm sorry but I don't have Edge installed. It's a bit like contracting syphillis. It sounds like a good idea at the time but later on bites you where it hurts the most.


When launching PDVD22 it successfully connects to two remote hosts, and Once a mode (PC or TV) is chosen it establishies a successful connection to


It then attempts to connect to a local service on (localhost). This is where it hangs and ultimately barfs.


I've tried to ping these remote hosts but I suspect ICMP is turned off as all requests time out.

I have my router's firewal configured to allow outgoing connection on all but a few ports, none of which are used by PDVD. It is however configured to refuse incoming connection on ports I have not specified. There should be no reason for a remote host to establish an incoming connection with any system on my network unless I have specifically allowed it.

Tell me what I should be looking for and I will get it done. I'd like to resolve this issue. Since I bought PDVD12 I have not used much else (well, VLC, MPC HC, MPC BE and ZoomPlayer). If we can figure this out I will likely upgrade, but, it has to work with my test Blu Rays first. One defaults to the audio commentary (useless) and the other fails AACS which I can't update in V12.

I've been in IT in some capacity or another since the implementation of CP/M so I'm not your average consumer. Tell me what I should look into and I will make it happen. I don't like losing and I'm not one to give up.

As this forum script package is limited with reference to the number attachments the referenced images can be found here:

or here (I have allowed indexing there for convenience):

Thanks in advance.
Neal (Houndog750)

It seems you might have walked too far away from what it really matters for playing movie discs.

Yep, you are not my average consumer, and it seems you have not been a customer for cyberlink for a long time as you were still using the powerdvd 12 version that might have been released 10 years ago.

I can see that you're still using windows 7,
Have you already updated your windows 7 with every bit of updates that microsoft has released to acquire the latest TLS 1.2 compatibility?

If all of these didn't help your case, I suggest you contact their support to sort out the problem directly.

BTW, powerdvd 22 also supports LAN sharing feature that it will host the local PC ( as a media console server, and if you didn't use the feature, I consider that the sharing feature is under standby status and it also matches your finding. However, the error you received in powerdvd should not be relevant with that.
It seems there is no other users having the same connection problem currently. It indicates cyberlink's server is working fine.

Check your firewall or Internet security software's setting and check if it blocked powerdvd22's connection to access the Internet, and then check your hosts file in Windows.

Does it contain any cyberlink server addresses and redirected those addresses to invalid IP address: ""?

If it is the case, remove those configuration in your hosts file.

Or you can contact cyberlink support to investigate the condition you currently encounter.
Technical wise, there is not a "0.98 frame" physically existing in videos, and the 23.98 fps is just an "estimated/approximate" result that calculated by Windows file properties or the famous MediaInfo tool because for a 23.98 fps video, the duration/interval of each microframe is not all encoded with the same/consistent value. As a result, the frame rate of the encoded video comes with an addition of 0.98 as the average of the frame rate.

In my opinion, no matter the playback fps is shown as 23 fps or 24 fps in the real time, they are all "correct" technically when you are monitoring it in powerdvd.

Does your display monitor support 23.98 Hz screen refresh rate exactly when displaying videos?
Do you adjust your screen refresh rate to 23.98 or 24 Hz in the Windows in advance to make it consistent with the 23.98 fps video?

The tip might help you ease the micro judder if any occurs on the playback because I remembered that powerdvd does not support auto adjusing the screen refresh rate in windows when playing video files.
Mine worked fine on the AI features you've mentioned in photodirector, and it seems no other users here encountered the same problem as you are having now.

IMO, the AI features operate your CPU and GPU to do the image processing, and if the processing caused that the Windows OS crashed at some unknown point, it is probably some of your hardware drivers or OS components did not function properly on the PC so whenever a software try to run AI processing by utilizing your CPU/GPU, the OS crashes down.

Try to find a IT service provider to diagnose your PC from OS perspective might be a faster way to seek solutions instead of just heading to cyberlink.

If a program occurred some issues, it might crash itself down but normally it won't shut down the PC or crash the entire OS directly.
If the symptom does happen, the root cause is usually not the software you used, but some other problems existing on your PC.
I've noticed that you mentioend "I'm working on a virtual encrypted disk".
Are you running Windows on a virtual machine, on a server, or anything else?

If you installed photodirector on a device that does not use virtual encrypted disk, and then copy your old project folders and the source photo files, which you imported in the project, to the platform, does photodirector load and convert your old project fine in this way?

By the way, it seems the virtual copies you created in a project are stroed at your project folder (where the .phd file is located).
It seems the new patch for photodirector 14 has fixed some file path related issues.

How about updating your photodirector via this patch and then re-load your old version project to check out?
The AI style transfer and the "style" tool contain some templates to convert images into paintings in photodirector, but I don't see any templates that are exactly belong to "stable diffusion" style.
Quote Hello,

I received an email advertising new Photodirector features and it also listed AI Anime Face. I looked into Photodirector after updating to the most recent version and I can't find it.
Any help?

Yep, it might take time to find the feature.
It is included in the template packs that located at the Guided > Style tool.

I have updated PhD today with the last version availabale today (14.0.0829.0) and now the problem switched. It works correctly with the status W11 Standard User and stop/crashed with the status W11 Administrator. If I create additional Standard user or Guest, the application fails when I click on Sky replacement for exemple.

I hope no offense.
However, I do not see there are clear benefits if you need to use a Standard user account in Windows to install photodirector and its AI feature, and has needs to use the program between administrator account and standard account.

For a home or personal platform, the default user account that created in windows 10 or 11 is administrator.

Are you in a company or using a platform that has strict operation restriction and needs to operate programs between different user accounts frequently all on a single PC?
Quote Hi. If I play a blu ray pure audio using pcm, I can listen to music at 24 bit/192khz, but if I choose dts I can listen to music only at 24 bit/48khz. Is it possible listening to music with dts and at 24 bit/192 khz? DGG, for example, makes blu ray pure audio at 24 bit/96khz. I tried anything, but without success. What can I do?

Thanks and best regards,


P.S. I use windows 10 pro on a Lenovo thinkpad L5, intel core i7 10th generation with a dac Topping dx3 pro which can arrive at a very high resolutions (for example, 32 bits).

I consider the problem you experienced is relevant with the DRM protection of audio on BDs.

As what I've learned, Hi-res audio of BDs cannot be output in its maximum quality but played in down-sampled rate if you applied a USB DAC devices because of the evil DRM, most of DAC devices that commonly used by audiophiles are not BD DRM audio certified even though they are "Hi-res" certified.

If you would really like to play the Hi-res audio of BD discs in its maximum sample rate, you may use a HDMI home cinema A/V receiver as the audio output, and set the HDMI output mode as non-decoded HD audio mode in powerdvd's settings.

Using a home cinema level A/V receiver (amplifier) is the easiest solution than searching for a certified DAC because there are too many models of DAC customized and relesaed by various and different manufacturers are not specifically designed for the playback of BD DRM audio.

Another solution is that:
Go to find DRM-free version of your audio contents.
As what I've learned so far, from powerdirector 20, it does not contain any licensed NewBlue plugins any more.
The trial use watermark (of the NewBlue plugin) is expected as it is not licensed to powerdirector 21 as what you've mentioned you didn't purchase additional licenses from NewBlue separately to be used in all powerdirector versions generally.

But, it is weird that the program took you 15 times to enter the FX room's 3rd party tab.
After the first time you got in, do you still encounter the hang problem every time whenever you click on the 3rd party tab in the FX room?
I might assume that the transcoding of some of videos that you inserted in the remaining 20% session got hang in the system when burning the disc.

Just try using power2go to produce your project again by creating a BD disc folder on hard drive first, and disable the hardware encoder option on your burning dialog. (Do not burn to a blank disc physically.)

If a video disc folder cannot be produced, I assume that if you try the disc bunring later, it won't complete, either.

A produced BD disc folder can be burned on discs using the burn disc folder tool in power2go.
Go to:   
Powered by JForum 2.1.8 © JForum Team