CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote Hello Scott,

Firstly, thank you Jeff for adding your knowledge & insights into this thread (& all the other threads to which you contribute). It's always much appreciated.

Here, ADR has no problem importing the MP4 you attached. There's no "white box". Do you mean the screen stays frozen & you cannot import the file, or does it disappear & allow import?

PIX


Hi PIX, It stays frozen and I have to click the x to close the white box - the file doesn't import yell
Quote

This was my understanding:
4 channel support in 360° video files for spatial audio, your mp4 only has 2 channels so no real spatial control but should load fine, see attached pic. Additionally, only output to 360° video file, no audio only output.

mono, stereo, 5.1 or 7.1 in WAV files, no 4 channel in WAV files. Your WAV file is 4 channel as I guessed prior.

Format : PCM
Duration : 3 s 791 ms
Bit rate mode : Constant
Bit rate : 4 608 kb/s
Channel(s) : 4 channels
Sampling rate : 48.0 kHz


Jeff


Ahhh ... so AD will only process spatial audio when contained within a video file? That's interesting and unexpected but thank you for the clarification! I will try merging the audio and video in PD first and then attempt to import.

2nd problem - the video file I supplied is confirmed to be 2-channel only, however I still get a white box and you seem to have no problem with it...weird.
Thanks for your help! Cheers, Scott
Quote The mp4 attached does not have spatial audio, it has basic 2 channel AAC audio:

Audio
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 5 s 184 ms
Bit rate mode : Constant
Bit rate : 137 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz

Are you sure it was this file that does not import correctly?

Jeff


BIG APOLOGIES Jeff ... I had only assumed that the OneX recorded in spatial since it was newer than my old VIRB that had spatial. I have just realized that it's only the newer OneX2 that has 4 mics. Sorry for confusion on that point, however it definitely is the same .MP4 that gives me a white box and won't import to AudioDirector.
Do you get any pop-up prompt at all when importing to AD or does it just load fine?
Cheers, Scott
Quote As PIX indicates, a file would be nice, but I suspect the same as here: https://forum.cyberlink.com/forum/posts/list/84249.page#post_box_348281 The Zoom H3-VR manual says it records in 4 channels. This will import into PD as PD is not a unique channel editor, it will not import into ADR unless the new ADR13 has had features added to support, nothing relevant in release notes or manual. You might be able to use the ZOOM Ambisonics Player application for conversion of your audio file to an acceptable ADR format as it can convert to 5.1.

Jeff


Hi Jeff - thanks for your input but I'm pretty sure that AudioDirector has claimed support of 4-channel spatial audio since AD9. The link in my OP describes spatial audio and specifically at the bottom of the page "* AudioDirector 9 supports editing and producing the spatial audio in 4 channels for 360° video files. The feature is not supported for video files that are encoded with 5.1 or above channels audio." I haven't paid any attention as to whether AD now supports 5.1 audio.

The real annoyance for me is that I bought the Zoom microphone years ago when AD9 was current and I'm pretty sure I tested it out with AD at the time with no problem. Now I finally have a project that would benefit from spatial audio and I'm experiencing issues.yell
Cheers, Scott
Thanks for replies - to answer your question PIX, the exact same "format not valid" prompt comes up whether I load the file manually or send it via PD365. Here is a small WAV sample direct from the Zoom H3-VR. Also attached is the smallest .MP4 direct from the Insta360 OneX (after stitching). I'd appreciate hearing whether you guys get the same white box with no information when importing the .MP4 (screenshot attached).


Thx, Scott
Quote I have sent copies of error messages, diagnostic results etc as requested by Cyberlink and the latest request, sent a copy of the WAV file to them for their analysis, just waiting for their reply.



Hi Dave - did you ever get a response to this problem? Experiencing the exact same thing more than a year later and haven't seen a response to my support request. Cheers, Scott
I have CL 365 package and have installed the latest version. Trying to follow tutorial for spatial audio here: https://www.cyberlink.com/support/faq-content.do?id=23357 When I import a video file with spatial audio (recorded from Insta360 OneX), a white pop-up appears while the progress meter stalls in the background. If I click the X to close the pop-up, the progress meter goes away and no file is loaded.

I then tried just importing a spatial audio file (recorded with Zoom H3-VR microphone in Ambix mode). I get an error suggesting the file is broken or unsupported. This exact same file imports fine into Powerdirector and plays in the timeline.
What can I do to get spatial audio working?? Thx, Scott
I was going crazy trying to find any information at all about new "Extended Mask Support: Hide, duplicate, reveal, or modify masks like never before with enhanced keyframe controls."

Went through the help system in detail but no mention of new "linear or hold" options for keyframes.
Finally noticed that the URL launched by F1 help system was still
https://help.cyberlink.com/stat/help/powerdirector/20/win/enu/14_00_00_mask_designer.html

replace the 20 with 21 and now I have the updated info!

https://help.cyberlink.com/stat/help/powerdirector/21/win/enu/14_00_00_mask_designer.html

Hope this helps someone save some time! Cheers, Scott
Four years later, Tony's video helped me since there doesn't seem to be any improvement to nesting projects! At the very least, when you click on Insert Project the option to select Nested or Expended would at least get people to investigate the difference and save a lot of headaches! Thanks for the discussion guys! Cheers, Scott
Hi all - I've successfully created an export profile for my 360 videos following guidelines in the forum however I still don't understand the purpose of many of the settings within profile.ini. I've searched for any reference here but just get examples of what others are using. I'm frustrated because I can get a decent H264 rendering by cranking up the bitrate, but if I ever try to use H265 the rendering time seems to exponentially increase the farther along it gets ... resulting in 8 hrs rendering for a 4 min video (at 5.7K).

I see a number of settings that look like they may offer a variety of file / video formats but have no idea what values are legal. Ideally, I'd love to know what every single node means and all legal settings, but in order to get a decent H265 render I have marked specific inquiries for the gurus:


&
<Class>MPEG-4 HEVC
<Name>My 5.7K H.265 @29.97 80Mbps
<Description>5760 x 2880 H.265 @29.97 80Mbps
<Output FileName>
<DescID>20210 <--- is this just a random ID - does it need to be unique from other profiles?
<NameID>22572 <--- same as above
<Group>2 <--- guessing this is the "Custom Profiles" grouping?
<File Format Class>11 <-- yup, 11 is a great number! but what does it really mean?
<Video Format Class>10 <-- from observation 10 = H265, 8 = H264?? Any other formats just waiting to be coaxed out?
<Audio Format Class>10 <-- sure, we'll go with 10 .... unless 11 sounds better?
<Stream Flag>3 <-- I haven't streamed a Number 3 in a long time
<Field Order>0
<Attribute>4000083 <-- that's a mighty fine attribute you got there! What's it do?
<Video BitRate>80000000 (finally something I understand!)
<Min BitRate>40000000
<Max BitRate>80500000
<Video Quality>0 <-- is 0 a good quality setting??
<Video Width>5760
<Video Height>2880
<Frame Rate>29.969999
<Profile Level>65281
<Pattern>IBPBPBPBPBPBPBPBPBPBPBPBPBPBPBPBPBPBP
<Pre Processing>0
<Resize>1
<Flip Video>0
<Speed Quality Indicator>6 <-- building profile w GUI results in 3(speed) or 6(quality) - if I increase this to 9 what happens?
<Interlacing>0
<Encoder Mode>0
<App Type>2
<Dynamic GOP>0
<Deblock>1
<EntryMode>1
<Encoder Type>32
<Audio Layer>2
<Audio Mode>2
<Audio BitRate>384000
<Audio Channels>2
<Audio SamplesPerSec>1
<Audio BitsPerSample>1
<Misc>0
<SamplesPerFrame>0
&&


Thank you to those who can shine some light and save me hours of experimentation!
Cheers, Scott
Quote

I looked at two different Stabilization tools (one from the Fix/Enhance menu [top of below image] and from the Action Center [on the bottom, with the Advanced {gear} settings showing]), but neither screen shows any other Advanced setting access.



Looking at the keyframe tool from each of these menus doesn't show any "new" settings related to focus/viewpoint. Can you describe or post/attach a screenshot of where you found them?



Weird, my PD version is 17.0.2126.1 and the options appear as shown here:

***SOLVED*** You have to be editing a 360 video for those options to appear - I tried with 2D and options appear as per your screen captures
Quote Two thoughts here.

I agree that the trial version limitations are too restrictive and watermarks would be a better approach.

With that said, I don't think there's actually a 30-day limit to the trial software, which may be why they've chosen to reduce its functionality. I may be wrong about that but I know for a fact that there is a 30-day money-back guarantee when you purchase any software, and the full version has none of the trial versions limitations. So you can buy PD17 (or DirectorSuite365) and try everything out for 30 days and then get a refund if you're not happy.

The second item is that PD17 still only has a 360° starting view setting, so if you're looking to move the focus during uninterrupted play, that feature is still not available. As long as you're willing to put in transitions between active scenes, you can set each individual clip's starting point wherever you want.

Here's an example. Almost every scene has a different starting viewpoint:



Thanks for your response optodata, I actually bit the bullet and am trying the subscription ... happy to report that PD17 does have a way to change focus on the fly ... it's wrapped into the Stabilization tool under "advanced" - that unlocks the timeline where you can insert keyframes and rotate the scene.
Cheers, Scott
I purchased PD16 and have been using for last 6 months for 360 degree videos - pretty good but doesn't allow me to rotate the video over the timeline so still stuck using Premiere. I downloaded trial version of PD17 to see what was new and if it would do what I need. Extremely disappointed to learn that it wouldn't even import my 360 content!

From trial download page:
Other limitations:

Watermark appears on the video
Limited templates and effects
Importing and producing H.264 video files is only supported on
Windows 10/8.1/7 SP1 systems or hardware platforms offering independent
H.264 encoding and decoding
2K/4K resolution H.264 video files are not supported
Importing and producing H.265 video files is not available
Importing and producing Dolby or DTS 5.1ch audio files are not available


So what use is a 30 day trial if it won't allow you to evaluate? Watermarking the output should be enough to stop people from using it for free, no??
Quote Hi Scott -

I'm sure you're seeing what you're seeing, but I'm equally sure I can't replicate that here in PDR16.

I imported 224 360° photos from various cameras - Mission, Gear360, Theta S, Theta V, Fusion, Yi 360, PixPro & Insta360 - about 30% of those were "duplicates" that were edited in PhD9 before import.

I could detect no pinching or distortion at any point in the timeline e.g. unadjusted & adjusted versions of the same 360° photos displayed the same wherever they were placed in the timeline.

N.B. I did not resize any photos before import or use any stretching or CLPV to modify photos.

If you post some screenshots it might make the issue clearer for other members.

Cheers - Tony



***EMBARRASSED*** I got back around to this project and by previewing the source files in a standalone 360 viewer discovered that the source images were the problem - I was harvesting the images from the web and despite exact same capture routine, at some point they were being saved as 330 degrees stretched to equirectangular dimensions. Apologies for making you spend any clock cycles on it.
I have a sequence of 175 equirectangular images that I'm trying to make into a 360 sequence. I've marked them all as equirectangular and they all display the 360 badge in topright corner of thumbnail within media room.

When I add them to the timeline, approximately 70 of them import correctly, then the rest import with a "pinched" nadir resulting in an overall warp to the scene. I have resized all source images to exactly 4096x2048 and tried again -same result (althought the warp doesn't necessarily start at the same scene).

I've tried clearing the timeline and importing images one by one - there's an image number at which they all start appearing warped (again, no hard division i.e. not tied to a specific image). I've even deleted the images from the media library and re-imported just the bad ones ... same result.

I've tried right-clicking the scene in the timeline and setting "Clip Attribute->Set Image Stretch Mode" to "Use CLPV to stretch..." with no change.


Tearing out my hair trying to determine how the program is seeing any difference between the source files.

Please help!
Thx, Scott
Go to:   
Powered by JForum 2.1.8 © JForum Team