CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote It sounds like you project has become corrupted, and your best bet at recovering it is to look in the Auto Save folder for the most recent version that was saved before the problem occurred. The folder location can be found from the Preferences | Project menu. The default locations are shown here.

If you want to share screenshots, save them as JPG or PNG then use the blue and white Attachments button below the forum's text box to upload them here.

TO: optodata Thanks for answering. After I posted this comment I found a simple answer should have been aware of it. In W10 on left side of screen there's a long list of programs, etc. in alphabetic order. Sure enough there was a couple of CyberLink things and one of them was a copy of the same editing program. It only had a few very minor changes that had no effect on what I was doing. Have been using it a few hours already. But I'm printing off your answer and will keep it with my notes just in case.
Yesterday 12/15/2022, I was deleting a few frames and changing some texts. Suddenly a spinning blue circle appeared on my pc screen for a few seconds and then it disappeared along with all the frames. Shortly thereafter, a message from Microsoft appeared on my screen saying something like "a notification has been sent to CyberLink concerning these difficulties".

Today 12/16/2022 when I attempted to access a prior saved version of my edits I was able to work with it for about five minutes and then the spinning blue circle appeared again and everything disappeared.

I have two screenshots. One is the Windows File Explorer page which shows an icon for each PD version I have saved in the past day or two. The other screenshot is what happens when I have attempted to access a PD file. There is only one thing which shows. Its the file name at the top of the screen with no * behind it.

I don't know if or how screenshots can be attached to this message. Please advise.

Quote Hello,

Can you attach some screenshots of your timeline to provide more information to our users? Would help to get a clearer picture on what you are asking with more details.

PowerDirector Moderator

TO: Moderator I think this should not have been posted by me. After further reflection, there is no need to
delete the Timeline2 frames. Guess I don't have an option to delete this. If you do, please go ahead and
delete this topic. Sorry.
Made some changes in selection of video frames which had originally been used. Had to delete them.
But those deleted video frames had Timeline 2 frames containing time duration and video texts
applicable only to them.

QUESTION: How can the delete function be applied to frames that are not on Timeline1?
Quote Ctrl+Z means hold down the control key and then hit the z key and release it. It is that way in the PD documentation.

To: tomasc Don't know why it happened today instead of yesterday when I tried the Ctrl+Z. But today it worked.
Been busy for twenty minutes taking some of the video segments that were many minutes away from the
front of the edit work file and dragging them back to the segments at the front.
Thank you!

Quote Edit/Undo or Ctrl+Z is undo on the keyboard. Default is 50 levels of it.

TO: tomasc I could not activate the Ctrl+Z from my keyboard but it no longer matters. Because trying to restore
the edit work file no longer seems to be an option. I found all the rest of the missing frames. But they were thirty
minutes out from the three minutes of video frames at the beginning of the edit work file. Its weird because the
edit work file had been only twenty minutes long and was so close to completion there was no longer anything to
do which would have lengthened the file. My original thought was to delete all those empty frames to shorten the
distance. But as I found out today, using the Split feature for deleting doesn't seem to work on empty frames.
If you have further thoughts about this I would like to know. Otherwise I plan to restart using the edit work file which
was saved before this one.
Quote Can you post a screenshot of the new timeline? Also you should be able to use Undo to go back to the original content, and it would help to see a screenshot of that too. Use the Attachments button below the forum's text box to upload the JPG or PNG images here.

Also if Undo doesn't work, close the project without saving it and then reopen it

TO: optodata

Undo is something unfamiliar to me. Do you use it only when in Title or Title Designer or neither?
Will send pictures after I receive info about Undo and have used it.

Opened the file this morning and everything was still like it was yesterday evening.
Never heard of this before. Had just finished a few revisions to a blackboard with statements done in white
lettering. Containing info the viewers should know before watching the video. It was ok. Moved to the right a short
distance (perhaps 500 video frames) just checking for anything else needing change. Found an ugly surprise.
Something had happened to the rest of the video. It was broken up into segments of varying length. Separated
from the next segment usually by a long span of empty timeline frames in between.

Nothing has happened to each of the video frames. There are no missing segments of video. Have decided to
fix this. Will take a long time spent in dragging segments back together. Unless someone has answers.

1) Anyone know what I might have done to cause this situation?

2) Is there an edit processing feature which will automatically put numerous separated segments back together?

Quote Sure. Try this: Highlight the clip. Hit the Home key on the keyboard. Expand the Timeline ruler to the maximum by moving the white ball on the bottom left of the screen to the right next to the + sign. Move the scrubber at least 1 frame to the right using the period key. Hit the Split clip button. Highlight that left frame by a Right mouse click and choose Remove and Fill gap and/or move all clips, whichever is the most appropriate for you..

tomasc: not sure what is meant by "highlight" the clip? Clip means the frame I'm trying to get rid of ? Then I'm ready to go ahead and do this. Thanks for your response.

tomasc: Nothing works to eliminate this frame. Taking a closer look at the unwanted frame I have noticed that only about
two-thirds of that frame is visible on the timeline. The edit system does not do anything with it. I have decided to remove
the front two frames Leaving only the actual video frames. Then I will close and save the file. Will read it back in to make
sure there is nothing in front of the video frames and proceed to make a new info frame.
Quote Sure. Try this: Highlight the clip. Hit the Home key on the keyboard. Expand the Timeline ruler to the maximum by moving the white ball on the bottom left of the screen to the right next to the + sign. Move the scrubber at least 1 frame to the right using the period key. Hit the Split clip button. Highlight that left frame by a Right mouse click and choose Remove and Fill gap and/or move all clips, whichever is the most appropriate for you..

tomasc: not sure what is meant by "highlight" the clip? Clip means the frame I'm trying to get rid of ? Then I'm ready to go ahead and do this. Thanks for your response.
Using the answers to my previous message "Texting questions", I created an info frame, using white text on a
blackboard, which viewers read before the video frames start.

Encountered a question.
1) Wanted to make the white text brighter than the original text. Which was accomplished. But then discovered
there was ONE FRAME left from the original text. It is now the first frame of the video. Its address is 00|00|00|00.
Is there a way to delete that frame? Or cause the rest of the whole video to back-up one frame?

2) Looked for a way to eliminate the extra frame by clicking on the Title function but could find no way to
access Title Designer to see if anything there for frame removal.

TO: PD Moderator
Your answers were just what I needed to clear up confusion. Thank you!
Experiencing problems with my first attempt of adding texts to frozen frames after "Title Designer" phase has started.
There are several steps necessary. I don't know the sequence of doing them. Is causing the problems below.

1. Haven't found the way to delete the "My Title" words from the bounding box. Don't want a title.

2. What do you click on first when you want to move the bounding box from the center of Preview to some
other place like a corner?

3. Font type. I want to use Courier New. System usually changes it to some other font type. How to prevent this?

4. Font size. Every time I have entered a number (like15) into the font size the system quickly changes it to
a larger number. What to do to prevent this?

5. What is the purpose of the "T" in the upper left corner of the edit work area? In past attempts I have noted
it will accept only the first line of words in your text. But no additional lines. Why?

Gene Lenz
1) Recently did some video editing on the Timeline. When finished I saved the Project with choice of name and in pds format. A few hours later I opened PD 19 again to do more editing on same edit work file. The edit pgm gave me a notice saying "you have not saved your file. Do you want to save it now?". All of this was on the same day. Why do these notices keep appearing?

2) I have several source files in avi format (from years ago). When the editing project is done, I want the edited files to be in mp4 format. Is format conversion done within the edit program where everything is in pds format? Or must it be done as a separate step after the edited files have been Produced?
Quote Programs like PowerDirector are non-destructive, that is they don't change your original clips.

In order to do this PowerDirector uses a pds file. This file records all your changes as well as the location of the original clips.

So, as soon as you save a new project a pds file will be created in the location you specify.

When you then produce (to avi or whatever) this then creates your finished video.

The advantage of this is you can use your clips again in other projects, or you can go back to the first project and change the edits and produce again for a different look.

Hope this helps.


Phil, thank you for your comments. I'm getting an education on pds.
Original attempt at editing resulted in failure due to my use of pds format on the timeline. Which I did not know at that time being new to this editing business.

My only input source file is avi format. After some editing on the timeline, I closed the file by clicking on the X in upper right corner of edit work area. At that point the system put me back on Windows File Explorer page. At bottom of that page I put in the name for the file and designated avi as the file format.

But what surprised me was the notation "pds" appearing directly under the file name line. After my first time experience above, what gives with this pds business? Its a code for system processing isn't it?

Thank you.

Some further questions.

Yesterday, I noticed a long hard drive address: C:\User\Test\Documents\CyberLink\PowerDirector . What is this address for? Is that where my latest edit file version should be located?

Just to experiment, I tried that. Twice. Yesterday and again today.
Both times when some editing was finished, I put the edit work file name EDWORK01.avi at the end of that hard drive address.

But both times when I attempted to retrieve EDWORK01.avi from that address above, this error message appeared:

"An error occurred while opening this media file in the media library. It may be because the file is broken, an unsupported format, protected video content, or for another reason. Try contacting your video provider for a different video format".

Well, avi is a supported format. My video stuff is not protected content. Doubt two files were "broken" whatever that means.
Two mos ago started this video project. It finally crashed because it was a pds format and I wasn't aware that was a no-no.

Question # 1. Each time you finish an editing session, where in Windows File Explorer should that edit work file be located?

Question # 2. Just to confirm. If "pds" with all the nested inserts should not show on the timeline, avi format is ok on timeline?


If there is no timeline content, then logically there is nothing to Produce and PDR will default to the Create Disc module, where content can be added, organised and burnt to disc.

If you put content into the timeline, the Produce tab should then allow you to choose all the available options.

PowerDirector Moderator

Thank you.
Must have done something when I was "exploring" so now when I click on Produce tab, it goes immediately to "create disc". My choice would be the alternate which is "create file". But it is now grayed out. What sequence of clicks to fix this?
Quote Original restart became to lengthy. Hopefully prior misunderstandings have been resolved. Such as:
1. Did not start the project with the edit system's Produce phase.
2. Not starting with Produce caused edit system to use pds as the starting file format.
3. Did not realize pds format creates many nested inserts.
4. Nested inserts caused edit system to block audio editing which is needed.
5. Mouse double-clicks on Timeline segment to open audio editing failed. Caused system to only "update Thumbnails". ??

Found informative CyberLink article titled "How to convert Cyberlink PD pds video to mp4. (Also applies to avi or other formats).
Seems useful since my source files are all avi format.
My restart will begin with the four conversion to avi steps in the article.

Please respond if you have knowledge this article is outdated or has erroneous info.

-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
10/13/21 7:30 PM Started with first two instructions in Step 1 of the CyberLink article.
1. "Run PD".
2. "Click on File > Open Project in upper left corner".

Opened edit pgm. Clicked on File > Open Project.
RESULT: Notice appeared at center of work area. "You have not saved changes you made to current project. Do you want to save the changes now?".

Question 1 - My input file going into this is the edited output file from my prior editing session. It was saved then. Why does editing pgm say "you have not saved changes........"?

Question 2 - you want to save the changes now"? I clicked on "No". Edit pgm responded with display of Windows 10 File Explorer page showing the edited work file from the prior editing session. Should I have responded "Yes" which would be the second save for the same thing?

After all the mis-cues in Restart # 1, just trying to be ultra-careful and wait until an answer from someone.
Go to:   
Powered by JForum 2.1.8 © JForum Team