CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote <snip> As I wrote in my last post, I think CL's tech support should be called in as the higher level techs have remote diagnostics and critical inside tech knowledge that may point exactly to why you've been unable to work with the ProRes clips, despite the wide range of installations and hardware you've tried.

I hope they can get this figured out for you!


Yeah, me too! I did file a problem ticket with Support, and we have been bouncing messages back and fort for a few days. Hopefully they will be able to figure something to fix the problem.

Today I found out something interesting. If I import any file that is NOT ProRes into the Media Room as the first file, then I can successfully import short ProRes files and edit them. It is not necessary to actually include the non-ProRes file in the edit timeline, it just has to be in the Media Room.

When it comes to rendering, short videos of 2 to 3 minutes in length seem to render OK, but longer videos usually crash about half way though the render process.

Tha plot thickens...

Having fun - hope you are too!

Ralph
Well, I’m back again… I had to put the PD18/ProRes file import problem on the side for a while since work got rather busy.

After some further tests, I decided that regardless of the outcome of the file import problem, the computer I had planned to use was just not going to be fast enough for my needs. So, I broke out the checkbook and hit the Black Friday sales to assemble a new computer.

After some careful shopping and double checking prices, I assembled a reasonably usable machine. It includes an MSI Prestige 570 Creation motherboard, an AMD Ryzen 9-3900X CPU, 64 GB of G.Skill RAM, two Samsung 870 EVO SSD drives for the WIN10 OS and editing, and two WD 8TB hard drives for duplicated backups and archive storage. I retained the Zotac GT-1660-Ti graphics card that I was using in the previous computer. It’s a bit underpowered as compared to the CPU, but it will do for now.

I installed an 850 watt power supply, which is definitely overkill, since at 100% AMD CPU and 100% graphics CPU simultaneously, the total power draw is only 330 VA. But I got the power supply for the same cost as a 450 watt unit, so it works out OK.

I also added a dual fan Noctua NH-U12S CPU cooler, but after some thermal measurements I found that the stock AMD cooler which was supplied with the CPU would have been sufficient. However, the Noctua cooler exhausts the hot air away from the motherboard and RAM, whereas the stock cooler directs the hot air against the motherboard and RAM. Needless to say, I prefer having everything cooler rather than warmer.

The case is a Rosewill THOR V-2, which is on the large end of the size range, but that makes it easier for the four cooling fans to keep things cool and the extra space in the case makes it a lot easier to get at things when I need to work on the computer. I have too many machines around here that are the proverbial “two pounds of junk in a 1 pound box,” so I figured I’d make it easy on myself this time around.

After assembling the computer and running it through some initial tests and setting up the BIOS and hard drives, I installed the latest & greatest version of Windows 10. After checking for all the latest updates, I installed PD18 and registered the program. So far, so good. Now the fun begins…

Using 1080P or 4K files from a GoPro-style camera, I found that the rendering speed ran between 4 to 5 times faster than real time. O joy! Maybe I can get my life back when I am rendering files… Then the dark clouds appeared on the horizon…

Attempting to import any ProRes file results in the same program crash as it did on the other computers. And yes, I did try the import both without and with QuickTime installed, with the same results either way. From this, I conclude that the problem is either within Windows 10 or PD18 and is not CPU hardware specific, as the first computers used Intel CPU’s and the new computer uses an AMD CPU.

Grumble… I guess it’s time to file a ticket with Support or take up basket weaving…

Just for grins, I have attached the DxDiag file from this computer. I don’t see anything wrong that catches my eye, other than the diagnostic reports at the end of the file that report PD has had an app crash. But I don’t know what that’s trying to tell me.

Thanks for reading this ramble.
Quote <snip>
Based on everything you've posted, I do think that updating from Win7 is the best way to go, especially since you were able to get the clips working in PD18 the first time you tried it.


Sorry I haven't posted anything for a couple of days, but business calls and all that...

Anyway, I have done some more testing and here's what I found out.

First, I made a brand new clone of the WIN7 working system.

The cloned WIN7 system runs PD17 and PD18 just file, ProRes files import, edit and produce properly.

Then I cleaned up and uninstalled a barrel full of stuff not related to video editing. That lightened the drive by about 50 GB of files (I told you I had a bunch of stuff on it!)

After the cleaning process, PD17 and PD18s still worked as expected. So far, so good.

Next, I upgraded the cleaned up WIN7 clone drive to WIN10. Testing showed that PD17 works OK as far as importing ProRes files is concerned, but editing is very slow, and producing requires about 4x the run time as it does with WIN7, making PD17 effectively unusable. Unfortunately, PD18 crashes when attempting to import ProRes files.

Next, I installed WIN10 on a brand new drive and installed PD17 and PD18 on it.

Neither PD17 nor PD18 will import ProRes files without crashing the programs.

It appears to me that WIN10 is doing something to the system that causes PD to blow up when encountering ProRes files. Whether Cyberlink can locate and fix the problem is unknown, but I hope that they do.

If anyone is interested in pursuing this further, I will be happy to post the DxDiag files for each of the test systems.

Currently, I am setting up to compare all the loaded system components in each system to see if I can find something that is missing from the WIN10 setups. It's a long shot - and it may not work - but at this point, that's about all I have to go on. In the meantime, I will carry on using my WIN7 setup for video editing.

Ralph
Quote <snip> Since you have the perpetual version, you might want to at least try the hotfix for AVI files just in case it applies to this ProRes issue, too. You can simply delete the new .DLL file and use the original one if it doesn't help.


That did not help, but thanks anyway.

Ralph
FWIW, attached is the DxDiag file for the cloned WIN7 drive after it was upgraded to WIN10.

Ralph
Quote Ralph715, What I would try is install your PD17 version on the Win10 clean box and see if ProRes editing works in PD17 as a debug step. My PD17 on WIN10 also has no issue editing any of your three uploaded files.


Something to consider is that the WIN7 system has been upgraded from PD14 to PD16, PD17, and PD18. I do not know what would happen if I try to install PD17 and then install my stand-alone copy of PD18 which I purchased for the WIN10 computer. Would Cyberlink allow the installation? Would installing the stand-alone PD18 "see" the PD17 installation? Would installing PD17 on the WIN10 machine unregister PD the WIN7 computer which I am using now? I know that upgrades of PD can find the custom effects andf titles from the previous versions, but I don't know if that will happen if I install the stand-alone PD18 on top of the upgrade PD17 version - if '17 will install at all.

Quote PD18 maybe did something at release as was discussed here: https://forum.cyberlink.com/forum/posts/list/80286.page#post_box_330195 and also labeled as new here: https://www.cyberlink.com/support/product-faq-content.do?id=24397&prodId=4&prodVerId=-1&CategoryId=-1 it's just unclear what maybe new means as ProRes has been supported in some aspects for many releases.

Very similar issue with Ninja 2 recorder ProRes files, WIN10 and previous PD version here: https://forum.cyberlink.com/forum/posts/list/50424.page#post_box_265101 not totally clear what resolved in this case either.

Jeff


Yes, thanks, I had already viewed those threads. Unfortunately, they didn't help very much.

All this is rather frustrating for me at this point. I am 81 years old, and have worked with computers and software since about 1971, many years of network experience, SysAdmin, blah, blah.. and realize that sometimes there just is not an easy fix for the problem. I run my own manufacturing business single handed, and am usually short of spare time to troubleshoot stuff that should work as advertised. Grumble... That's why I so greatly appreciate all the help everyone has been sending my way.

Ralph
Quote As a side note, the Win7 driver for your HD 4600 is more than 5 years old! You really should update it from this webpage, and you can download the latest Win10 driver and install it on the other machine from that same page as well.


Unfortunately, attempting to update either machine results in an error messahe rtelling me that the hardware cannot support the new driver. I have tried to update in the past with the same results.

Quote I don't see anything obviously related to the ProRes issue in the remaining details, and the .mov stream handler is exactly the same on my Surface Pro 3 running Win10. Since you have the perpetual version, you might want to at least try the hotfix for AVI files just in case it applies to this ProRes issue, too. You can simply delete the new .DLL file and use the original one if it doesn't help.


I will try that. Thanks.

Quote The thing that stands out in your initial description is that you were able to get PD running correctly when you updated the cloned Win7 drive to Win10, but the fresh Win10 install failed. That's exactly what I experienced a few months ago, but Cyberlink tech support couldn't replicate the problem, even with a copy of my problematic system image. This thread has all the details.


Yes, I had read that thread a week or so ago.

Quote My suggestion is to go back one step and stick with the Win10 upgrade from W7. As long as Win10 can be activated properly, you might even be able to reset the installation and have PD work, but honestly, I would just upgrade and move on.


I see see several potential problems here - first, the WIN7 drive has a LOT of old applications on it. This was set up in 2016, and the OS has not been reloaded since then. The WIN7 machine is my business machine - email, accounting & inventory programs, web editors, all sorts of video edting programs, and a lot of odd machine-specific programs for running hardware necessary to my business. Even if I clone the WIN7 drive and then uninstall most of that stuff and clean up the registry, it will likely still be much less stable than a new installation of WIN10, which seems to handle memory a lot better than WIN7 does.

As for PD18, running a test on the original WIN7 machine, PD18 produced a 19 second ProRes HD video to 1920x1080-30 with a run time of 46 seconds. On the WIN7 drive updated to WIN10, the run time wa 34 seconds. On the clean WIN10 machine, PD18 did the conversion in 29 seconds. That's about 37% faster than the original WIN7 system. I would prefer to use WIN10 if possible for the speed increase.


So many options - so little time... <G>
Quote It may help if you follow the steps in the Read Me Before Posting sticky thread, and attach the DxDiag test results here.


Oops!

Quote There are often enough clues in there to allow one of us volunteers to at least point you in the right direction, if not outright solve the issue. In fact, if you run the test on both machines, we might even find the answer in the differences between them.


Obviously that's a good idea, so I have attached the two DxDiag files to this message. If you would prefer that I post the files as text instead, just let me know and I'll do that in another message.

A side note - The WIN10 computer does have a GTX-1660ti video card installed, but the problem remains if I remove the 1660 and use the mainboard video card same as is in the WIN7 computer.

Also, I want to say that I am MOST appreciative of the time and effort everyone has (and is) putting forth to help me figure this out.

Ralph
Quote I have Apple QuickTime 7.74.80.86 installed on a Surface Pro 3 running Win10 and PD 365 (18.0.2204.0).

I can import all 3 clips and have enabled shadow files (shown by the green icons in the Media Library), and there are no issues previewing or editing them on the timeline:


I don't run PD or QT as Admin, and I don't have any issues whether shadow files are enabled (and create) or disabled.



Thanks for checking the files. I do appreciate the help.

I think the problem is that something is missing or not set up correctly, but I don't know what it is.

I have been using PD since version 14 but have only started using 4K videos since I installed PD17.

I find it "interesting" and somewhat aggrvating that I am having this problem with PD18 on a brand new WIN10 installation, since PD18 works just fine with WIN7 on the same hardware.

Ralph
Quote

By chance did your Win7 box/drive that you updated to Win10 without a clean install have older versions of PD ever installed? It appears your fresh WIN10 install you only loaded PD18 for the failure. I only ask as I had helped a user out several years ago that couldn't import ProRes into his WIN10 PD and the issue sounds rather similar to yours so just seeking a few details.

Jeff



Yes, the WIN7 computer has PD17 still installed alongside the PD18 upgrade. the WIN10 computer is a clean install of PD18, which was a seperate purchase just just for the WIN10 system.

Ralph
Quote Maybe post the location to a sample clip that's not working for you so a few users can see if the issue repeats. Your file is truly Apple ProRes MOV file and not a 4:2:2 MP4 (AVC) clip?

Jeff



An update - if you want to take a look at a sample of the files in question, here is a link to 3 test files in HQ, 422, and LT formats.

https://filedn.com/lLYu7GQm05V4CLoIvC7y464/Apple%20ProRes%20Test%20Files/

(These are on my pCloud Public Folder.)

Ralph
Quote Maybe post the location to a sample clip that's not working for you so a few users can see if the issue repeats. Your file is truly Apple ProRes MOV file and not a 4:2:2 MP4 (AVC) clip?

Jeff


The files come from an Atomos Ninja Assassin recorder. I'm pretty sure they are real ProRes MOV files.

I have tried 3 different versions of QT, none seems better than another.

What did help a bit was to set both QT and PD to Run as Administrator. That lets me import ProRes files - I have to use the menu to import them, drag and drop is disabled when the program runs as admin.

However, after the file has been imported and the shadow file created, just "touching" the imported file with the mouse results in a total lockup of PD once again.

I believe the problem is a disagreement between Windows 10 and Quicktime. If I cannot figure out a fix for this mess, I will have to abandon WIN10 as an OS for PD18 and revert to WIN7 instead, even at the loss of render speed.

Ralph
Quote Might be as simple as missing Apple Quicktime from WIN10 images.

Jeff



Thanks for the excellent suggestion (QT is required, IIRC,) but I had already installed the latest version of QT - no joy. Also tried the Lite version of QT, also with no luck. I did have to install QT on my WIN7 machine to get ProRes files to import.

Maybe WIN10 barfs with QT? Haven't been able to find anything about that possibility so far.

QT on the WIN10 computer will play the ProRes files just fine though... Go figure... Grr!

Ralph
I need help...

I have two licensed copies of PD18, one of which is installed on a Windows 7 computer, and the other is installed on a Windows 10 computer.

Both computers have completely identical hardware.

When using the WIN7 computer and PD18, PD18 imports Apple ProRes files (HD, 422, and LT) with no problem, but on the WIN10 computer, PD crashes as soon as any ProRes file is selected for import. PD just freezes, and must be killed with Task Manager to close it.

As a test, I cloned the WIN7 drive containing PD18 and installed the cloned drive as the boot drive in the WIN10 computer. Running the cloned drive on that machine, PD18 imports and edits ProRes files just fine.

I then upgraded the OS to WIN10 over WIN7 on the cloned WIN7 drive, and found that after upgrading from WIN7 to WIN10, PD18 still handles ProRes files correctly.

I then installed a fresh copy of WIN10 (latest version, fully updated) on a brand new drive and installed PD18 on it.

Guess what?

Yep, PD18 once again refuses to import ProRes files. It just locks up and crashes.

I have searched forums, Googled, Yahooed and Binged until my fingers were worn out, but so far have not found any workable solution. I really want to be able to use the WIN10 computer with PD18 for rendering, since WIN10 seems to run PD18 somewhat faster than does WIN7.

All suggestions are greatly appreciated.

Thanks in advance,

Ralph
Within a few minutes after you purchased PD, you should have received an email from the Cyberlink Online Store.

This email is VERY IMPORTANT - do NOT delete it!

That email messaege has the product key for PD as well as a complete set of clickable links to the download files for your purchase. You can download all the needed files from the links in that email.

Also - after downloading the files, make sure to back them up so they will not get lost or accidentally deleted.

Hope this helps!

Ralph
Go to:   
Powered by JForum 2.1.8 © JForum Team