Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
I can't see it yet either. I contacted customer service--no joy yet.
My update manager shows there is no update (which isn't correct). I'm on version 21.4.2812.0 and I can't update to 21.5 version because it's not showing. My account is paid through April 2024.

Contacted customer service and sent them screenshots. No joy so far.
Option 1 did not work--it just opened the application manager and got the same error.

Option 2 "worked", but when I say worked, instead of normal months where everything could be downloaded and installed in mere minutes, I spent the past HOUR using the search function to first find, then INDIVIDUALLY download each and every new piece of content.

Is this going to be the new normal? If so, what an incredible waste of time... and I never did find the fonts from this month (May) to download and install.

HUGE step backward. Can't imagine what it would be like to do a clean OS install and have to INDIVIDUALLY click on thousands of pieces of content in order to download/install them.

Not happy. At all.
Application manager shows that there is a Spring Stickers pack for PowerDirector 365. When I click on "install" I get the message "Now you can view all these effects from inside PowerDirector/PhotoDirector and download them directly, once you have updated to the latest program versions".

I opened PowerDirector and they are nowhere to be found so I can download them (unless I'm not looking at the right place?).

Got an email for new May content today, and NONE of the new content is showing up in application manger at all.

I uninstalled/reinstalled both application manager and PowerDirector 365--same issues.

Any ideas?
Quote This is a known issue, and the pack is actually installed but the App Manager is out of sync.

Thank you!
All of the new style packs installed with no problem EXCEPT the Van Gogh AI Style Pack. When I press the "Install" button, it downloads, says it's installing, then instead of showing up as "Installed", I get the "Install" button again.

Here is a screenshot.
Quote Please remember to search the forum before posting as most questions have already been asked and answered. This thread has all the known info. If you have any new info or further questions, please respond in that discussion.

I typed both the terms CLToast and CLToastRun into the "search" at the top of the community form and nothing turned up. Maybe if the search worked correctly I would not have posted something that was already discussed.
Noticed programs CLToast.exe and CLToastRun.exe running at startup since the latest PowerDirector update. What are they and are they necessary to run at startup? They are located in the folder C:/Program Files (86)/Cyberlink/Shared Files/CLToast.exe
I updated to the patch that was released in February, so now my PowerDirector Ultimate version is 16.0.2524.0

Now I notice that the patch is no longer on the downloads page.

Is there something wrong with it? Do I need to roll back?
Is there a way in PowerDirector 15 to reset the FX database? I have installed everything, yet I am missing some of the 3rd party plugins.
I contacted customer support, complaining that the beta patch is not sufficient. They replied that a stable patch for Power Director 15 is forthcoming (but no date).

Keep an eye out for it...
Is the PDR15 v3223 patch EVER going to be released, or has it been abandoned??? I'm still using PDR15.
Go to:   
Powered by JForum 2.1.8 © JForum Team