Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
You might want to try this: Please let me know if it works also for PowerDVD 15.
Today the project reached 100 downloads, thank you!

For anyone interested, you can find the source code here:

Please forgive the structure of the code, it was made only as a proof of concept and I did not have much time to spend on this. If you wish to contribute, please let me know.

As for the vertical stretch, I think it should be possible with a few modifications.
I suppose you have higher resolution than 2560x1080. Try changing the resolution in Windows to 2560x1080 exactly. That should resolve the issue you are having. I do not have any screen with such resolution and my laptop would not support it anyway (DisplayPort 1.1 only), so unfortunately I cannot help you with that.
Hi, thank you for the feedback. I do not have PowerDVD 13, but it works with PowerDVD 14 and I hope they had not changed file names that much.
1) Did you copy the loader to the PowerDVD directory in C:\Program Files (x86)\CyberLink\PowerDVD13?
2) There should be PowerDVD.exe in the same folder and when you run it, it should open PowerDVD.
3) When you place PowerDVDLoader.exe into this folder, it should run PowerDVD.exe and wait until you close it, then exit automatically.
You might be interested in this: Please let me know if it works with PDVD 13 as well.
This issue was bugging me for quite a while and because there were no replies and no info whether it will be resolved in some patch, I wrote a small program that takes care of resizing the movie and removing the borders on 21:9 screens.
You can download it here:
Unzip it, run it, run PowerDVD and hit Ctrl + Alt + F to stretch the movie. To disable the stretch, hit Ctrl + Alt + F again. Tested with PowerDVD 14, but it might work with older versions as well. It is provided as is, free of charge and without any warranties of any kind. Let's hope CyberLink adds an option to remove the borders soon and this tool will not be needed. Enjoy!
Here is the result:

Note: If you experience issues with stretching the movie and you have a screen with higher resolution than 2560x1080, try reducing the resolution to exactly 2560x1080. Thanks Jak for finding a workaround!
Thank you for the response - would it be possible to at least enhance the Stretch option to also stretch the picture vertically thus removing the black bars? I mean if it is allowed to stretch the image horizontally, why not vertically? Another option would be to add "Horizontal stretch with fixed aspect ratio" or "Uniform stretch". As you can see above it really does not look good to have such a huge screen with a small picture in the middle and huge black bars on all sides.
Currently, playing Star Wars bluray looks like this:

Notice the black borders on top an bottom as well as those on the sides. Also in bluray playback mode there is no zoom button no matter which type of decoding is selected (software/hardware).
Stretch to fit the screen option stretches the picture horizontally, but it keeps black bars on top and bottom (and deforms the picture so the movie is not watchable in such mode).
Zoom button is present for MKV playback, but so far the only way to play bluray movies on 21:9 screen without the black borders I know about is to rip the bluray to MKV and remove black borders in the process, then play the MKV.
Is the missing Zoom button in bluray playback a bug?
Go to:   
Powered by JForum 2.1.8 © JForum Team