CyberLink Community Forum
Messages posted by: mtsarpilot
Forum Index » Profile for mtsarpilot » Messages posted by mtsarpilot
Author Message
Thanks Nina, it's downloading now. That was simple. I wonder why Cyberlink's Support -> Software Updates page I am seeing here does not let me get there via the obvious path. Oh well, it's on it's way now.

Thanks for the quick reply and URL.

Joel
I am running PD9 version 2330. I've been away from editing for a while so have not updated in a while. I'm about to start a big project and want to update to the latest version. I can't seem to find how to update the software. I would have thought this was obvious, but no-where can I find a menu option to check for updates. Searching the forum it looks like one way is to go into the Help -> About PowerDirector, then select Updgrade and the Update tab to see what's available. But it is all empty, no information shown.

How do I get the bits for 2930 or whatever is latest version?

Thanks,

Joel
Hi All,

Sorry for the diappearance. I took Robert's advice and switch out of .wmv format to solve the problem and missed on advsing that back to the forum. I switched to using the PD9 stock .mp4 profiles and the problem has not occurred. It's possible it may only be a problem with the .wmv profiles.

Workload and travel have kept me from being active on the forum (or doing much editing)

Jason,

Right below the text input window where you are typing and well above the "Preview" and "Submit" buttons there is a blue button entitled "Attachments" that will enable you to attach your dxdiag file.

Joel
Anyone heard from Cap'n Kevin lately? He is usually quite active in helping explain issues, solving problems for folks, etc. and I have not seen him replying on posts in a little while.
I have now confirmed this is a bug in PD9 by running this same sequence on 2 computers of mine and also an independent individual has run the same on their machine and confirmed it occurs as well. This needs to be reported to Cyberlink for their defect list.

To recreate the bug:
- Produce a short video (in this test case, all it took was 3 seconds) and encode using any of PD9's stock MPEG-4 profiles. For the attached files, I used the Standard Quality (though I've confirmed it happens on all three profiles)
- Create a new project in PD9 and use the output of the above step as the source video for this new project
- Produce the video again using the same MPEG-4 Profile and select SVRT

It's just that simple. The first second or more of the video will be grey or scrambled depending on the player. After a few seconds the video finally syncs up. I've attached sample files for reference. As a test, I also uploaded the failed file to YouTube to see if it could decode cleanly and it does not. You can see that video at: http://www.youtube.com/watch?v=QaH7A9onx98

I have numerous longer videos this problem occurs on and it never syncs. The video always appears grey.

Happy Debugging,

Joel
Yup, that has been my experience as well. It has happened to me every time when trying to use SVRT. I switch back to hardware encoding and get a clean video, it just takes a lot longer and the video get another re-encoding pass I presume over time will cause more artifacts to show up.

Is this a known bug in PDR9? Anyone have a workaround? Are others getting SVRT to work?
I created an MPEG-4 High Quality (720p) as my initial rendering. Then from that I was going to just change some audio for a second copy of the movie. The simple thing, use the original output file as an input for a new .pds file, overlay some audio, and let PDR9 render it fast using SVRT since the video is not changing at all. One would think this would be a piece of cake since the input file is one that PDR9 created and the output is of exactly the same parameters. The output file is of the right length and all the audio is there, but the video is a flat grey screen.

Has anyone else seen this? Any clues on how to fix this one?

Thanks,

Joel
Yes, I did exactly as you describe. I created a file. Then created a new project in PD9 in which I put in chapters onto that one file as the only source input. Then rendered the VIDEO_TS from this new project. I think I am just cursed with all the problems I've run into with PD9.
Great, this can solve a big problem. It's a shame so many people have to work around what should be basic functionality in PDR9.

I've installed imgburn - a simple question on it's use - Looking at it it's not obvious which mode to use to create a Video DVD from a VIDEO_TS folder.

Do you use "Build" (Write files/folders to disc) mode and just point it at the VIDEO_TS folder? If so, which of the other fields in the tabs should be filled in? For example, is the label visible when the disc is loaded into a Windows machine the ISO9660 label or the UDF label? Any other fields in the Label tab need to be filled in?

Thanks,

Joel
I am trying to burn my video to DVD which has never been successful through PDR9. PDR9 can generate a folder with the TS_VIDEO but then fails when writing to DVD, latest one is an error EB020BE2

Searching the forum I see lots of complaints about PDR9 not burning, does it ever work? How do you get it to work?

If I want to go to a folder first then burn to DVD, what do folks use to do the DVD writing? I don't care to have to buy yet another program to do what PDR9 is already supposed to do.

Thanks,

Joel
Hi Robert,

My GoPro was on R5. 1920x1080 30fps. I simply dropped the clip on the timeline and cut off the beginning and end short portions, that simple.

I am using WMV 9 highest quality for the output, 1920 x 1080.

Thanks,

Joel
Yes, the odd thing is PDR9 says it completed fine. I've had this problem on a number of occasions with different source files, so it is a generic issue I'm seeing. I've rechecked the directory numerous times to ensure I'm looking in the right place. I can also see the file during creation, then it disappears. 1Nina had a really good observation, the file does not automatically load into the edit interface after creation like files usually do. That would be directory independent.

It only seems to happen on .wmv output files amazingly though.
No, the file does not show up in the edit interface afterwards. By the time I go back to the edit interface the file is long gone. It also only seems to happen on .wmv files, not on other file types.

The original is an MPEG-4, 1920 x 1080, 30 fps file from a GoPro camera.

There should be no funky edit modes like audio in a video track as all I'm doing is an original trim of the captured video to get rid of the excess useless footage. So the only thing on any track is the input video. Ultra simple content.

Merry Christmas to all - and to all a good editing session ...
I'm producing a short video clip, just 40 seconds into a .wmv file at 1920x1080 resolution. PDR9 completed the rendering and says it is done, yet it deletes the output file when it is done. I have an explorer window open and can see the output file during the rendering, then as soon as PDR9 says it is done I see the file disappear. I've run it multiple times, rebooted a few times, changed the name of the file, changed the location of the file, etc., always with the same result.

Has anyone seen this one and have a solution?

I'm running Win XP Pro SP3.

Thanks, and Merry Christmas
No
And the saga continues in my attempts to use this product. I am now attempting to create a DVD and within a minute of starting the burn MotionMenuGenerator.exe crashes. Attached is the failure information.

I have reinstalled the software numerous times, that has not helped.

Has anyone seen this one and have any suggestions?
Just a side note on this issue. When I got this error, it was intermittent, not all the time on a specific clip. It occurred only twice in my weekend of fighting with PD9 on my recent project and at different points in the rendering. Don't know if that helps in any way or just throws in a red-herring but thought I'd offer that tidbit.
I agree, the forum is always helpful. A great group of folks in this forum.

BTW - you can always view your entire project in a single page, no matter how big it is. Right click on the timeline and select "View Entire Movie". PD9 will resize to make it fit. Elements may be tiny, but they are all there. I've been working on a 31 minute project and this worked fine.
As insideously frustrating as this behavior is, to help address your question, yes you can highlight multiple items at the same time.

A couple ways work:

1) Click on the first item, then hold control and click on each of the next items you want. Then they all move together
2) As with many Windows based programs, you can drag a box around all those you want to select and they all highlight together

When the audio track shifted out from time sync with their linked video tracks due to a delete, I found I had to time shift that audio track for nearly my whole project. To do them one at a time would be killer. To address this what I did was reduce the size of the timeline until my whole project was on the screen. Then drag a box around all the audio clips, title tracks items, etc that had shifted to select them all. Right click to Group them. Now zoom back in on the timeline to be able to see down to the frame level and slide one into time sync, the rest move with it thankfully.

Painful, but at least it's a workaround to yet another nasty defect in PD9.
Having just done a project with over 100 Cross transitions, I can tell you DON"T DO IT. Besides the pain in the butt factor, there is one more gotcha. When you insert a transition near the beginning of the movie it takes forever. It defaults to Overlap as you've seen and shortens your timeline. Then when you do the switch, PD9 has to lengthen the timeline again and push everything out. On my computer that took over a minute any time I had to put a transition in.

Just say no unfortunately.
I've been getting that error on a number of occassions as well. Then again, I've been plagued with screwball error after error. With Kevin and Dayfdd's assistance we've determine my computer just does not have the video horsepower to crunch this hard. (see posting http://forum.cyberlink.com/forum/posts/list/14248)

Like my other problems, I always got this error during transitions between video clips. That's when PD9 seemed to have to do the most processing as it was crunching on both the incoming and the outgoing video clip to render them and any affects applied to them, plus how to do the overlap it has to generate on the transitions.

I'd suggest attaching a DxDiag file so Kevin or Dafydd can advise if you have enough video compute capability.

Because I don't, I had to solve the problem another way, painful but it worked. The steps were:

1) Create a copy of my .pds project and in it remove all transitions and all content below this Effects track (i.e. voiceover, audio track, title track, etc., they will all get put back in step 3)
2) Render this in your final format, it will work fine because the extra compute of the transitions is not in there
3) Create another copy of the .pds project, import this new temporary rendering and split up the video clips. In my case Scene Detect did a pretty good job of splitting them out for me. It's important to start with a new copy of your original project so your title track, audio track, etc. all come back and are time sync'd to your video
4) Lay them into a new video track directly below their intended location on the primary video track
5) Slide them up to "Overwrite" the original track. This keeps everything in time sync to the other tracks. Some of the video's may have rendered short by one frame. You have to go in and delete that frame hanging out on video track 1 after the overwrite (part of the pain because you have to find them all, and now your timing to your other tracks is off by 1 frame )
6) Add your transitions back in
7) It will now render ok because the source video clips are in the same format as the final file, thus SVRT can be used and there is far less crunching to be done to render them and the transition along with adding your audio and titles, etc.

This was time consuming and painful, but it got the job done.

Good luck,

Joel
Dafydd,

Attached is a screen snap of my preview options.

I finally got a video to render by removing all transitions so PD9 did not have to compute enhancements on 2 videos while executing a fade transition between them. Then cutting up that resultant video back into the original and putting the fades in so that it calculated fades with no enhancements on. What a royal pain. At least the final render goes faster as it gets to use SVRT for much of the video content, only having to render the transitions and the still photos.

My computer is within the hardware specs of the product, but clearly pushing PD9 to the limits. Cyberlink has not tested their product when it is pushing a computer to it's limits, as it comes up with many many different hangs and failure modes. This is scary for anyone trying to use the product on a moderate powered machine. Most people would not put in the time I have put in to get a resultant video. Very frustrating!

I'm not sure I care to keep using this product unfortunately.

Thanks again for all the help.

Joel
Kevin, Dafydd,

Thanks for both your posts. I've determined the issues always occur during a Fade transition between two videos that have multiple fixes enabled. I've read posting where people are complaining that transitions freeze the last frame and just use it for the outbound transition and 1 frame for the incoming transition until the transition is complete. Fade appears to keep motion going on both clips. Doing all this processing on 2 video streams plus the fade seems to overload the system and all sorts of havoc ensues.

As a last ditch effort to at least get a video out of this project, I'm in the midst of rendering the video without any transitions or other tracks. Then I'll drop that long video stream back into the project, splitting it and inserting a transition at each location. That way PD9 does not have to render all the video with enhancements while also doing the transitions. A major hack, but it should work. Not something I'm willing to do for all my projects though. I'll let you know how this attempt goes.

If this goes well, I'm thinking I'll eventually render a DVD from the resultant MPEG-4 file instead of directly. Will this produce a good quality image on the DVD? I'm guessing so as the resolution will be lower, but there are likely other downsampling effects that could play in. Then again, it's all starting at 1920x1080 and 5MP stills, so the MPEG-4 file is no different than the source video content.

As for the questions you each pose:

Kevin's on driver level, I chose the 5/12/10 version as that is the latest one shown supported on Dell's website. I saw the 10/25/10 version on Nvidia's but wanted to try Dell's most recent tested first. I'll upgrade to Nvidia's most recent and see if there is any difference.

Dafydd's on video input: 1920x1080, 30 fps, 15 Mbit/s

Dafydd's on preview options: I'm not sure I follow what you are asking regarding what my previous options are. Help me better understand that one.

Dafydd's on memory: I noticed last night in the DxDiag that the system is only seeing 2GB of memory. A few weeks ago we changed it to a single 4GB SIMM and I did not even look to see if the system is recognizing it all. I'm thinking the computer has a max of 2GB per SIMM and thus not seeing it all, what a horrible surprise.

It may be that my computer is too light weight to work on HD video. That would be a shame as I'm not in a position to upgrade it

Thanks for all you guy's advise, this is great and far beyond what Cyberlink would ever provide.

Joel
Well, this time it got about 5 minutes into rendering and just stopped. No CES_CacheAgent, nothing, just sat there doing nothing. Not even any CPU usage by PDR9. Yet Task Manager showed the program to be happy (i.e. status of Running).

Off to another reboot. Checked the Preferences and found that although I was selecting Hardware Acceleration in the Produce screen, using hardware CUDA was not enable in the Preferences, so I checked it. That seemed to be my death-nell.

Now PD9 starts up then goes to "Not Responding" once started. After about 3 rounds of this I decided to leave it for an hour. 10 minutes later it showed up Running. What the heck. To confirm this was the cause I went into Preferences and uncheck "Enable NVIDIA CUDA". All was fine. Checked it again and instantly PD9 comes up Not Responding. Took about 10 minutes for it to return to responsiveness.

Maybe my hardware does not support CUDA, but hanging for 30 minutes when it is checked is a bit out of line. It's probably waiting to timeout on some hardware call, but this is absurd.

OK, so now I am about 30 seconds from uninstalling this program permanently and demanding Cyberlink credit back my credit card. I've burned something over 30 hours in the last week trying to get this stuff to work and nothing seems to. Any suggestions?

Joel
Kevin,

Attached is the DxDiag file.

I'll let it run without shadow files, certainly quicker to get up and going that way.

My computer is a 2 year old laptop, good specs at the time, though still 2 years old now, so it is not the fastest machine on the planet. My old tower machine can't even crunch on PD9, I tried and it's on its knees begging for mercy.

Thanks for all the suggestions and help.

Joel
 
Forum Index » Profile for mtsarpilot » Messages posted by mtsarpilot
Go to:   
Powered by JForum 2.1.8 © JForum Team
© 2013 CyberLink Corp. All Rights Reserved. [ Terms of Services | About CyberLink | Contact Us | Privacy Policy | Site Map RSS