CyberLink Community Forum
where the experts meet
| Advanced Search >
Well, I was going to refrain posting in this forum for the time being (I also forgot about it). Largely because I hadn't really had any issues with the waveform generating since my last post in November.

However, as you can probably guess byt the fact i'm posting again, I am still having this issue. This makes it version 15, 16, 17 and 18 I've had this waveform problem. I can over look the instability of the software because PD18 is pretty much exactly what I need in a video editor... its easy and simple but still has many features to play with.

The waveform though, I NEED that to work in order to edit. Maybe not 100% of the time, but more ofdten than not I need to see where the waveform of my commentary.

For some reason, it appears to work once every 24 hours. The first time I use it, it works. If I ever try to edit another video the same day, then it just refuses to ever load the waveform.

None of the discovered work-arounds work anymore either, such as using the Empty Library option. That used to work pretty much every time, but not in PD18 (if you empty the library and save, then open the project, everything actually comes back).

I'm currently trying to edit some RE3 footage. I did some earlier, took about 10-15 minutes for the waveform to appear. No problems, worked fine. Now this time, the second time I'm trying to edit, I've been at it for over an hour but no waveform.

Tried converting the audio file (M4V) to MP3 to see if MP3 was simpler to work with... no effect.
Emptied the library... no effect.
Restarted PowerDirector... no effect.
Restarted Windows... no effect.
Cleared temporary files... no effect.

The video waveform, always works. And THIS is what I just don't understand at all. The video, which is much larger, to the tune of 7Gb, and is presumably more complicated than an audio file, generates it's waveform in LESS than two minutes. Yet the much samller, simpler, lightweight M4V and MP3 takes either 10-15 minutes (or longer) or worst case, never appears at all.

Even weirder, the MKA audio file that MKVExtract creates from ShadowPlay recordings generates it's waveform withint 2-3 minutes. Isn't MKA audio less used and less popular than M4V?

JUST as I finish up typing, what shows up? The waveform. D'oh! Adding the time it took type this, it must have taken a good 80 minutes for that to show up.

And despite the waveform finally appearing, I'm still gonna post this. It took a while to type and I don't want to feel like I wasted that time... so y'all can have something to read.

None of these problems I encounter with PowerDirector will EVER sway me to another video editor. I've tried several... they're all as complicated as the female mind. But PowerDirector is simple... like mens minds, lol.
Quote

I don't have any insight as to how PD actually generates the waveforms, but I don't typically work with MKV files and haven't ever seen PD18 take more than 10 or so seconds to display them.

If you want to share the clip, I'd be happy to test it on my system and see if it takes a long time for the waveform to appear. I have a very fast machine, but it still might be useful to check.

Also, I know you've been burned by this issue many times, but so far, I haven't seen it occur since the PD17 patch was released. While it might still be possible that some combination of clips and projects ends up without a waveform at some point, I believe that CL has finally driven a stake through this bugger's evil heart! cool


Well, the video is just a bog-standard MP4 file, it's not an MKV or anything odd. The audio file is an MKA as that's how the Elgato software does things. No idea why they didn't just opt for MP3 though.

Not sure if you'll really need to test the video file at this point, as it is just a typical MP4 file. Like you, PD18 doesn't take long at all to display the waveform of the video, reglardless of length or file type... but it really doesn't seem to like any audio file.

This does seem to be the case, as I have far less issues with PD18 and waveforms, compared to both PD15 and PD17, which were just a nightmare to use. With any luck, maybe CL has indeed cured this problem once and for all! laughing
Quote

Well at least that explains why you're still seeing the issue. I hope that that there's some way to get that patch applied, as it definitely has the patch for this issue.

It might be because the update is actually to v17.6, and that partial version is what's getting blocked. Here in the US, I see a very cheap PD 17.6 offering on ebay, and maybe that's the best way to get the update...


I did buy, on eBay again just as a cheap stop-gap, PowerDirector 18 Version 18.0.2028.0. Again, I believe it's not eligible for future updates but since it's Version 18 it appears to be more reliable when it comes to generating the waveform.

Though I still have one question: The waveform for video files are generated really quite quickly. I had a 40 minute M2TS file generate the waveform within a minute or two.

However, the 40 minute MKA audio (commentary) file that accompanied it took about 10-15 minutes. Given the audio file is a lot smaller in size, and presumably less complicated, why do audio files, including MP3, take so long compared to a large video file? It takes so long I always get concerned it won't work.
According to my PowerDirector, it's version 17.0.2307.0 Ultimate.

I've tried updating to the latest patch (3005) but it doesn't work, it just tells me I have the wrong version for the update. I know the updates on the CL website do NOT work with 365 versions, or bundled versions, Steam versions etc... but I do not know where I can find stand alone updates to these.

I purchased this off eBay as a lifde-time pre-activated version that was NOT eligiable for future updates. I couldn't really afford the £100 price tag at the moment, so I went with a cheaper approach for now, until I could afford it. I'm guessing the one I bought off eBay isn't exactly on the up and up?

While the Empty the Library option seems to no longer be reliable, I can sometimes... and only sometimes... get it to work if I save the project, exit then re-open. Somewhat hit asnd miss with that though. The MP4 video gets it's waveform faster than the M4A audio I work with, which is strange to me.
Not trolling, I just saw a question and answered it. I was unaware the CL had issued a patch for PD17 to fix the waveform issue.

I tired installing the latest patch but it said I do not have the correct version of PD17 so I can't really test it.
Quote

Has this been sorted out now after about 2 yrs ?

I am having this problem now after doing what Cyberlink suggested on a previous thread


Lol, not even close. A group of us did find out that we can get the waveform to appear if you used the Empty the Library option, saved then re-opened. This seemed to often work.

But this no longer works as well as it used to. Videos seem to get their waveform without a problem, but audio files, including MP3 and M4A no longer generate a waveform. Saving, closing and re-opening fails to work as well. Whatever it is, it just gets WORSE each and everytime.

So to answer your question, NO, CyberLink haven't sorted it out. I'm currently sitting here for 30 minutes waiting for an M4A audio file to generate the waveform, and so far absolutely nothing is happening.

Saved, closed, opened, repeated... over and over. Still waiting, been nearly 35 minutes now. Totally gonna have to move on from PD17 at this rate, it's just never worked the way it's supposed to, which is a shame because it does everything I need it to, without it being overly complicated like some other video editors.

OMG... it just generated a waveform about 40 minutes later!!
Lol... OMG still happening in PowerDirector 17. Some MP3/M4A files will display waveform, others will not. Completely random, no rhyme or reason. Even removing all library items doesn't work as often.

Tried Audio Editor to force the waveform to be generated, thinking that might help... but of course not, how naive of me. The waveform is a VERY important part of my editing. Without a visible waveform, it makes editing nigh-on impossible. Which in turn makes PowerDirector useless to me as a functional product.

It's 2019, 17 versions of PowerDirector later and the simingly simplest task of displaying a visual representation of the audio is still eluding the CyberLink team.

On top of that, it took near as next to 10 minutes just for this webpage to fully load.
Optodata: No anger meant, and I'm not angry at anyone at all. I believe it's just more frustration than anything else. It doesn't seem like it, but I don't like posting these sarcastic posts just to get my frustration across. But I also don't like bumping because I feel as though I'm pushing someone elses more important post down further for my own need.

Actually, selective memory isn't too far from the truth.

It's nice of you to say that about the my waveform post, but i'm positive the community would have figured it out. The people here seem to be pretty knowledgable about PowerDirector, so I'm sure the problem wouldn't have eluded you all for too long.


Moderator Guy: Apologies for the unnecessary post. As I mentioned above, t'was frustration that 10 months had passed without any kind of reply, be it help or someone else with the same issue. I actually forgot about this post until I Googled the problem again and saw my post at the top. Then I saw how much time had passed since.

In all fairness, I do not have much knowledge of PowerDirector, hence a lack of replies on other peoples posts. I don't have anything to add to the community as I'm still learning PowerDirector. Otherwise I'd be more than happy to try and help out others providing I had some useful information.

Sincere apologies to the CyberLink Community for my little... tantrum.
Soooooo... is this the kind of help I can expect for the CyberLink Community Forums? 10 months later and not a single, SINGLE reply to my request for help?

Not even so much as a "I have the same problem" reply?

Wonderful community we have here. Thank you to "everyone" who has assisted me in the matter.
Quote
That actually isn't a bug. In my experience, I see PD constantly checking how many frames remain to be produced and using the current processing speed to estimate when it will be finished. It's very accurate if you have consistant media content, but any time you have a section with lots of transitions, FX, Color corrections, extra video tracks, etc, producing slows way down and the estimated time will start increasing. If the denser section isn't at the end, the estimated time will rapidly decrease once the quicker rendering begins.

ADDED: You can easily see this if you turn on previewing while producing. That way you can connect the slowest parts of production with specific edits in the timeline.


This isn't related to the waveform issue, as it seems that we have found a small workaround. This is instead related to the other issue I mentioned, in that the rendering time keeps increasing.

To what Optodata said in the quote, the render time can increase with transitions, F/X etc. I rendered a 48 minute MP4 into an MP4 file, it only took about 6 minutes. No transitions, text, FX or anything.

I then added a JPG image, lasting 5 seconds, with a crossfade transition of 0.40s into the video. This increased the render time to around 45 minutes!

That's a massive increase for a small image and a very short transition. Is that much of an increase normal behaviour? It honestly doesn't seem right.
All of a sudden, many replies apppear out of no-where.

Before I made any kind of reply, I decided to have a go of this myself and try out Optodata's proposed workarounds.

I was quite excited that it seemed as though a breakthrough have been made in forcing a waveform to generate in a project that would never display it.

So I went through several projects finding an older one that I knew never had a working waveform from the start. So I opened it, and kept an eye on the PDHanumanSVR service that is responsible for the generation of the waveforms.

No surprise then that service was at 0% CPU usage. This meant that PowerDirector was refusing to acknowledge the fact that a waveform was needed.

So I then right-clicked an empty part of the library and selected "Remove All Unused Content..." and re-saved the project. Closed PD17 then re-opened...

And... nothing. No PDHanumanSVR activity, no Wafevorm cache activity and no waveform after 10-15 minutes of waiting. So I currently have no conclusion. It works for some people but not everyone? It works with some projects but not all?

The only thing I have noticed, at least on my end, is that MP4 files tend to load waveforms a lot quicker, instead of the TS files I usually use. I only did one test with this, and recorded in MP4 format instead of TS, and the waveform appeared quicker... well, the fact it appeared at all was surprising.

I will test this more by capturing more footage in MP4 format and seeing how reliable the waveform generation is.

For now, I can't say that Optodata's and Svens findings DON'T work, is just that they just didn't work for me. But may still work flawlessly for others.

EDIT: It seems it may work to an extent. I opened a project without a waveform and saw no activity from anything. Then I tried the "Empty Library" option instead. Saved, exited, re-opened... and the PDHanumanSvr was active and a waveform appeared in less than a minute. So... maybe y'all are on to something.
Sweet moses that is a lot of testing.

Well that's usually further than what I get... I don't even get a 0Kb ~PD_0000.txt file appear in the waveform folder. And that is correct, WHEN it works the txt file, for me at least, often goes to about 4-5Mb in size, at least for the video. The MP3 file would be about 1Mb smaller.

Ah, I actually tried that as well, placing the ~PD_0000.txt file from another project into the waveform folder. I even tried placing the ~PD_0000.txt generated by PD14 into the waveform folder for PD17 (I had PD14 and PD17 installed along side each other). The reason for this is because PD14 would often successfully generate a waveform where PD17 would not, but PD17 ignored the ~PD_0000.txt file created by PD14 and would end up creating it's own.

Yeah, that's pretty much my finding as well. It just seems to be random when it works and it doen't work very often. It'll work once, then if I import another video into the same project (without closing) the waveforms never generate.

In the case of using the Normalize function, I assume you had to place another audio file on to the track, as you canot use Normalize when there is a single audio track. I just tried this myself, with the track I use for the commentary (MP3) and unfortunately it did not do anything. No waveform generated. And when I tried using Normalize for the video track... well, PD17 just went to "Not Responding" for 5 minutes before I had to force quit.

Hm, definitely not reliable. And for some reason, unlike yourself, I cannot for the life of me trigger the waveform. I really just have to wait for it to work. It took me several hours today of constantly closing PowerDirector, restarting PowerDirector, restarting the PC... I even did a clean install of PD17 and it didn't help!!

In other words... PowerDirector is just... a very frustrating mess at the moment.

But all the same, kudos to your testing and findings! I'm impressed.
OK, so still having this annoying and ridiculous problem. When this problem is happening, I noiticed there is absolutely NO activity from the PDHanumanSvr service.

I believe this is responsible for the waveforms (as well as the shadow files) and when it IS working,PDHanumanSvr is using upto 30% of the CPU. When it isn't working it uses none, which is when I can tell it's again broken.

I've restarted my PC, restarted PowerDirector, reinstalled PowerDirector, opened and closed many projects to force it to work... and nothing. I simply cannot get PDHanumanSvr to become active after placing files in the timeline.

Even after importing a new set of files into the same (working waveform) project within minutes of each other, it STOPS working and a waveform for the new files never generates.

If so many have been having this problem, I'm truly perplexed as to why CyberLink has just sat on it for so long, you'd think they'd want to fix the bugs in their software ASAP.
Optodata: Yeah, I read that nVidia had changed something with their latest drivers starting from 416.xx. Hopefully CyberLink will release this wonderful update at some point. Touch wood.

I was wondering whether to roll back or not. I'm a bir OCD when it comes to keeping drivers up-to-date (especially my GPU in case of any perfomrance gains) but if the older drivers help speed up rendering, I'll happily take that over a few fps more. I'll give the driver roll back a go.

Makes sense, I sometimes have videos with several transitions and FX. Not so much colour correction but there's always something like that. To be honest I never would have even noticed this until you mentioned it. And I'll have to give the preview screen while rendering a go.

I did try the method of importing clips into a project that had a previously working waveform but it was no go. Left for a while and still no waveform generated, and no activity in the Waveform cache folder either. Sometimes that only thing that "fixes" this is restarting my PC, then opening PD17 right away and giving it time to generate.

Thanks for all the information!
I got that a bit wrong, it's TS files I use, not M2TS (M2TS is what I render to).

The TS and MP3 files both come from my AverMedia capture device that I use for YouTube. I will probably try to switch the output to MP4 instead of TS and see if that makes any difference.

I also have a new problem concerning the Fast Video Rendering Technology... emphasis on the word "fast" because as of the most recent nVidia update, the feature was disabled. I got it back but now FVRT is a ton SLOWER than if I was to render without it.

For example: a 20 minute video WITHOUT FVRT rendering about 15-20 minutes.
The same video WITH FVRT rendering about 40-50 minutes. Makes sense? Not a bit.

Also!! Anyone else notice the Time Remaining actually keeps going UP rather than down for like 5 minutes? I get that a lot, especially with long videos.

Just throwing these problems in here, I seem to have no end of them with PowerDirector. I swear that the best version of PD I used was way back when I started YouTube was PowerDirector 9.
Optodata: It's not a bad idea to keep tabs on the waveform folder, It let's me know if there's any activity and therefore any chance of a waveform ever appearing.

Same, not all projects are effected. It seems to be random which ones have a waveform and which ones don't. And yep, tried all those ideas to force the waveform to generate. Indeed, nothing works.

I'll give the first method a go once I begin another project, opening a previous project that had a waveform, importing the clips and then see what happens. The other method you mentioned is something that USED to work. Importing the clips into a new project first would often result in a waveform, however that seems to be the case less and less now.

I'll keep you posted on the results.


JL_JL: I forgot about that thread. Seems a while ago. I find it strange that a fix has not been implemented. As several people on here have said, it's odd that PowerDirector can generate a mass of thumbnails for a video however long, but struggles with a waveform even on short videos.

I'll pop the info PDM suggests into here later tomorrow.


Thanks for the help/ideas/suggestions though.
As my title suggests, I have a huge issue regarding the waveforms.

This issue has (for me) been present since PD14 and clearly has not been fixed. Most of the time, after placing a video and audio file into the time line, the waveform never appears... like literally NEVER.

I've left PD17 for hours hoping to eventually see the waveform, but no. Nothing. Nada. Same thing would happen with PD14, 15 and 16. Though to be honest, PD14 was much, MUCH more relaible than the newer iterations.

I've browsed to the Waveform cache folder in Appdata where txt files would appear as the waveform is generated. I do this constantly to see if there is any activity. 8 times out of 10 there is not. Even now as I type this, I'm in PD17 trying to edit a video, minus my waveforms, with the Waveform cache folder open, hitting F5 to see if anything happens. A pointless excersice unfortunately.

I think a good 25 minutes have passed as I type, and still no waveform has appeared. I know that longer, larger videos will take longer but this is just terrible. I absolutely need the waveform to edit my videos, without it I cannot do anything, therefore it is useless.

The videos I use are usually M2TS files, and the audio files are all MP3. PD17 does not have any issues with these files yet fails to display the waveform. And yes, I have Enable Waveforms ticked in Settings.

So, WHY hasn't this problems been fixed when we're already 17 versions in? And how does one go about fixing this? Any why isn't there any activity in the Waveform folder when there totally 100% sholud be? How do I FORCE waveform generation??

What prevents the waveforms from generating in the first place??

I need help with this. This has been on-going for too long, getting each new version of PD hoping it'll be more reliable only to discover... not.

Thanks for any help anyone can provide.
Been having this problem for as long as I can remember, especially with the last 3 versions of PowerDirector. Currently running PD16 on my main PC, and PD14 on another PC.

I'll import a video and an MP3 (audio commentary).. sometimes, depending on the length, the waveform will appear within a few minutes. Other times, the waveform NEVER appears. I can have PD16 open for over 30 minutes and the waveform just refuses to appear.

Even now, I'm editing a video, had PD16 open for 45 minutes or so... waveform? NO WAVEFORM.

Nothing I do helps to force the waveform to generate. Resizing the timeline, opening WaveEditor, nothing whatsoever. The same problem also happens to PD14 on a completely different PC. It can't be PC/hardware related, it has to be a bug in PowerDirector which is still present after all these iterations.

The videos I import are mostly MP4 and TS files. The audio files are usually MP3 and WAV. This problem affects all the filetypes I try. I need the waveform to help me know where I need to edit my videos. Without it, PowerDirector is useless for me. I've been trying to hold off returning to Corel VideoStudio because PowerDirector does what I want and is easy to use.

I think this is definitely something that needs fixing. It is VERY irritating waiting for the waveform to appear only to find it never will.
So I have an issue with SVRT that's really quite bothersome.

I recently rendered a total of 8 videos using SVRT, as I only needed to add a image to the beginning of each video, so I didn't want to spend 20 minutes erndering the entire thing.

For 5 of the videos, SVRT worked great. Rendered each 20 minute video in less than a minute with the added image at the start of the video. The other 3... SVRT only rendered the CHANGE to the video. The image lasts 5 seconds before fading into the video.
THAT is all SVRT outputs, just a 5 second video of the image.

All these videos were rendered in PD16 using the same custom profile I use for all my YouTube videos. They are no different to the other 5 videos that SVRT rendered perfectly.

While rendering, I can see that the full time of the video is being rendered as it goes from 00:00 -> 20:00, so it appears to be processing the full length of the video. But it just isn't.

I then tried SVRT on PD14 that I had installed on another PC and it did the exact same thing. This tells me the videos might be to blame, but I cannot see how when they should be completely identical (only the length is different).

Nothing has changed within PD16 as I ran the SVRT rendering one after the other, doing nothing but editing the videos.

Anyone have any ideas as to why SVRT is only outputting the changes to video rather than the entire video??

UPDATE: Have discovered something strange. nNormally, the image I place at the start of the video is crossfaded into the video that follows it. However, if I REMOVE the crossfade, SVRT renders the video in it's entireity. I have no idea why this is the case as every other video I rendered with SVRT has always had the crossfade in the same position with the same duration. ANSWERS?!
I've just been trying to render an 18 video, with strange results.

I've tried rendering in M2TS with HA enabled, but noticed that the time remaining had jumped from around 50 minutes to 1hr 45m for some reason.

I eventually discovered that the rendering time was increasing because it had actually STALLED. The rendering had just stopped dead and wasn't moving.

The MBs produced, the MBs remaining and the percentage produced hadn't moved for several minutes, indicating the video rendering had indeed halted. It always seemed to stall at 0:58:09... 58 seconds and 9 milliseconds. I also opened Task Manager to check the CPU usage for PDR12.exe, and it had dropped to normal usage. So yes, the rendering, despite still seemingly going, had stopped.

I tried several times just in case it was a one-off anomaly, but nope. Always at the same spot. I checked the video, nothing wrong with it as far as I could tell.

So I rendered WITHOUT the hardware encoder... and... it renders beyond the point where it would normally stall. So I'm guessing there is a (serious?) problem with the hardware encoder, either with PowerDirector 12 or my laptop (or both).
Go to:   
Powered by JForum 2.1.8 © JForum Team