CyberLink Community Forum
where the experts meet
| Advanced Search >
Long shot BUT... is it possible a Win10 update went on your system and you haven't rebooted yet?
I had selection problems in MS Word a few days ago after a W10 went on which was resolved after a reboot.
RE FOLDERS: Nope media room just displays everything you import.
You can show/hide different media types by toggling off/on the media types icons (videos, images, audio) at the top of the window.
If you want to move everything you've imported into ONE folder you have to use Pack project materials.. under the File menu.

IMPORTANT: Be careful about duplicate filenames.
I recently had a scenario where some pictures I had imported pictures from various folders had the same filenames.
This resulted in pictures I had already used in my slideshow being replaced with the duplicates without me noticing until I had produced the project.

I only noticed because the new pictures were stretched so stood out.
This was because they had different dimensions to the ones they had replaced however the slideshow kept the dimensions from the old pictures resulting in the wrong aspect ratio being used.
Took me awhile to track down what was happening as initially I though it was a bug in PD making the aspect ratio go haywire until I tracked it down to duplicate filenames!
Yes that is what I did HOWEVER 1st uninstall all Cyberlink products AND then delete all Cyberlink folders left behind in the Programs folder. Make sure to backup any pds files.
I did this before installing DS365 as I only just noticed the uninstall leaves alot behind.
You could then try reinstalling PD17 again just in case this may resolve it.
If not repeat above and you'll have to go DS365.
I found a 30% discount special till 24th Feb:
For others that may find this thread I could NOT resolve this problem on either my old laptop running PD15 OR on my new laptop running PD17 (both were "perpetual" versions ie NONE subscription versions) despite multiple uninstalls and reinstalls.

The solution was I had to buy PD 17 again by buying "Director Suite 365" (subscription version).
Uninstalled PD17 and reinstalled my previous version PD15 from Director Suit 5.
This was 100% stable on my old Win8.1 laptop but now on my new W10Pro laptop PD15 quit unexpectedly just like PD17.
Gave the same eventlog error (below).
Has anybody else had problems caused by module AEJ_Converter.dll?

Faulting application name: PDR.exe, version: 15.0.3929.0, time stamp: 0x5a7ab45e
Faulting module name: AEJ_Converter.dll, version: 2.0.1.2807, time stamp: 0x552375b4
Exception code: 0xc0000409
Fault offset: 0x000000000001cf30
Faulting process ID: 0x373c
Faulting application start time: 0x01d4c909a8ecda59
Faulting application path: C:\Program Files\CyberLink\PowerDirector15\PDR.exe
Faulting module path: C:\Program Files\CyberLink\PowerDirector15\CESdlls\AEJ_Converter.dll
Report ID: ea963c50-21be-4d11-a826-8a19860b0772
Faulting package full name:
Faulting package-relative application ID:
Completely uninstalled PD17 & GV CODEC.
Rebooted & reinstalled GV CODEC (this time latest version v8.50.1927) then PD17 all using "Run as admin".
Launched PD & prompted to install latest patch which I did then started using PD.
After about 15mins was working in Theme Designer and just clicking a photo when PD unexpectedly quit.
Looked at event viewer and found same error (below) due to faulting module AEJ_Converter.dll.
Anyone else having this problem?

AEJ_Converter.dll version info:
File version 2.0.1.2807
Product name Cyberlink AEJ_Conv Dynamic Link Library
Product version 2.0.1.2807
Size 273 KB
Date modified 27/09/2018 1:06 PM
Language Chinese (Traditional, Taiwan)
Original filename AEJ_Conv.dll

EVENTLOG ERROR:
Faulting application name: PDR.exe, version: 17.0.2514.0, time stamp: 0x5c3c2865
Faulting module name: AEJ_Converter.dll, version: 2.0.1.2807, time stamp: 0x552375b4
Exception code: 0xc0000409
Fault offset: 0x000000000001cf30
Faulting process ID: 0x3158
Faulting application start time: 0x01d4c8fa5b1112a3
Faulting application path: C:\Program Files\CyberLink\PowerDirector17\PDR.exe
Faulting module path: C:\Program Files\CyberLink\PowerDirector17\CESdlls\AEJ_Converter.dll
Report ID: 89523148-1e92-4f16-bc32-f94a6bee4640
Faulting package full name:
Faulting package-relative application ID:
Ok so PD just completed exited without warning (no error/nothing) while just clicking a photo in Theme Designer.
Don't know why I hadn't done this sooner but reviewed Eventlog and found the error below which coincides with the time of unexpected quit.
Googled and searched forum for "AEJ_Converter.dll" but didn't find much.
Does anyone have any info on this error that may help me solve my instability problems?

Eventlog Error:
Faulting application name: PDR.exe, version: 17.0.2514.0, time stamp: 0x5c3c2865
Faulting module name: AEJ_Converter.dll, version: 2.0.1.2807, time stamp: 0x552375b4
Exception code: 0xc0000409
Fault offset: 0x000000000001cf30
Faulting process ID: 0x115c
Faulting application start time: 0x01d4c8cb46bc1e77
Faulting application path: C:\Program Files\CyberLink\PowerDirector17\PDR.exe
Faulting module path: C:\Program Files\CyberLink\PowerDirector17\CESdlls\AEJ_Converter.dll
Report ID: 9a054630-2414-4dbd-9fd0-d3ce1dfc7b34
Faulting package full name:
Faulting package-relative application ID:
When I insert nested projects they appear as additional tabs in the timeline pane.
They ALSO appear in the master project tab as a video/audio clip with a "pds" icon at the bottom left however they CANNOT be edited here, they can only be edited by switching to the nested project tab which btw can NOT be selected if you have the master project timeline locked so must unlock 1st.

If your behaviour is different check your nested project setting in prefs (see attached pic) since it can be changed from the default of "Nested" to "Expanded". I'm not sure what "Expanded" means as there is no doc explaining it and I haven't tried it.
Thanks guys for feedback this is exactly what I was looking for.

CODECS:
Hankster65 do you have any additional CODECS installed?
I have Grass Valley CODEC v7.31.2939 installed as its required to read my source AVI files.
I also had this CODEC installed when I completed a large project using PD15 but did NOT experience any stability probs with that version though was running Windows 8.1 on an older/less powerful laptop at that time.

AUTOSAVE:
NonnyM thanks for the info re autosaves - I will now turn that off since I save so regularly anyway (due to PD crashes) plus when I once used a "recovered" pds file version I found my project had been corrupted but not till a few days latter so lost DAYS worth of work.

BITLOCKER:
My laptop came with Win10Pro and bitlocker was already enabled.
I researched it and found that with modern CPUs it apparently adds very little overhead so left it enabled however since I'm running out of options I will try turning this off however calcs suggest it will take ~9hrs to decrypt my 270GB of used space so will have to do this overnight.
Was not trying to "win" just replying to each issue you raised.
I appreciate your response to my post.

FYI I started a new project today WITHOUT any nested projects and still experienced an unexpected crash while doing something simple in Themes (can't remember exactly what) so am genuinely interested in others experience in regards to PD17's stability..
Are you using 365 version?
I'm using Ultimate version so perhaps that may explain our different experiences.
RE: Not my experience.
Do you use nested projects?
I have 5 nested projects added to my master project which has total runtime of 43 minutes.
I would be interested to know if you and other that may read this post use the nested projects feature.
Please let me know AND if you experience problems or not.

RE: I don't think it would describe a typical user's experience.
I think a "typical" PD User probably wouldn't use nested projects.

RE: Is it possible the issue is at your end, with your system?
Unlikely as it's a brand new Dell XPS 13 9360, Gen 8 i7, 16GB, 512GB SSD with W10 Pro & a VERY clean install of Office and PD17 Ultimate. Have run full Dell diagnositics a number of times and has always passed with no problems detected.
No other crashes or problems experienced outside of PD.
Have been using PD since v13 and NEVER experienced this level of instability with the product.

FYI: I am an IT Infrastructure Architect of some 30yrs experience and have an advanced level of understanding of my hardware and windows OS.
Even after applying the latest PD17 patch (v.2514 PD17) PD is still prone to unexpected crashes AND corruption of your nested projects.

CRASHES DURING SIMPLE TASKS:
I have experienced crashes (the builtin error report window pops up) even when doing the most simple things such as:
1) Changing the duration of a video clip.
2) Changing the volume of a music clip.

LOST NESTED PROJECTS VIDEO CLIPS:
Also be careful as when using nested projects TWICE I have lost all video clips on a nested project tab for no apparent reason.
This means ALL work you have done on the nested project is completely lost since there is nothing left to edit.

BEFORE & AFTER FILES FOR NESTED PROJECT CORRUPTION
For those that may have the knowledge to find the problem in the PDS file I have uploaded the BEFORE/GOOD file to the dropbox URL below .
1) CoolgardieAll11.pds: GOOD nested project called "CoolgardieBaby4" has no problems as all clips are dispalyed.
2) CoolgardieAll11.1.CORRUPT.pds: CORRUPT nested project called "CoolgardieBaby4" now has all clips missing so can no longer be edited.

FYI: I rolled back to CoolgardieAll11.pds and have saved 40 versions since then and so far so good (as far as the corrupt nested project problem) but still get crashes described above however this is concerning as you have to continually check nested project tab clips haven't disappeared as this can happen at anytime.

Dropbox URL: <a>https://www.dropbox.com/sh/oxnu8vcosvv19d6/AADmY5nd3vra5C9v41JmCkgJa?dl=0</a>

(Posting here as I have raised a Support Ticket with CL however they just ask questions as if they haven't even read the support ticket and/or request something that you cannot do like upload your 30GB packed project file as you just don't have the upload bandwidth nor data allowance required).
When installing are installing as Administrator?
...right click installation binary then select "Run as administrator"
See picture.
'RE (NO) SUPPORT:
My experience is exactly the same.
I find it extremely insulting when you make the time and effort providing a detailed support ticket and the response suggests they didn't read it.
My conclusion is they've outsourced the support to a generic support center who know nothing about the product other than what they can find by googling.
Don't waste your time with Cyberlink support.
I've posted many support tickets over the last year's and months and only ever got generic advice often not even related to the problem!
I don't think they can read English.. . Well they certainly can't comprehend it based on their responses.
No not being harsh... my comments are based purely on FACT.
If you can't find the answer in these forums then I'm afraid your stuck.
Although I CAN use PD17 I'm finding it very buggy and crashes often.
I'm also running Win10 Pro 64.
See my post here for details:
https://forum.cyberlink.com/forum/posts/list/0/78477.page#322024
FYI: PD17 STILL UNSTABLE AFTER INSTALLING PATH 2514 (Released 2019-02-10)
Installed the patch, rebooted, no other programs running and after ~1hr of editing a nested project PD started playing a different/wrong clip than the one highlighted on the video timeline.
After I clicked around a few times trying to get the correct clip to play it crashed and the PD error report screen opened.
It asks what you were doing at the time of crash and sends your logs files to CL - I filled it out and submitted.

YOUR WORK IS ALWAYS AT RISK
So once again I lost all my edits but luckily only 15min worth as I'm regularly saving versions and noting the changes in each version which is labourious but necessary due to to PD's unreliability.
I reverted NOT to may last saved version but the one before that as I don't want to risk introducing corruption into my project.
My conclusion is that my work is still always at risk of corruption despite this latest patch.
Hi Tony,
I appreciate your time and effort in doing this to try and replicate my problem.
However I don't think it is caused by a set series of steps so cannot easily be replicated.
Instead I believe it is due to PowerDirector's overall instability/buggyness.
I will explain why I have come to this conclusion.

MY LEVEL OF WINDOWS KNOWLEDGE:
Firstly I would like to point out that I am an IT Professional (Infrastructure Architect) of over 30 years’ experience specialising in Microsoft/Windows type software. I am only making this point so others following will understand that I have an above average ability to diagnose the root cause of Microsoft Windows instability problems however I am HIGHLY aware that even the most experienced IT Pro can overlook something that may be found and solved by people with less experience so I VERY MUCH appreciate EVERYONE’S input and suggestions.

PROBLEM NOT MY HARDWARE OR WINDOWS ENVIRONMENT:
So based on my experience/knowledge I believe my NONE PowerDirector environment (Dell XPS 13 9360 laptop & Windows 10 Pro Operating System) are VERY stable and most likely NOT the cause of my corrupt pds file.
Of course you can never completely rule out these items but my knowledge and logic suggests they are NOT the root cause.
(Optodata kindly reviewed my DxDiag file and pointed out I am not running the LATEST video driver however I rolled back to the previous driver since the latest has a bug plus I'm not getting any issues that suggest a video driver problem).

WHY LOGIC SUGGESTS POWERDIRECTOR IS BUGGY/UNSTABLE:
I've had multiple times (couple of times per week) where PD has just hung in the middle of editing and I could do nothing to make it respond except to reboot my laptop. As I've previously said in this thread when I relaunched PD it offered to "recover" my pds file I accepted the offer and continued my work. I believe THIS (“recovered” pds file) is what was responsible for corrupting my project however the real problem is that this corruption is not immediately evident since you can continue to works for DAYS (as in my case) and not discover a problem unless you check all sub projects.

EXAMPLE OF PD17's BUGGYNESS:
Yesterday I worked on my project for 4hrs and at the EXACT same time my laptop switched to Power Save (due to low battery) PD completely locked up. I waited for 5mins but it remained unresponsive so I was unable to save my latest changes, in fact I could not even ALT+TAB back to PD once I had switched out of it.

GRASS VALLEY CODEC:
The only NONE Cyberlink supplied component I use that could be “blamed” is the CODEC I have to install to read my source AVI files and this is the Grass Valley CODEC v7.31.2939. Yes there is a newer v8.5.0.1927 that I initially installed but rolled back to v7.31.2939 when I 1st started to experience PD17 hangs. I did this because I had previously used the older v7.31.2939 with PD16 for many months on previous projects and NEVER experience PD hangs so at the time thought the newer CODEC might be the cause however now I think it’s just PD17’s buggyness.

HOW I’M WORKING AROUND PD17’s BUGGYNESS:
I’ve actually thought about swapping to different Video Editing software however have invested too much time and effort in my current project to swap at this time but may consider this once finished this project if PD17’s stability doesn’t improve with the soon to be released patch. In the meantime I do this and strongly recommend others also do it to avoid losing their edits:

  1. Do NOT accept PD’s offer to “recover” your pds file when you relaunch after it has hung.

  2. If doing a lot of Fix/Enhance work (like I’m doing with my Super8 film clips) do screenshots of the colour correction settings you apply so you can easily go back and reapply them if PD hangs and you lose your changes.

  3. Keep a small text file open and each time you save your project increment the number suffixed to the filename, copy n paste this filename into the text file along with a short explanation of your changes in that version. This way if PD hangs you can open the last normally saved version (NOT recovered pds) and know exactly what you had last done which makes it easier figuring out what you lost when PD crashed.


Hope this may help other also experiencing problems.
I like PD and would like to keep using it however feel my time consuming edits are "constantly at risk" due to PD hangs which detracts from the enjoyment of using it so unless this is fixed soon I will have to consider switching to another product.

Regards Nigel
To be clear:
My laptop is running ALL latest available drivers without bugs including latest BIOS.
BIOS update you referring to is NOT for my model 9360.

However we have digressed from the actual problem as it has NOTHING to do with my display driver version.
You need to breath out and let go of this one thing... appreciate your responses though 😉
For one you haven't yet updated to PD17 v2514, which has addressed quite a few earlier issues.
I check and force a check EVERYDAY - the bell icon has NOT advised me of an update!
Why not since this is the end User mechanism builtin to explicitly advise of updates!
Where can I get the update from? (NOT beta update)
UPDATE:
JUST checked the updates page and I DO have the latest (NONE BETA) patch available (v.2314) installed.
See here: https://www.cyberlink.com/support/powerdirector-video-editing-software/patches_en_US.html

Where do I get this v2514 update from?
(Again ONLY if NONE BETA else I'm increasing the risk of problems... and I would only do this if there wasa beta feature I wanted OR just happy to be a "unpaid tester" which is a NO for both for me)
Go to:   
Powered by JForum 2.1.8 © JForum Team