CyberLink Community Forum
where the experts meet
| Advanced Search >
Just bought program…keeps crashing!!
Reply to this topic
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
I just bought a 1 year subscription to Power Director for my son for a birthday gift. I was gonna surprise him with it tomorrow. Well, playing around in the program I can't keep it from crashing. Anytime I'm in the sound clips or music section and trying to either preview or even just clicking on certain sound file names, The program will lock up and windows gives me a pop up saying the program is unresponsive. I feel so ticked spending money on this thing and it's crashing already.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
I'm sorry you had such a negative experience. Chances are that something went wrong with the installation, or more likely that there are some problems with Windows on your system that haven't shown up until PD pushed your system hard to do video editing.

Uninstalling/reinstalling is easy to do, and the next steps would be to follow the instructions shown in bold exactly as described in this post to see if they can find and repair any damage to Windows' core files.

If you still need help, you can contact CL Tech Support from this page. If you'd like more help here from fellow PD users, please follow the steps in the Read Me Before Posting guide and attach the DxDiag file so we can see the details of your computer.
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
dxdiag file as requested
 Filename
DxDiag.txt
[Disk]
 Description
 Filesize
82 Kbytes
 Downloaded:
441 time(s)
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Quote I'm sorry you had such a negative experience. Chances are that something went wrong with the installation, or more likely that there are some problems with Windows on your system that haven't shown up until PD pushed your system hard to do video editing.

Uninstalling/reinstalling is easy to do, and the next steps would be to follow the instructions shown in bold exactly as described in this post to see if they can find and repair any damage to Windows' core files.

If you still need help, you can contact CL Tech Support from this page. If you'd like more help here from fellow PD users, please follow the steps in the Read Me Before Posting guide and attach the DxDiag file so we can see the details of your computer.


I also ran the sfc scan in the command prompt. It did say it found errors and fixed them. But when I went back into Power Director I still had the program crash on me when I was clicking around sound clips.

This message was edited 1 time. Last update was at Sep 01. 2021 12:00

Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Quote I'm sorry you had such a negative experience. Chances are that something went wrong with the installation, or more likely that there are some problems with Windows on your system that haven't shown up until PD pushed your system hard to do video editing.

Uninstalling/reinstalling is easy to do, and the next steps would be to follow the instructions shown in bold exactly as described in this post to see if they can find and repair any damage to Windows' core files.

If you still need help, you can contact CL Tech Support from this page. If you'd like more help here from fellow PD users, please follow the steps in the Read Me Before Posting guide and attach the DxDiag file so we can see the details of your computer.


I went through and re-installed the program and I decided to download every sound and transition pack from the manager program. But when I go into PowerDirector, and go into Sound Clips, there are still a lot of clips that weren't downloaded. I started clicking and downloading them one-by-one.....every time I click on this sound clip titled Biyoyon01 the program locks up and I'm forced to close it. Why would just particular sound clips be causing the program to crash?
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
There are 3 specific sound clips that are causing the program to crash anytime I click on these sound clips and try to download them. Biyoyon01, Cat01, and Man Walking. Any time I click on these 3 the program becomes unresponsive and I'm forced to close it. I've downloaded all other sound clips with no issues except these 3.

This message was edited 1 time. Last update was at Sep 01. 2021 13:35

Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Glad you've made progress and thanks for all the details - especially for narrowing down the crashes to those 3 specific sound clips. Can you tell me which packs each of those clips came in?

Also, the nVidia driver for your GTX1080 is almost a year out of date, so you may want to get and install the lastest version (471.96) that was released just yesterday.
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Quote Glad you've made progress and thanks for all the details - especially for narrowing down the crashes to those 3 specific sound clips. Can you tell me which packs each of those clips came in?

Also, the nVidia driver for your GTX1080 is almost a year out of date, so you may want to get and install the lastest version (471.96) that was released just yesterday.


I am not sure of the packs they came in. But now I'm having additional issues. I installed the Power Director program under my windows profile, but I noticed when I log in to my son's profile, PowerDirector doesn't have anywhere near all the sound clips that it does under my profile. Also, when I click to different tabs like the "downloaded" tab I'll get a pop-up saying "the parameter is not correct".

This is getting super aggrevating. Maybe this wasn't the program for us. I don't have the time or patience to solve these constant quirks. It was meant to be a fun birthday gift and it's turning into a nightmare.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
I completely understand your frustration. Using PD from mulitple accounts is always going to cause challenges regarding which clips are available. That's a Windows issue and it's because each person's content (especially downloaded content) will only be accessible to the user account it was downloaded from.

I found all 3 sound clips and don't have any problems placing any of them on the timeline or playing them back, but that leaves you with a tech support issue and it sounds like you may not want to pursue that. If you'd like to open an issue with Cyberlink, they can be reached here.

FYI I'm also seeing "Parameter is incorrect" on my end. That was a known issue back in April that was thought to have been fixed in the most recent patch. However, it's clearly still present and I'll let CL know about that bug.

This message was edited 1 time. Last update was at Sep 01. 2021 14:13

Reply
PowerDirector Moderator
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 1196 Offline
[Post New]
Quote Glad you've made progress and thanks for all the details - especially for narrowing down the crashes to those 3 specific sound clips. Can you tell me which packs each of those clips came in?

Also, the nVidia driver for your GTX1080 is almost a year out of date, so you may want to get and install the lastest version (471.96) that was released just yesterday.


Hi,

On my system the 3 sound clips are here:
C:\Users\Public\CyberLink\Downloaded Audio




On looking at all 3 they are encoded with Fraunhofer IIS MP3 v04.01.02 (fast). A very quick look at other downloaded clips shows that they are not all encoded the same and I didn't see any others with the same encoder. Obviously I haven't gone through every clip but it may point to the problem?

Cheers
PowerDirector Moderator
 Filename
Sound Clip 2 MediaInfo.txt
[Disk]
 Description
 Filesize
1 Kbytes
 Downloaded:
440 time(s)
[Thumb - Sound Clips 1.PNG]
 Filename
Sound Clips 1.PNG
[Disk]
 Description
 Filesize
33 Kbytes
 Downloaded:
9 time(s)

This message was edited 1 time. Last update was at Sep 01. 2021 14:24

Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Quote Obviously I haven't gone through every clip but it may point to the problem?

I noticed that too. Here's a screen recording of what I'm seeing on my end regarding those particular clips and the Parameter is incorrect issue:



Note the second part include two randomly downloaded clips. Buzzer is also a Faunhofer .mp3 while 1001 Nights is a .WAV file.

I've since found that right-click > View Properties works correctly once these clips are placed on the timeline, but in OP's case PD may crash when trying to drag them there.

Also once the Parameter is incorrect message starts appearing, it can be difficult to get PD to display the media contents again, which is exactly what was happening in the original issue I linked to

This message was edited 1 time. Last update was at Sep 01. 2021 14:51

Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
I'm also being told from Cyberlink support that Power Director should be ran under an Admin. I'm sorry but there is no way I'm giving my son admin privileges just to be able to run this program properly. That is ridiculous.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
No, I think what they're saying is that when you install PD, you do it from an account with Admin privileges.

Any standard user accounts will then be able to use the app and download content but they won't be able to make system-level changes, like installing updates or uninstalling PD.

Standard practice, overall.
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
I'm trying to uninstall this entire program. Windows has treated each content pack like it's own program! Do I really have to go
uninstall every one individually? There's like a hundred of them!
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Each content pack is separate so you'll neeed to uninstall them individually, just like you installed them.

EDIT: If you made a Windows System Restore Point prior to installing PD and all related content packs, you should be able to go back to that restore point and all traces of PD would be gone.

This message was edited 1 time. Last update was at Sep 01. 2021 15:20

Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Well thank you all for trying to help me but I think I'm done. I'm uninstalling everything and I'm going to ask for my money back. I'm obviously way in over my head with this program. I just wanted something cool for my son to be able to use that was a little more powerful than the basic video editor that comes with Windows. This program has too many issues from what I'm experiencing and it seems like it is more complicated than I thought. If anyone has suggestions for other programs I would appreciate.
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Quote No, I think what they're saying is that when you install PD, you do it from an account with Admin privileges.

Any standard user accounts will then be able to use the app and download content but they won't be able to make system-level changes, like installing updates or uninstalling PD.

Standard practice, overall.


I tried installing under my admin profile. But a ton of thr sound clips I downloaded were missing when I would run the program under my sons profile. Cyberlink support made it sound like I had to then manually transfer the files to a folder in his profile. I'm just done
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Quote I tried installing under my admin profile. But a ton of thr sound clips I downloaded were missing when I would run the program under my sons profile. Cyberlink support made it sound like I had to then manually transfer the files to a folder in his profile. I'm just done

I think it's easier to simply download the new items while logged into your son's account, but either way works. Be sure to request a refund from customer service so you won't be out any money.
Reply
Skycrapper1 [Avatar]
Newbie Private Message Joined: Sep 01, 2021 00:31 Messages: 11 Offline
[Post New]
Maybe I will try one more time with this program after I've cooled off a bit. I have a support ticket open with Cyberlink. Maybe they can help me figure out why these particular sound clips are causing the program to crash.


out of curiosity, is there a way to get this program to install on a drive other than my C: drive? In the download manager I tried changing the install location to one of my external hard drives which has a lot more space. But it kept saying the folder was invalid, incomplete or write protected. To my knowledge the drive doesn't seem to be write protected so I'm not sure why it won't let me install to another drive
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Sounds like your administrative account might be corrupt or you might have a Windows files/folder permissions issue.

For the first one, try creating a new Admin-level account and see if you're able to do everything without any setbacks. No need to install everything, just see if the App Manager can install to a non-C: drive.

If that's the case, in my opinion it's worth migrating all your docs, videos and photos over to the new account. This article explains some ways to accomplish this. It links to a free tool and also shows easy steps to manually copy a profile in the last post.

Here's another article. Although they're wanting you to buy their backup app, all the listed steps can be done without buying anything and you'll either have repaired your main account or created a new one without the current limitations.

Google/Bing for Windows file & folder permissions to learn how to resolve those specific issues if creating a new account doesn't work.

Basically what I'm saying is there seem to be some pretty significant issues with Windows and these are some fairly quick ways to solve them. You could certainly use the Reset This PC command and get everything working the way it's supposed to, but that often means resinstalling all your apps from the beginning.

I don't think there's any "best" or perfect answer, so I've listed them in terms of biggest bang for the least amount of effort through #%#&^% it and start over - but at some point you should have a fully viable computer.

FWIW my kids are in college now but I know full well what it's like to maintain multiple computers with kids' accounts, and sometimes I had to bite the bullet and stop applying band-aid fixes when too many things stopped working. I hope you can get this resolved with a minumum of additional effort then move on to the more important goal of your son getting to enjoy his b-day gift!

EDIT: I have reported the Parameter is incorrect issue to CL on ticket CS002399607

This message was edited 3 times. Last update was at Sep 02. 2021 00:43

Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team