CyberLink Community Forum
where the experts meet
| Advanced Search >
Just bought program…keeps crashing!!
Reply to this topic
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
Sounds like your administrative account might be corrupt or you might have a Windows files/folder permissions issue.

For the first one, try creating a new Admin-level account and see if you're able to do everything without any setbacks. No need to install everything, just see if the App Manager can install to a non-C: drive.

If that's the case, in my opinion it's worth migrating all your docs, videos and photos over to the new account. This article explains some ways to accomplish this. It links to a free tool and also shows easy steps to manually copy a profile in the last post.

Here's another article. Although they're wanting you to buy their backup app, all the listed steps can be done without buying anything and you'll either have repaired your main account or created a new one without the current limitations.

Google/Bing for Windows file & folder permissions to learn how to resolve those specific issues if creating a new account doesn't work.

Basically what I'm saying is there seem to be some pretty significant issues with Windows and these are some fairly quick ways to solve them. You could certainly use the Reset This PC command and get everything working the way it's supposed to, but that often means resinstalling all your apps from the beginning.

I don't think there's any "best" or perfect answer, so I've listed them in terms of biggest bang for the least amount of effort through #%#&^% it and start over - but at some point you should have a fully viable computer.

FWIW my kids are in college now but I know full well what it's like to maintain multiple computers with kids' accounts, and sometimes I had to bite the bullet and stop applying band-aid fixes when too many things stopped working. I hope you can get this resolved with a minumum of additional effort then move on to the more important goal of your son getting to enjoy his b-day gift!

EDIT: I have reported the Parameter is incorrect issue to CL on ticket CS002399607

This message was edited 3 times. Last update was at Sep 02. 2021 00:43

Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7092 Offline
[Post New]
CL tech support responded and said that they were unable to triggger the issue on their end, which is similar to what happened last time.

They also said they'd responded to Skycapper1's service request and would like to do a remote diagnostic connection to understand what's going on with OP's system. I hope they're willing to go forward
Reply
BadWolf [Avatar]
Member Private Message Joined: Sep 10, 2015 09:45 Messages: 89 Offline
[Post New]
Quote I'm also being told from Cyberlink support that Power Director should be ran under an Admin. I'm sorry but there is no way I'm giving my son admin privileges just to be able to run this program properly. That is ridiculous.


They told me to run the program as administrator also (not just install). They are grasping at straws and have no clue.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team