Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote It sounds exactly like what is noted in the below post about SGX being removed from Intel drivers and Windows in newer updates. Did you update your Windows or Intel driver recently?

They decided to remove SGX from their hardware content protection, so UHD BDs won't play anymore on PCs since it is a requirement.

It also could be that you have two GPUs but somehow the GPU configuration changed to make the main GPU switch to one another, which is not compatible for UHD-BD playback. See this faq:

Maybe provide the requested DXDiag file so we can see if there was a recent update. Also run the CyberLink BD advisor as well for more insight. It also could be something else...


Are you telling me that Intel and/or Microsoft deliberately disabled the playback of UHDs in their latest software "updates"?! That is the most galling, ridiculous thing I've ever heard! That's not a update, that's a downdate, or downgrade!

I'm absolutely furious.

Thanks for the explanation.

The whole reason I use my PC to watch UHDs in the first place is because every 4K player, including Xbox SX, is noisy as hell when the disc is spinning. I would use Leawo Media Prof to make a "back up copy" on my hard drive and watch that with no noise. A Lossless MP4 is, for all intents and purposes, the exact same thing, essentially.
Just a few months ago I was happily using PowerDVD 22 to watch UHD discs but I just tried again today and it no longer works. When I try to play the disc itself I get error code 01003 and when I try to watch a ripped back up copy I just get a black screen.

I don't want to hear how my hardware is not compatible. Just a few months ago I watched the entire Godfather trilogy, The Road Warrior and The Prestige and they all worked fine.

Please can somebody help me?
Go to:   
Powered by JForum 2.1.8 © JForum Team