Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >

Okay, we started it in Safe Mode and it works work and the pictures now load in the timeline - woo hoo - but we have no idea why it is working in Safe Mode - can you enlighten us?

I checked the box and we have 144Hz display.

What should we try next? We have no idea why it will work in Safe Mode, but not regular.

Thanks for having us try this at least so we know it has to be some setting somewhere in the computer that is causing the issue, would that be the issue?

Quote I'd probably try Safe Mode and see if PD17 launches properly there. If so, it could give you some insight into potential conflicts. Is your successful laptop platform using 144Hz display?

Okay, I tried eveything you said. I went to the link you had and downloaded the graphics. That didn't work.

I tried Power Director compatability mode - nothing.

I then tried compatability trouble shoot you suggested - nothing.

I then change to compatible to windows 7 - nothing.

I am still where it is stuck when I open the timeline and it won't load the balloons.jpg and freezes.

Oh, and I did download the BIOS.

So I saw two other posts about this issue but nothing resolved except that it may not work with Windows 11, but one person says it works find on their system.

Got a new laptop and went to my account and downloaded the product and when I open up Power Director and click on TimeLine the screen then just freezes as it is trying to load the media that starts with balloons.

Here is the DxDiag and also pics of the screen where it is frozen.

My other laptop was Windows 10 which I upgraded to Windows 11 and it loads the media balloons on the timeline. So it works on that computer with Windows 11.

I have Power Director Ultra 17 and I also downloaded the 2021 patch.


Did you ever get this resolved as I am having the same issue.



Thank you so much for taking the time to go through this for me. Greatly appreciated. Let me execute all the steps you recommended over the week and will let you know if this was successfull in a week's time.

Aaron - did you ever get this resolved? I am having the exact same issue when I installed on my new laptop. When i get to the screen where I select either timeline, storyboard or slideshow, it crashes.

I am wondering if the Core Isolation is not letting it load, as I had a video capture device I have been trying to load on the new laptop and it will only work if I turn off Core Isolation. However, to turn Core Isolation back on, I have to delete all the files and reinstall - whcih I don't want to do everytime I use Power Director. Core Isolation is part of the Security/Antivirus on the computer, so I don't want to keep it off all the time.


Quote I bought a new PC. It has Windows 11. I have installed PowerDirector 17 but it will not load. It took the registration key and I get to the screen were I can select either timeline, storyboard or slideshow but it then crashes by not loading beyond this screen.

Is there a fix for this to get it to work? Do I need to instal an obscure media file reader or disable something on my PC? Is 17 compatible with Windows 11?

Thanks in advance.

This is the PC I bought if the specs matter:

DELL Inspiron 3910 Desktop PC - Intel® Core™ i5, 1 TB HDD & 256 SSD, Black
Go to:   
Powered by JForum 2.1.8 © JForum Team