CyberLink Community Forum
where the experts meet
| Advanced Search >
Ok false alarm, tried it again just now and it worked.
I got sent a refund link from Cyberlink support, however it doesn't work, the web page the link goes to says:

"Server Error. Error: We are unable to process your request at this time. Please accept our apologies for this inconvenience. Error Number: SYS_000003"

It's been like this for 5 days now, the refund request will expire in 7 days..

I was already out of the 30-day return period, but after contact with Cyberlink support they sent me the refund link. Has anyone else had this problem with the refund link not working? Any way to fix it? Tried multiple browsers.
Yes please support this in the next patch... pretty please
Ok after sending support tickets about it, Cyberlink have now said they have forwarded the problem to their R&D team, so here's hoping it's fixed in the next patch. We'll see....
Yeh we really need Cyberlink to support this. Especially considering PowerDVD 8 Ultra decodes DTS-HD 7.1 tracks in full 7.1. I don't know why they downgraded PowerDVD 9's support for this.

For interpolating, do you mean using Dolby Pro Logic IIx or TrueTheater Surround? In PowerDVD9, when I enable those, I lose Protected Audio Path and audio is downsampled to 48khz/16-bit. Personally I don't want my 5.1 tracks to be upmixed though so I leave it off.
I'm using PowerDVD 9 build 2029 with the Auzentech X-Fi HomeTheater HD, using analog 8-channel outputs to my Gigaworks S750 7.1 speakers. Windows 7.

PowerDVD 9 is limited to decoding DTS-HD in 5.1 channels. I have tested and can confirm that DTS-HD Master Audio 7.1 tracks are output as 5.1, not 7.1.

With my Auzentech card, sound is not downsampled, however what is the point of having a Proected Audio Path if the player cannot decode DTS-HD in 7.1 channels?

Will DTS-HD 7.1 decoding be supported soon?
Bump... anyone else have this problem? 2217a doesn't fix it, the DTS-HD track still doesn't play properly (still has jittery sound).
Using the newest PowerDVD 8 build, Baraka using the DTS-HD Master Audio 5.1 track causes audio skipping every 10 seconds or so. The Dolby Digital track on the same disc has no such problems.

I think it's because it's DTS-HD MA 5.1 24/96, which PowerDVD can't downsample properly :rolleyes: I haven't tested any discs with that particular audio format, no. of channels and bit depth/sample rate, so it seems to be a bug with PowerDVD8. Celine Dion which was the same no. of channels/bit depth/sample rate but Dolby TrueHD had no such problems.

Anyone else with this problem? I'm using X-Fi Titanium 7.1 analog to Gigaworks S750 7.1.
1. Any Blu-ray movie with A B C D functions (eg. I, Robot)
2. Doesn't matter
3. Vista 64, Q6600, 8800GTX
With build 1830, my A B C D buttons still don't work on my official Cyberlink remote. When Cyberlink fixed the Top Menu button they forgot to fix these.

Is the development team aware of this and will it be fixed in the next patch?
3:10 to Yuma has worked fine for me since build 3730.
This issue has NOT been resolved with patch 1622, I still cannot use the Menu button on the Cyberlink BD remote.
Same problem here, it will randomly disappear and the only way to get it back is a complete re-install of PDVD.
Same problem here, the Popup menu for Blu-ray discs no longer works in PDVD8 Ultra.
Well they fixed the problem a few days ago, activates fine now!
Just purchased the newly released PowerDVD 8.0 Ultra, and I can't activate it, when I try to enter in my CD-key that was sent in the email, I get this message:

Processing online activation... please wait.

Your activation key is incorrect.
Please try again (0x80ab000b).

Go to:   
Powered by JForum 2.1.8 © JForum Team