CyberLink Community Forum
where the experts meet
| Advanced Search >
PD14 - asking me to Activate (again)
Reply to this topic
AndrewHGoldenk [Avatar]
Newbie Private Message Joined: Jun 15, 2017 13:55 Messages: 2 Offline
[Post New]
After a Windows update my PD14 is now asking me to re-activate the product before it will let me use the Screen Capture facility. I activated it over a year ago after reformatting my computer. And i've used the Screen Capture in the last year. It DOES NOT offer me the opportunity to enter an activation code when i start the Power Director. Any ideas.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6212 Offline
[Post New]
Sounds like there might have been some corruption during the update. See this post to run two quick tests to see if there's any system damage and the utilities will try to repair anything they find that's wrong.

If there are problems they find but can't fix, you may want to try rolling back the update or using Reset this PC to get a stable install of Windows.

Once everything is ok there, try uninstalling PD14. Accept the offer to remove all personal settings if asked. Run the installer, and this time you should be prompted for the license key.

If you no longer have the original installer, contact customer support as shown in this FAQ. If you have the original installer and get PD14 working, be sure to update it to the final version (4207).
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team