CyberLink Community Forum
where the experts meet
| Advanced Search >
I can't install PhotoDirector 365.
Reply to this topic
n8shift [Avatar]
Newbie Private Message Joined: Aug 20, 2020 08:27 Messages: 19 Offline
[Post New]
I just can't install PhotoDirector 365.

After starting the application mangager it takes many hours (after 8 hours I stopped) and PhotoDirector is still not installed.

In the applications manager (see photos) the installation points PhotoDirector 365 and Director Suite 365 - PhotoDirector change constantly. When one installation point is finished, the other installation point pops up again.

That in constant change, without which PhotoDirector 365 was actually installed in the end.

I am very frustrated and angry.




Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5740 Online
[Post New]
I've never seen anything like that, and certainly the installation shouldn't take more than a few minutes at maximum.

The fisrt thing I'd do is uninstall all the apps and download the latest copy of the App Manager from here. (Note that the link is to the US version, so you'll need to change the location at the upper right if you need a different version).

Next, right-click on the installer and choose Run As Administrator. Do the same thing to the desktop icon when you launch the App Manager to install the apps.

If that doesn't solve the problem, it may be that there are Windows permission problems with the installation folders (default is C:\Program Files (x86)\CyberLink), and often those issues can be corrected by creating a new user account in WIndows.

You can try that to see if it works, and then you may want to migrate your existing settings to the new account if all the installations are successful. This article has more info and links to a free tool to do the migration.
Reply
n8shift [Avatar]
Newbie Private Message Joined: Aug 20, 2020 08:27 Messages: 19 Offline
[Post New]
I loaded the current application manager as you described. Then i deleted all cyberlink applications, completely removed the c: programs / cyberlink folder and then started the application manager. The screen reappeared as I have already posted.

Director Suite 365 - AudioDirector
Director Suite 365 - PowerDirector
Director Suite 365 - ColorDirector
PhotoDirector 365
Director Suite 365 - PhotoDirector

After that I installed all Director Suite 365 applications, with the exception of PhotoDirector 365.

After the installation I can start "Director Suite 365 - PhotoDirector", but no menu reacts to every mouse command. the program is simply dead.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5740 Online
[Post New]
OK. You didn't mention anything about running as Administrator, checking permissions on Windows folders or creating a new user profile. Any or all of those could be at play here.

Since deleting the entire folder structure after removing the CL apps hasn't made any difference, it seems to me that your PC has some significant issues and it's probably a good idea to submit an official support request from this page.

You may also want to try the steps in this post while you're waiting for a response from CL tech support.
Reply
n8shift [Avatar]
Newbie Private Message Joined: Aug 20, 2020 08:27 Messages: 19 Offline
[Post New]
With a lot of trickery I achieved the following success.

I can start "Director Suite 365 - PhotoDirector" in the selection window via express mode Fast processing with click-and-go functions and load a single image. However, no library appears and the menu items are restricted.

But if I start full mode Full functionality in normal UI mode, the main window starts without any function (i.e. completely dead). I can then no longer close this main window.

There must be a conflict somewhere in the program between full mode and express mode.

Is there any way to install the program without the Application Manager and where can I find the program to download?
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5740 Online
[Post New]
Cyberlink tech support are the only people who can help you with that.
Reply
asiagol777 [Avatar]
Newbie Private Message Joined: Oct 18, 2020 03:05 Messages: 1 Offline
[Post New]
Same with my problem, but now it start normally thanks
Reply
n8shift [Avatar]
Newbie Private Message Joined: Aug 20, 2020 08:27 Messages: 19 Offline
[Post New]
Quote Cyberlink tech support are the only people who can help you with that.



yes, the support could help me. I had to delete photo director completely and repair the registry.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team