Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
Quote According to the specs, only the 64 bit version of Windows 7 is supported. You need to have more than 4 GB of ram in the pc to be assured that it is 64 bits.

It's my 64-bit Windows 7 and 4GB Ram.
But anyway, I have resolved the issue. After posting the thread here, I started searching online and came across this useful guide. The tasks which I have done, first I run the program install and uninstall troubleshooter. After doing the tasks properly, the problem got solved. Now I have no longer any issues while installing this and working on it.
Greetings to all, I am encountering a serious issue that I cant seem to solve it anymore. I recently tried to install PhotoDirector on my Windows 7 PC, but after completing the downloading process when I am trying to install this on my PC, I can't do this. Does anyone have any idea about how can I able to fix it? Any kind of help would be highly appreciated.
Go to:   
Powered by JForum 2.1.8 © JForum Team