CyberLink Community Forum
where the experts meet
| Advanced Search >
With the new update patch everything works now. WOW
So now I bought a new LG UHD Blu-ray drive and the result:

PDVD 18 works well
PDVD 19 does not work

Asrock Z390, Intel I9, Windows 10

Harold



Quote Well today I uninstalled PDVD 19 and 18, went to registry and deleted most left over registry keys. just the obvious.
Then deleted all Cyberlink left overs on hard drive.
Then reinstalled Pdvd19, run the program, put in a 4K UHD Blu-ray - and the same not working happens:
Resume - Restart loop.


I do not know what else a Customer is supposed to do !!

PDVD 18 works well.

Greetings, Harold





Well today I uninstalled PDVD 19 and 18, went to registry and deleted most left over registry keys. just the obvious.
Then deleted all Cyberlink left overs on hard drive.
Then reinstalled Pdvd19, run the program, put in a 4K UHD Blu-ray - and the same not working happens:
Resume - Restart loop.


I do not know what else a Customer is supposed to do !!

PDVD 18 works well.

Greetings, Harold




Quote PowerDVD 19 starts loading the 4k UHD disk but only for less than one second then start or resume is displayed again.
While PowerDVD 18 is loading the disk for 5 seconds or more and playing it.

This should be enought information for Cyberlink to pinpoint the problem.

I dont think that this is my DB-RE BU50N problem All is OK with 18 version.

Greetings, Harold





Don't upgrade to 19 jet.
Mine does not work with 4K UHD , 18 is good.
Greetings, Harold

Quote

Hello,
Users are not forced to upgrade to the latest version to continue playing Blu-rays. An update may be requried for your GPU or other device driver, or for PowerDVD.
Please contact CyberLink Technical Support and they will help you to resolve the issue:
https://membership.cyberlink.com/support/service/technical-support.do
Be sure to include the full specs of your computer (DXDiag file) and also which exact discs you are trying to play.
Cheers,
PowerDVD Moderator
PowerDVD 19 starts loading the 4k UHD disk but only for less than one second then start or resume is displayed again.
While PowerDVD 18 is loading the disk for 5 seconds or more and playing it.

This should be enought information for Cyberlink to pinpoint the problem.

I dont think that this is my DB-RE BU50N problem All is OK with 18 version.

Greetings, Harold




Quote PowerDVD 19 still not working with 4k UHD, Cyberlink means because I have Windows 1903 ??
Well PowerDVD 18 works just fine.

Go figure.
greetings, Harold




PowerDVD 19 still not working with 4k UHD, Cyberlink means because I have Windows 1903 ??
Well PowerDVD 18 works just fine.

Go figure.
greetings, Harold



Quote Frankly speaking, your screenshot brings us nothing for a perspective of your issue.

What I can "speculate" from your screenshot is that you connected your PC with multiple monitors.
Then, nothing close to come up a "suggestion" to let you try.

I do understand you could be pretty upset after you paid for something but not able to use it as what you expected.
However, as an end user, it means your might not be an expert of powerdvd nor the engineer who develops the playback features.
If you kicked off the troubleshooting with their technical support, showing a positive attitude to cooperate with them will be helpful to investigate or help the issue you received.
That's what I experienced from the technical support of different companies not only cyberlink.

Cyberlink support helped me sort out many uhd bd playback concerns since this feature came out in powerdvd 17.
Anybody even using version 19 ?

With 4k UHD Blu Ray Movie ??? On a Windows Pc ??
Greetings, Harold
All drivers are updated incl. all Intel I9, motherboard etc. My hardware is all new and for 4k uhd and all works with
Blu Ray player but not drive in the desktop. Cyberlink UHD advisor all green.
Windows 10 newsest version.
Only all my UHD 4k movies do that. Funny thing is that after a few times selecting either restart or start the BD drive does not even gets polled by cyberlink, meaning does nothing, no light blinking.

Support gives me the standard replay not even looking at my submitted screen shots.

Greetings, Harold

Quote It's hard to tell if everything is updated on your platform especially you only checked the driver update via Windows 10's update wizard.

If it is a clean installed windows 10, it means every driver is under raw status even though all "Windows Updates" are applied.
You should provide more hardware info here to let us check it out, or contact cyberlink support for your issue directly.
Clean Win10 install and updated, all drivers updated. Checked registry - no previous Cyberlink found.
Also no other Cybelink on my HD.
Clean install of 19 ultra
Cyberlink adisor all green

Movie Black Panther, 4k UHD Blueray

Will start then displays restart resume - whatever I select - always comes back to resume restart

Greetings, Harold
Updated to newest software, works now
Lots of problems, many movies do not play or get stuck. WALLE does not do a thing. When will they work things out??
All those play good with regular BLURAY players.
thanks, Harold
Go to:   
Powered by JForum 2.1.8 © JForum Team