CyberLink Community Forum
where the experts meet
| Advanced Search >

That behavior is very, very strange. It seems like renaming the clip is a partial workaround that would let you edit .wav clips in WE, but you still can't use it from inside PD. With all of the steps you've taken so far, I hope tech support can get this working for you!

When you see this, please post the CS number you received and be sure to update your ticket with the URL of this thread so that the technician can see everything that's happened so far and can also access your shared pictures and clips.

Here is the enquiry number: CS001990385

Thanks again for your help and I will keep you posted.

What error message (if any) do you get when you try to select an output other than .wav?

Also, what happens if you change the extension on a .wav clip to .wma before importing it into WE? I can open the .wav clip that way and also if I rename it as a .m4a, but .mp3 does NOT work. Let us know what happens when you try.

Typically the file starts to process but the progress bar stops part way through and there is no error message (or file in the folder).
My results are the inverse of yours - if I change a .wav extension to .mp3 it imports, but changing it to anything else produces a failure.
I have just lgged a ticket with Cyberlink as you suggested.
Bedtime for now!

I'm a fellow user like you, and I don't have the answer to why WE isn't working with .wav files on your PC or why a fresh install didn't solve the issue. I don't think there's any benefit in trying another source, as a corrupted disc should either not work at all or else give you clear install error messages, but you can certainly check this page after signing in to see if you can download PD16 and try that version.

And just to confirm, you have updated to the 3424 patch after reinstalling PD, correct?

Please see my reply below - I think we've eliminated the corrupt installer possibility. And yes good point I did forget the patch on one occasion, but unfortunately it doesn't affect the issue I'm having.
Quote You can get a free copy of WaveEditor by downloading Power2Go and try it out with the premium features for a few days. You would then know if your existing copy of WaveEditor is defective.

Many thanks - this was a really helpful suggestion in terms of narrowing the possibilities. I uninstalled the WE which comes with PD16 and installed P2G. I think this is a slightly different version in that it is not PD 'Express' but that is of no consequence - the behavior of the program remained the same which strongly suggests the install from my CD is also good and not the issue here.
Quote Here's another idea: What happens if you open an MP3 with WE, make a simple change like Boost and then use File >Save Track As... and give it a new name like "test.wav"?

Is WE able to convert, process and produce the clip, and can it play its own output? If it's at least able to save the file, then please put that in the Google folder and we could check the details for more possible clues. If it can't produce to .wav, which formats CAN it produce to?

Also, you may want to open a support ticket with Cyberlink. It generally takes a couple of days so you could get that started today.

Curiously, WE will only import .mp3, and will only export as .wav - I will put an example in the drive folder as suggested. It cannot then import it's own .wav because it's .wav! AD9 does not have similar problems..See also my response to tomasc. Many thanks for your continuing interest!

Thanks for the update. The new DxDiag doesn't have the slew of Pinnacle codecs that were orignally installed on your system, but since you still have the problem, they weren't the cause. That's a big item to cross off, though.

I have AD9 on my system and it works with your original clip, just like PD14 and 17 and WE do. Again, it seems pretty clear that we're looking at a codec or configuration issue on your system, the missing piece is why removing Pinnacle and doing a fresh install of PD16 +WE didn't solve the problem.

The other odd thing is that if you look at your source clip with MediaInfo and compare the audio section with my processed .wav version, you'll see that both use PCM, constant bit rate and contain 2 channels, but they're otherwise very different: different codec, reversed bit setting, different bit rate, different sampling rate.

Without digging way down to try and figure everything down deep in WIndows, one thing that you can quickly try is to download and Codec Installer app (the 3rd option on this page).

Pay close attention to make sure you aren't also installing any junkware, then see which codec the app recommends for your source clip. You should also be able to choose a different one that's already installed, and that may do the trick. You can restore your latest system image if anything goes wrong.

Many thanks for this Optodata. I am a bit nervous of playing with codecs which might impact other programs running properly (and I might not even find this out for months!) so I am going to leave this suggestion till next week - I have a friend who is a computer pro (though not an expert in this type of application unfortunately!) and I'll get him to do it for me when he is back on Monday. Meanwhile I did just wonder if there could be any problem with my installs of PD16/WE2 from the CD, and if it could be worth trying an install from another source? I think the box said I am entitled to a download copy but I couldn't find a source on Cyberlink's site. There are no errors flagged when I install but does the installer have some checking process that all the files and registry entries are complete? Also if AD9 can find the right codec why doesn't WE - does AD9 have it's own internal set where WE does not?
Well, I made a system backup and uninstalled Studio 9 and its companion effects program. I also did a registry clean to ensure there were no loose ends. I uninstalled PD16 and WE2, and then re-installed them.

Result: I can find no difference at all. WE continues to load .mp3's happily, but instantly it's asked to load a .wav file the error message pops up.

I then tried loading the trial version of Cyberlink Audio Director 9 which is offered. This worked immediately and did exactly what WE is supposed to do - it imports borth .mp3's and .wav files either from within PD16 or independently.

So why does AD9 work when WE2 doesn't? Any ideas guys?

For info I have put an updated copy of DXDiag in the Google Drive folder.
Quote Thanks very much for the detailed uploads

The good news is that I was able to open your clip in PD14 (which uses WaveEditor), and both programs were able to work with the clip and transfer the audio back and forth after I boosted the level by 12dB twice. I was also able to load the C0002.wav file into WaveEditor independently. See the attached screenshot.

The bad news is that off the top of my head, I'm not sure what's going on with your system. The DxDiag results look normal (although your video driver is from 2015 - latest version is here). However, I see a lot of Pinnacle codecs in there and there's a possibility that their presence is interfering with WaveEditor.

I've uploaded the .WAV file from my testing to this folder, and it will be interesting to see if you can import this version sucessfully or if it also gives you trouble.

EDIT: I have actually attached the screen shot now innocent

Many thanks for your message and the screenshot - I hope I can eventually get the same result om my PC!
So far as I can see, PD16 is fine but WaveEditor Express which installs with it is unable to import any .wav files in any scemario, although it imports and edits .mp3's quite happily. WaveEditor shows as an option in Windows 7 as the default for .wav, and if I make it default and click on a .wav, the program opens but again fails to import, in this case without an error message appearing. Your edited .wav file plays in my other audio programs but again is not imported into WE.
I conclude therefore that we have isolated the issue to WE. There does not appear to be a way to re-install WE except by re-installing PD16 as a whole? I could try this but am unclear that it will make a difference as the initial install appeared to go smoothly and nothing will have changed? I agree that there are a surprising number of Pinnacle files in my system. I have only the one program - Pinnacle Studio 9 (along with Hollywood FX for Studio), which I occasionally use to import and edit video from my old DV camcorder. It came with an associated Firewire card. I'm unclear if PD16 can totally replace this. If so I cuold uninstall it and see whether that resolves any clashes. I don't know if it's possible however to do anything more forensic before trying these rather drastic measures? Any further suggestions welcome! (p.s. thanks for the heads-up on the video driver - I haven't installed this yet as I don't think it's likely to be the problem and don't want to risk confusing things further!)
Quote It sounds like there's an issue with your source clip(s) and/or the way PD is set up and configured on your system.

Two things that will greatly help us help you would be to follow the steps in the Read Me Before Posting thread and post the exact version of PD16 you have along with the DxDiag results; and also to upload a short sample clip to a cloud folder (on OneDrive, Google Drive, etc) and paste the link to it here (If you're comfortable sharing it).

Doing those things should give people here enough info to get you up and running.

OK: PD16 details are 16.0.3424.0, VDE 181119-02

Here is a link to a Google Drive folder:

In it you should find:

The DxDiag file you requested
A video clip
A screen shot of the WaveEditor Import fail
A screen shot with details of an arbitrary .wav file which fails to import directly into WaveEditor
A screen shot of the above file failing to import

Many thanks for you advice and I hope this helps!
I recently purchased PowerDirector 16 for use wioth a Sony AX53 camcorder.
The program seems to function satisfactorily in the editing tasks I need except when I try to use the bundled WaveEditor 2 via theAudio Mixing Room. WaveEditor then opens with a message that the audio tracks could not be imported, and has the import options greyed out so it is unusable. This remains the case even if I extract the audio as a .wav file first in PD16.
If I open WaveEditor independently of PD16, the import options are not greyed, and it will happily imnport and edit .mp3 files. However if I try to import .wav files I get the same error message (these are files that play happily on WMP and VLC). It seems to me that WaveEditor should handle these files (the clue is in the name!).
For info. I am running under Win7 Pro, and Audacity works perfectly. Has anyone else had similar issues?
Go to:   
Powered by JForum 2.1.8 © JForum Team