CyberLink Community Forum
where the experts meet
| Advanced Search >
[PDR16] GM7 3424 Beta Patch Now Available - Adds Support for NVIDIA NVENC Hardware Acceleration
Reply to this topic
PowerDirector Moderator
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 896 Offline
[Post New]
Hi Members,

CyberLink has released a Beta Patch for PowerDirector 16, which will update your PowerDirector to v3424. This beta patch includes a hotfix to add support for enabling NVIDIA NVENC hardware acceleration with driver version 416 or above.

Note: this patch is NOT for the subscription version, OEM versions, UWP versions, volume license, or versions purchased via Steam.

Downloader URL:
Link removed. All these updates and more available here: https://forum.cyberlink.com/forum/posts/list/77855.page

Release notes:
- Adds support for enabling NVIDIA NVENC hardware acceleration with driver version 416 or above.

Cheers
PowerDirector Moderator

This message was edited 2 times. Last update was at Dec 03. 2018 20:05


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4423 Offline
[Post New]
Quote
Release notes:
- Adds support for enabling NVIDIA NVENC hardware acceleration with driver version 416 or above.

Cheers
PowerDirector Moderator

PDM, please consider for the official release of this for PDxx have CL state what the real requirements are. This patch I'm sure will work with pre 416 drivers too. Release 416 or above as stated ONLY depreciated support for a very old SDK implementation which PD was still using. For instance, a pre 416 driver like 398.XX should work just fine with this beta 3424 patch too if a user so desires! An important option for those that might like for instance to have PD17 updates when they come but not necessary run a 416 and above driver.

Jeff
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4423 Offline
[Post New]
None of the 60i formats are supported for NVENC hardware encoding for a RTX2070 and 416.34 drivers for H.264 MKV and M2TS containers.
For instance, default profiles
AVC 1920x1080/60i (24Mbps) is not available for NVENC hardware encoding
AVC 1920x1080/60i (16Mbps) is not available for NVENC hardware encoding
.
.

The 60p formats are supported.

Jeff

This message was edited 2 times. Last update was at Oct 27. 2018 10:11

Reply
blasiusxx [Avatar]
Contributor Private Message Joined: Mar 12, 2011 09:44 Messages: 330 Offline
[Post New]
I think Nvidia has not supported GPU HW Encoding to Interlaced for a long time.

Was not that changed when switching from CUDA to NVENC technology?

It may be that I am wrong. Then please correct me.

Otherwise, the patch works very well for me. All produced videos in Progressive are accelerated by the GPU again. Even with the new hotfix 416.64 of today works the whole.

At least in terms of H.264 and HEVC.

CORRECTION (because i'm wrong): Encoding from HEVC/H.264 to H.264 1920x1080 16MBit/s (and 24MBit/s, too) Interlaced supports GPU Acceleration, HEVC not possible.

GTX1060 with Driver 416.64 and PD16 with this Patch.

This message was edited 1 time. Last update was at Oct 27. 2018 10:01

Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4423 Offline
[Post New]
Quote
CORRECTION (because i'm wrong): Encoding from HEVC/H.264 to H.264 1920x1080 16MBit/s (and 24MBit/s, too) Interlaced supports GPU Acceleration, HEVC not possible.

GTX1060 with Driver 416.64 and PD16 with this Patch.

Your correction is valid, my point was they no longer work with the RTX2070, yes they do work as they did previously with the GTX1070 or as you post, your 1060 or for that matter many Nvidia GPU's, take your pick.

My specific point was these previously available 60i formats are no longer functional for hardware encoding with the RTX2070, 416.34 drivers and this PD16 beta patch 3424.

Jeff
Reply
blasiusxx [Avatar]
Contributor Private Message Joined: Mar 12, 2011 09:44 Messages: 330 Offline
[Post New]
Thank you for the Info. I think RTX Cards very new, they need to optimizie the Software.

Does it work on PD16 without the patch? If PD16 is stable, there will not be any big updates for it anyway, and they're focusing on PD17.

Maybe it works with today's 416.64 driver?!?
If not, then I would install the last patch over it, and test again.

I will not buy any RTX anyway, if that's right here ...
https://devtalk.nvidia.com/default/topic/1038493/video-codec-sdk/details-about-nvenc-in-turing-/1

But this is OT.

Good Luck.
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4423 Offline
[Post New]
Quote Thank you for the Info. I think RTX Cards very new, they need to optimizie the Software.

Does it work on PD16 without the patch? If PD16 is stable, there will not be any big updates for it anyway, and they're focusing on PD17.

Maybe it works with today's 416.64 driver?!?
If not, then I would install the last patch over it, and test again.

I will not buy any RTX anyway, if that's right here ...

But this is OT.

Yes, way OT but I didn't see anything there that I wouldn't try the RTX2070 with PD.

My purpose of the post since this is a CL Beta Patch post and more than likely a monitored more than normal thread, was to let CL know of the 60i shortfall so they can possibly consider for their PD17 correction when released and perhaps the official PD16 release.

Jeff
Reply
Matt.777 [Avatar]
Newbie Private Message Joined: Jun 05, 2018 08:43 Messages: 14 Offline
[Post New]
Hi all,

This patch DID work perfectly, it now does not, option is greyed out, I reinstalled the patch and still not allowing me to select the FAST VIdeo Rendering Technology, this made an amazing difference in my Video Rendering times.

Please see attachments, which includes DxDiag, I have no issues running PD16 With my Hardware etc either, plus this is a newly formatted Win10Pro install

Any ideas folks?
 Filename
DxDiag.txt
[Disk]
 Description
DxDiag
 Filesize
74 Kbytes
 Downloaded:
286 time(s)
 Filename
Untitled.jpg
[Disk]
 Description
Screenshot of PD16 and issue outlined in yellow
 Filesize
500 Kbytes
 Downloaded:
15 time(s)
Reply
Matt.777 [Avatar]
Newbie Private Message Joined: Jun 05, 2018 08:43 Messages: 14 Offline
[Post New]
Quote Hi all,

This patch DID work perfectly, it now does not, option is greyed out, I reinstalled the patch and still not allowing me to select the FAST VIdeo Rendering Technology, this made an amazing difference in my Video Rendering times.

Please see attachments, which includes DxDiag, I have no issues running PD16 With my Hardware etc either, plus this is a newly formatted Win10Pro install

Any ideas folks?


To add to this it definitely something in the profile thats not allowing me to use it, heres the profile

&
<Class>MPEG-4 AVC
<Name>2K @ 60FPS - 80000 BITRATE
<Description>2K @ 60FPS - 80000 BITRATE
<Output FileName>
<DescID>11920
<NameID>11983
<Group>2
<File Format Class>11
<Video Format Class>8
<Audio Format Class>10
<Stream Flag>3
<Field Order>0
<Attribute>10040083
<Video BitRate>80000000
<Min BitRate>60000000
<Max BitRate>80500000
<Video Quality>0
<Video Width>2560
<Video Height>1440
<Frame Rate>60.000000
<Profile Level>65380
<Pattern>IBBPBBPBBPBBP
<Pre Processing>0
<Resize>1
<Flip Video>0
<Speed Quality Indicator>6
<Interlacing>0
<Encoder Mode>0
<App Type>2
<Dynamic GOP>1
<Deblock>1
<EntryMode>1
<Encoder Type>32
<Audio Layer>2
<Audio Mode>2
<Audio BitRate>384000
<Audio Channels>2
<Audio SamplesPerSec>1
<Audio BitsPerSample>1
<Misc>0
<SamplesPerFrame>0
&&

It definitely worked before but not it is not, below is the media info from a previously rendered file using this profile:

General
Complete name : E:\FINAL VIDEO\VIDEO 13.mp4
Format : MPEG-4
Format profile : Sony PSP
Codec ID : MSNV
File size : 13.8 GiB
Duration : 25mn 0s
Overall bit rate : 79.2 Mbps
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Format settings, GOP : M=3, N=13
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 25mn 0s
Source duration : 25mn 0s
Bit rate : 78.8 Mbps
Width : 2 560 pixels
Height : 1 440 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 60.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.356
Stream size : 13.8 GiB (100%)
Source stream size : 13.8 GiB (100%)
Language : English
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
mdhd_Duration : 1500394
Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 25mn 0s
Source duration : 25mn 0s
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 68.7 MiB (0%)
Source stream size : 68.7 MiB (0%)
Language : English
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
mdhd_Duration : 1500392
Reply
Matt.777 [Avatar]
Newbie Private Message Joined: Jun 05, 2018 08:43 Messages: 14 Offline
[Post New]
Quote


To add to this it definitely something in the profile thats not allowing me to use it, heres the profile

&
<Class>MPEG-4 AVC
<Name>2K @ 60FPS - 80000 BITRATE
<Description>2K @ 60FPS - 80000 BITRATE
<Output FileName>
<DescID>11920
<NameID>11983
<Group>2
<File Format Class>11
<Video Format Class>8
<Audio Format Class>10
<Stream Flag>3
<Field Order>0
<Attribute>10040083
<Video BitRate>80000000
<Min BitRate>60000000
<Max BitRate>80500000
<Video Quality>0
<Video Width>2560
<Video Height>1440
<Frame Rate>60.000000
<Profile Level>65380
<Pattern>IBBPBBPBBPBBP
<Pre Processing>0
<Resize>1
<Flip Video>0
<Speed Quality Indicator>6
<Interlacing>0
<Encoder Mode>0
<App Type>2
<Dynamic GOP>1
<Deblock>1
<EntryMode>1
<Encoder Type>32
<Audio Layer>2
<Audio Mode>2
<Audio BitRate>384000
<Audio Channels>2
<Audio SamplesPerSec>1
<Audio BitsPerSample>1
<Misc>0
<SamplesPerFrame>0
&&

It definitely worked before but not it is not, below is the media info from a previously rendered file using this profile:

General
Complete name : E:\FINAL VIDEO\VIDEO 13.mp4
Format : MPEG-4
Format profile : Sony PSP
Codec ID : MSNV
File size : 13.8 GiB
Duration : 25mn 0s
Overall bit rate : 79.2 Mbps
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Format settings, GOP : M=3, N=13
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 25mn 0s
Source duration : 25mn 0s
Bit rate : 78.8 Mbps
Width : 2 560 pixels
Height : 1 440 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 60.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.356
Stream size : 13.8 GiB (100%)
Source stream size : 13.8 GiB (100%)
Language : English
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
mdhd_Duration : 1500394
Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 25mn 0s
Source duration : 25mn 0s
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 68.7 MiB (0%)
Source stream size : 68.7 MiB (0%)
Language : English
Encoded date : UTC 2018-10-30 14:50:53
Tagged date : UTC 2018-10-30 14:50:53
mdhd_Duration : 1500392



Its now saying this:

see screenshot
 Filename
Untitled.jpg
[Disk]
 Description
 Filesize
487 Kbytes
 Downloaded:
22 time(s)
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team