CyberLink Community Forum
where the experts meet
| Advanced Search >
Deleting "Play with Cyberlink PowerDVD" from Right-Click Context Menu
Reply to this topic
BobT [Avatar]
Newbie Private Message Joined: Jan 29, 2014 17:35 Messages: 7 Offline
[Post New]
Bloody ell, you guys make me rage with this.

To remove "Play with Cyberlink X" (where X is the version no) from right-click context menus:

Start, Run, "Regedit"

Edit, Find, "PowerDVDXCommandVerb" (again where X is the version)

Delete that key. Have to do this for ALL file types, argh.


The even more ragier thing, I installed a patch to PowerDVD13, which then re-set all the default media file types to PowerDVD, AND put the stupid item back in my context menu for everything! If I take it OUT and change things back to what I want to use, a program shouldn't just go and put it all back again!

Make this an OPTION during installation AND patches please, and stop polluting my registry and taking over default file types! When I want to run PowerDVD, I will click my shortcut and run it, I have better programs for viewing pictures etc.
Reply
BobT [Avatar]
Newbie Private Message Joined: Jan 29, 2014 17:35 Messages: 7 Offline
[Post New]
You even put it on .dat files, ARGHGHGH
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4621 Offline
[Post New]
BobT , I would just like to remind you that this is not Tech Support; it is a user to user forum. We did not place anything anywhere nor can we undo anything that was done.,

Why don't you just go into Windows and set the default program for your files? I believe that you may have missed the settings when you installed the program.

If you go into the program and select settings, then preferences, More Settings, then file associations, you have the ability to change those preferences. This open was presented when you installed the software.

Good luck and perhaps a little tea to calm you down. .
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4621 Offline
[Post New]
Quote: BobT , I would just like to remind you that this is not Tech Support; it is a user to user forum. We did not place anything anywhere nor can we undo anything that was done.,

Why don't you just go into Windows and set the default program for your files? I believe that you may have missed the settings when you installed the program.

If you go into the program and select settings, then preferences, More Settings, then file associations, you have the ability to change those preferences. This option was presented when you installed the software.

Good luck and perhaps a little tea to calm you down.
.
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
BobT [Avatar]
Newbie Private Message Joined: Jan 29, 2014 17:35 Messages: 7 Offline
[Post New]
Considering I can't see a tech support section, and other users may find this (there was only one post found when googling, which was a question, not the solution), I had to put it here or no-where. Need to get it off my chest either ways.

As to the option, I thought I'd put it in my post but it seems I hadn't. I did indeed tell it not to change the file associations during initial installation. I then used the method above to remove ALLLLLL the context menu items from the file types in the registry.

The patch then went and totally undid all that! I don't recall an option during patching to tell it to NOT tinker with the default file associations, and there's certainly not an option to tell it to slap "Play with Cyberlink PowerDVD13!" in the context menu for almost every file type under the sun.
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4621 Offline
[Post New]
Did you change the Windows file associations/play options? .
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
BobT [Avatar]
Newbie Private Message Joined: Jan 29, 2014 17:35 Messages: 7 Offline
[Post New]
Yup, I'd already changed those back immediately afterwards. It was just irritating having to do it for all those bloody file types it had gone and auto-set it as.

As mentioned I had the ability to tell it not to touch them during initial install, but pretty sure I didn't get that option during the patch. (Along with the additional irritancy of it slapping all those context items back in my registry).

Cheers for being helpful though.
Reply
Dryne [Avatar]
Newbie Private Message Joined: Feb 05, 2007 06:46 Messages: 7 Offline
[Post New]
I agree with you that this is annoying as all heck.

I posted on how horrible this is already and asked they they fix this here:

http://forum.cyberlink.com/forum/posts/list/31605.page
Reply
CyberLink-Michael [Avatar]
Senior Contributor Private Message Location: Europe Joined: Apr 18, 2007 04:05 Messages: 7418 Offline
[Post New]
Hi,
sorry but we do not know yet why and how this happens to some users.

if you are used to Regedit - you can remove those keys manually:

HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Audio\\Shell\\PowerDVD13CommandVerb
HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Video\\Shell\\PowerDVD13CommandVerb
HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Image\\Shell\\PowerDVD13CommandVerb

HKEY_CLASSES_ROOT\SystemFileAssociations\Audio\\Shell\\PowerDVD13CommandVerb
HKEY_CLASSES_ROOT\SystemFileAssociations\Image\\Shell\\PowerDVD13CommandVerb
HKEY_CLASSES_ROOT\SystemFileAssociations\Video\\Shell\\PowerDVD13CommandVerb Technical Support

Werde Facebook Fan
Reply
BobT [Avatar]
Newbie Private Message Joined: Jan 29, 2014 17:35 Messages: 7 Offline
[Post New]
Quote: Hi,
sorry but we do not know yet why and how this happens to some users.

if you are used to Regedit - you can remove those keys manually:

HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Audio\\Shell\\PowerDVD13CommandVerb
HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Video\\Shell\\PowerDVD13CommandVerb
HKEY_CURRENT_USER\\Software\\Classes\\SystemFileAssociations\\Image\\Shell\\PowerDVD13CommandVerb

HKEY_CLASSES_ROOT\SystemFileAssociations\Audio\\Shell\\PowerDVD13CommandVerb
HKEY_CLASSES_ROOT\SystemFileAssociations\Image\\Shell\\PowerDVD13CommandVerb
HKEY_CLASSES_ROOT\SystemFileAssociations\Video\\Shell\\PowerDVD13CommandVerb


Apologies I've only just seen this reply.

Updated to the recent patch and it did it again. However I didn't have any of those keys at those locations. The PowerDVD13CommandVerb key seems to be under the specific file types, such as:

HKEY_CLASSES_ROOT\SystemFileAssociations\.bmp\Shell\PowerDVD13CommandVerb

For every file type under the sun heh. Have to mash F3 + Delete + Enter to get rid of them all. Then go into Default Programs in Control panel and set all the default associations back as PowerDVD13 has taken over everything.

There's so many..

This message was edited 1 time. Last update was at Jun 05. 2014 00:09

Reply
EyesWideBlown [Avatar]
Newbie Private Message Joined: Oct 07, 2013 14:16 Messages: 7 Offline
[Post New]
Same problem here with Win7 64-bit Ultimate Edition, I have to go thru my registry manually one by one to get rid of all "PowerDVD13CommandVerb" and "PowerDVD14CommandVerb" entries. It can't be that hard to have your software clean up the mess it has left behind, especially when you have a paying customer who has upgraded to a new PowerDVD version.
Reply
Nosxxx [Avatar]
Newbie Private Message Joined: May 28, 2013 15:28 Messages: 1 Offline
[Post New]
Hey Please fix this asap!!!
Reply
[Post New]
This was actually pretty simple:

  1. Download ShellMenuView (x32 / x64)

  2. Open

  3. Sort any of the Categories (I chose the first one, "Menu Name")

  4. Scroll down to PowerDVD (mine was "@C:\Program Files (x86)\PowerDVD14[...]")

  5. Shift select all

  6. Right click

  7. *Disable Selected Items* (F7)

This message was edited 5 times. Last update was at Aug 08. 2015 16:37

Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team