Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
I've tried unilstalling and reinstalling PowerDVD 22, no change.

The drive was up to date with it's latest firmware.

What I find really weird is that the Blu-ray plays just fine up until a very specific point.

It plays the advertisements when it first loads up perfectly, the menu is amazing and functions quick and smooth.
When the actual movie starts to play, the 20th Centrey Fox logo and company credits play as normal.
Then when the Lips fade in to sing Science Fiction/Double feature the whole thing turns into a huge glitchy mess.

I can rewind to the beguinning and the Fox logo plays normal, and at the same point with the lips it glitches out and it's like that for the entire rest of the movie.

Tested my other discs and they are still behaving as normal.

I'm afraid what you know for certain could be not that certain actually.

What "another" software you use?
Is it a DRM-hacking software player? (as there is nearly no other legitmate blu-ray software players you can find in the world).

Don't put the DRM-cracked result on the same comparison basis if you are really into powerdvd.

If ALL versions of powerdvd cannot play the specific disc normally, it is likely that the issue is not on the player software side.

I would suggest you check your Blu-ray drive first and seek firmware update from the manufacturer. Make sure your Blu-ray drive can handle the DRM data reading correctly on the specific Blu-ray disc. Then, check the player software.

The other software is Leawo Blu-ray Player

I'll keep trying to find ways to check what else could be an issue
I've got a LG bp50nb40 external Blu-ray/DVD writer/reader that I use to plug into my laptop and it's been working just fine.
Can play everything I've put into it so far, until I tried the Blu-ray for the 45th Anniversary of The Rocky Horror Picture Show.

I was using the PowerDVD software the reader came with and it was playing very stuttery, but had a clear picture. I updated the software to version 18.0 and the stuttering stopped, but now it's insanely glitchy. Like all over the place, blurring, red and green blotches everywhere.
I then purchased and installed PowerDVD 22 and it didn't change anything.
I tried the disc on the Blu-ray player hooked up to our TV and it had no issues, so it's not the disc.

I tried another software and it plays the movie without the glitch, but I'd prefer to use PowerDVD 22 as I've payed for it and like it better.
So I know for certain that it's the software and not anything else.

How would I fix this?
Go to:   
Powered by JForum 2.1.8 © JForum Team