Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
Thank you, I was able to record a reinstall of it to find that it uses 2012 and 2017, which is does install if the packages are not present. But still I have the same issue. The program still doesn't launch, and returns the missing Kanten.X error. I just don't know anymore, I feel like I will need to refund this purchase, because this software just plain isn't working...
I've already disabled my antivirus (Windows Defender) while installing with the same result. I've attached my DxDiag.txt file here, because I'm still waiting on my most recent support case for this. Everyone says the same thing for this, which is that the C++ Redist needs to be installed, but I've literally installed every x86 and x64 package from 2005 to 2022, and I still have the same results. What exact C++ redist is used for PowerDVD22? Because I can uninstall the other distros and install just that one to see if there is some sort of overlap issue with this.
Posting here because maybe someone has a miracle fix for this.

I'm receiving the notorious error: Activation context generation failed for "C:\Program Files\CyberLink\PowerDVD22\PowerDVD.exe.Manifest". Dependent Assembly Kanten.X,type="win32",version="" could not be found. Please use sxstrace.exe for detailed diagnosis.

I have literally every C++ redistributatble installed on my machine, both x86 and x64 from Microsoft's site, and still receive this error. Does anyone know what the correct version of C++ redist is for this version? I've opened a support case but received a boilerplate response and haven't gotten any closer to a fix for this. I've run the tracer application and captured the log from it, the end of the log detailing the issue is below. I've been searching for a solution to this and attempting every fix I've found on forums for at least a dozen hours now, I've copied the Kanten manifest from the MediaEspresso folder to the root PowerDVD22 folder, and copied the CESdlls folder to the root as well, but after fixing those two issues the program still won't launch, and no errors come up in Event Viewer anymore, which leaves me even more helpless.

INFO: Parsing Manifest File C:\Program Files\CyberLink\PowerDVD22\PowerDVD.exe.Manifest.
INFO: Manifest Definition Identity is PowerDVD,processorArchitecture="X86",type="win32",version="22.0.63133.1913".
INFO: Reference: Kanten.X,type="win32",version=""
INFO: Resolving reference Kanten.X,type="win32",version="".
INFO: Resolving reference for ProcessorArchitecture Kanten.X,type="win32",version="".
INFO: Resolving reference for culture Neutral.
INFO: Applying Binding Policy.
INFO: No binding policy redirect found.
INFO: Begin assembly probing.
INFO: Did not find the assembly in WinSxS.
INFO: Attempt to probe manifest at C:\Program Files\CyberLink\PowerDVD22\Kanten.X.DLL.
INFO: Attempt to probe manifest at C:\Program Files\CyberLink\PowerDVD22\Kanten.X.MANIFEST.
INFO: Attempt to probe manifest at C:\Program Files\CyberLink\PowerDVD22\Kanten.X\Kanten.X.DLL.
INFO: Attempt to probe manifest at C:\Program Files\CyberLink\PowerDVD22\Kanten.X\Kanten.X.MANIFEST.
INFO: Did not find manifest for culture Neutral.
INFO: End assembly probing.
ERROR: Cannot resolve reference Kanten.X,type="win32",version="".
ERROR: Activation Context generation failed.
End Activation Context Generation.
Go to:   
Powered by JForum 2.1.8 © JForum Team