CyberLink Community Forum
where the experts meet
| Advanced Search >
I have found a solution but it was quite by accident. I am surprised it was so difficult to find.

There is a free download of "Power2Go 12 Essentials". The download comes with a 15 day trial of the premium product, but the essentials has the basic function I need to just copy a disc.

https://www.cyberlink.com/downloads/trials/power2go-platinum/download_en_US.html

This version 12 worked like a charm the first time. It copied the disc to a temp location on my laptop, and then asked for the second disc. It then copied to the second disc without any problems. It did not take very long. The entire process was less than an hour.j

Hope this helps someone else that just needs some of the basic free functions.
I have Power2Go version 8 that came with a Windows 10 laptop. According to the CyberLink webiste, this version should be able to copy a DVD to another DVD. The DVDs I want to copy are home movie DVDs...not protected movies. The copy process gets to 99% and hangs for hours. I just have one DVD drive and the process never gets to the point of asking for the second DVD.

I have verified my DVD driver is up-to-date. I have tried to find if there are any patches for version 8, but have not found anything.

Any suggestions?
Go to:   
Powered by JForum 2.1.8 © JForum Team