CyberLink Community Forum
where the experts meet
| Advanced Search >
At this point, the best advice I can give is to contact CL tech support:


Thanks for the suggestion, David.
Quote Hello,

First of all, you don't have the latest version of PowerDVD 12. The latest build is 8705. You can download it here:

After that, download and run the BD Advisor and it should tell you if anything else needs to be updated:


Hi David,

Thank you for your prompt reply. I had already used the BD Advisor, which indicates my computer is compatible for playing BD discs ("Pass" in all categories in both the Basic and Advanced sections).

Before trying the update, I uninstalled PowerDVD; restarted the computer; installed all of the applications from the CD-ROM (including the non-essentials, such as the Media Suite and label printer); and restarted again

Sadly, despite having told the uninstall program to remove settings, there were still a lot CyblerLink/PowerDVD entries left over in the registry following the uninstall - When uninstalling the routine should remove all CyberLink/PowerDVD entries from the computer, not leave a heap of rubbish behind which may be causing or contributing to the problem.

On attempting to install the PowerDVD 12.0 patch (downloaded from the link you provided) it failed (at the progress point, "Publishing product information") displaying a dialogue box with a single button, OK:
Error 2932.Could not create file
\1033.mst from script data. Error: 32.

On clicking OK the installer then announced it was "Rolling back action", at which point a futher error, "Feature transfer error" was announced, again, with a single OK button:
Error: 1603 Fatal error during installation.
Consult Windows Installer Help (Msi.chm) or MSDN for more information.

Having tried to install the patch, PowerDVD will now not load from its entry on the Start Menu. PowerDVD will launch when a DVD is inserted into the BD player, but the window will not permit dragging and dropping and does not give access to menu options, such as "I" or "Settings". It's in a worse state than before.

Putting a BD disc in the drive caused a dialogue box warning about AACS License keys needing to be updated, but the link only goes to a "buy a newer version of PowerDVD page" not to a page with any downloads for AACS license keys.

What next, please?
I've recently purchased a brand new laptop with an external Blu-Ray writer.

I have installed, removed, reinstalled, updated (at least tried; the updates often fail) {repeat variations ofthe actions} all to no avail. Whilst I can get PowerDVD to play DVDs it just will not play Blu-Ray discs.

I have checked the (I)nformation, which informs me that PowerDVD 12s version is 12.0.5522.55 and that there are no updates available.

My wife's laptop, with a built-in Blu-Ray writer, also running PowerDVD 12 will play the Blu-Rays, so why won't mine?

Additional information:

PowerDVD loads. On attempting to start playing a Blu-Ray, a progress bar is displayed, then disappears. All I get then is a black/dark grey flashing display within the PowerDVD window. On some previous attempts (see 'repeated' comment above) the 'this Blu-Ray doesn't support mouse use' dialogue box was displayed, but that seems to have ceased, and when is was displayed, it didn't display correctly, being just a white box until I cleared all windows from the desktop and then reinstated the PowerDVD window.

Graphics are nVidia, and are up to date.

OS: WIndows 10 Pro, April 2018 update.
Go to:   
Powered by JForum 2.1.8 © JForum Team