CyberLink Community Forum
where the experts meet
| Advanced Search >
After uninstalling the Nvidia graphics driver, I re-installed it without installing the 3D controller. I did install the 3D driver but since I have a passive 3D tv, I opted not to install the controller which I learned is for the emitter for the active shutter glasses. Power DVD still says I inserted a 3D bluray when a 2D movie is inserted, but this time it plays just fine. The player makes the proper refresh rate change and the voices are surprisingly in sync. So far everything is working properly with correct refresh rates. The only gripe is it I get that message every time I insert a 2D bluray. It plays them at full resolution too. If you dont watch 3D movies, I suggest you don't bother installing the 3d driver, as I had zero play back issues except no 3D play back of course.
I have the same problem too. All blu-ray discs are recognized as 3D and it's annoying. Everytime I choose to let the application change my refresh rate it switches to 3D. I use a GTX 970 with the latest driver to date. Intel 3570 processor. I just turn off the 3D option in my driver control panel. In fact, I like it off because it causes issues with some games I play. If Power DVD could toggle it on and off as needed, that would be awesome.
Go to:   
Powered by JForum 2.1.8 © JForum Team