CyberLink Community Forum
where the experts meet
| Advanced Search >
PowerDirector 20 recent crashing?
Reply to this topic
StreetTales [Avatar]
Newbie Private Message Joined: Mar 01, 2020 17:59 Messages: 4 Offline
[Post New]
Seeing if anyone else is experiencing recent and continuing crashes with PD20?


My PD20 (and previous versions) were working fine and today for whatever reason it loads my media and timeline but as soon as I undertake a function (basically anytime I click somewhere on the screen) it crashes.

Would love any help out there?

With thanks.

This message was edited 1 time. Last update was at Aug 06. 2022 02:25

Reply
PowerDirector Moderator [Avatar]
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 1554 Offline
[Post New]
Quote Seeing if anyone else is experiencing recent and continuing crashes with PD20?


My PD20 (and previous versions) were working fine and today for whatever reason it loads my media and timeline but as soon as I undertake a function (basically anytime I click somewhere on the screen) it crashes.

Would love any help out there?

With thanks.


Hi,

Can you clarify your crash - any error messages, just hangs or ....?
Is the issue present on all existing projects or just one?
Can you start a new project just using the sample files and do some edits on it ?

Any other changes on your system - any auto-updates of O/S, graphics drivers or new software?

Useful if you could attach a DXDiag just to see if there's more info on the crashes?
See here https://forum.cyberlink.com/forum/posts/list/85748.page#post_box_354916

Also the exact version of PDR20 - https://forum.cyberlink.com/forum/posts/list/85748.page#post_box_354918

The more specific info you can give, the greater the chance of members being able to help out.

Cheers
PowerDirector Moderator

This message was edited 1 time. Last update was at Aug 07. 2022 03:53


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
StreetTales [Avatar]
Newbie Private Message Joined: Mar 01, 2020 17:59 Messages: 4 Offline
[Post New]
Thanks for reply and your suggestions which I'll get to later tonight. I was thinking I'd need to do a resintall just as I managed to get to my project but only by opening a 'new' PD through my application manager and then opening my project ... still couldn't open it from the icon within my saved file location (which was one of your suggestions).

For now wanted to say thanks and negative to any updates / other changes ... that's what was so weird. No errors or error screen ... it just crashed and wanted to send a crash report to Cyberlink.

It was working well just hours before and had been for quite awhile (months and months). That's why I thought I'd put the question out there per chance it was a wider issue.

Back in touch to share what comes from those links you sent through.


Quote


Hi,

Can you clarify your crash - any error messages, just hangs or ....?
Is the issue present on all existing projects or just one?
Can you start a new project just using the sample files and do some edits on it ?

Any other changes on your system - any auto-updates of O/S, graphics drivers or new software?

Useful if you could attach a DXDiag just to see if there's more info on the crashes?
See here https://forum.cyberlink.com/forum/posts/list/85748.page#post_box_354916

Also the exact version of PDR20 - https://forum.cyberlink.com/forum/posts/list/85748.page#post_box_354918

The more specific info you can give, the greater the chance of members being able to help out.

Cheers
PowerDirector Moderator

This message was edited 2 times. Last update was at Aug 07. 2022 13:39

Reply
StreetTales [Avatar]
Newbie Private Message Joined: Mar 01, 2020 17:59 Messages: 4 Offline
[Post New]
Update,

Version is 20.7.3108.8 which I'm assuming is the latest because the application manager didn't offer an update (only the open option which I used to get back into cyberlink).

No errors recorded using the Dxdiag tool.

Since I opened PD using the application manner it has continued to work without crashing - i.e. it kept crashing when I was opening PD via my 'file location'.

For now all looking good and hoping it stays.

Thanks once again for your support.

John P.

Per chance it is helpful the following link is broken (it was on one of the the pages you sent through)


http://www.cyberlink.com/multi/download/updates_4_ENU.html
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team