CyberLink Community Forum
where the experts meet
| Advanced Search >
Nvidia Video Denoise Error - green box appearing on video???
Reply to this topic
killertomato [Avatar]
Newbie Private Message Joined: Nov 28, 2018 22:23 Messages: 41 Offline
[Post New]
Thanks to those who assisted me with my prior query on this feature.
I've gone ahead and installed and RTX 2060, updated Powerdirector and the Nvidia denoiser is now available to me.

The only problem is that it's constantly putting this green box on the top right when I enable Nvidia denoising (doesn't matter if it's strong or weak).

I have tried removing my Nvidia drivers (using DDU) and Nvidia Broadcast and reinstalling everything but it makes no difference. Powerdirector has also been reinstalled leading me to think this is a bug?

When I uncheck Nvidia denoiser the green box disappears, it also renders it out this way (regardless if Nvenc is enabled or not).

Here's a screenshot of what's going on:

https://imgur.com/a/yFtUBOa

Sometimes the greenbox only appears in the final rendered product (it doesn't always show on preview).

Can anyone else replicate this? For reference I'm using h264 4K60 files out of my DJI Pocket 2.
I did get the green box to disppear using a 4K30 file once and I have not yet been able to replicate it. Again 1080P stuff works fine but 4K60 is how I shoot so...

Any help would be appreciated as I think this is clearly a bug.

*edit* I also checked Vram useage to make sure the 6GB wasn't filling up but it's only half being used when denoising is enabled (and barely increases VRAM usage at all when enabled so that's not it)...

This message was edited 2 times. Last update was at Jan 08. 2022 14:15

Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 7455 Offline
[Post New]
Obviously I didn't see that issue in the other discussion so it may be specific to the nVidia driver version you have installed.

There are two separate driver branches, Game Ready and Studio Driver and I was running the Studio Driver 472.84 when I did the testing. There's now a much newer version out (511.09) and I don't see any problems with this version either.

When you run the installer, select only the NVIDIA Graphics Driver (not GeForce Experience) then on the Installation Options page and chose Custom (Advanced). Uncheck all boxes except Graphics Driver then check the Perform a clean installation box. This will force the installer to remove all existing drivers and then only install the new graphics driver. You should reboot when it's finished.

If you need any other nVidia components for gaming or other purposes, you can run the installer again and add them after you've confirmed that the green square issue is gone.

This message was edited 1 time. Last update was at Jan 08. 2022 15:49

Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 142 Offline
[Post New]
I saw this green box (upper right corner) also last week. I updated yesterday to the latest Studio driver of Nvidia and don't see any green boxes anymore. Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro365+Vegasaur/PowerDirector365
Hardware: i910900k,32GB,GTX2080s, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
killertomato [Avatar]
Newbie Private Message Joined: Nov 28, 2018 22:23 Messages: 41 Offline
[Post New]
Quote Obviously I didn't see that issue in the other discussion so it may be specific to the nVidia driver version you have installed.

There are two separate driver branches, Game Ready and Studio Driver and I was running the Studio Driver 472.84 when I did the testing. There's now a much newer version out (511.09) and I don't see any problems with this version either.

When you run the installer, select only the NVIDIA Graphics Driver (not GeForce Experience) then on the Installation Options page and chose Custom (Advanced). Uncheck all boxes except Graphics Driver then check the Perform a clean installation box. This will force the installer to remove all existing drivers and then only install the new graphics driver. You should reboot when it's finished.

If you need any other nVidia components for gaming or other purposes, you can run the installer again and add them after you've confirmed that the green square issue is gone.


Sadly this has not helped. I was only running the studio drivers to begin with. I've even done (another) complete driver removal (using DDU as it's more effective than Nvidia's removal tools) as well as just uninstalling through Windows and re-adding...

The pesky greenbox persist at 4K. I guess I need to contact support.

This message was edited 2 times. Last update was at Jan 11. 2022 11:25

Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 5233 Offline
[Post New]
I've had a lot of PD issues of various forms when switching between AMD and Nvidia GPU's or vice versa. Using DDU to remove all of either before switch has been very beneficial for migration from one to the other.

Since it worked for 1080, you might try turning off NVDEC (hardware decoding) in the pref > Hardware Acceleration and see if that is a benefit for your source video.

Jeff
Reply
killertomato [Avatar]
Newbie Private Message Joined: Nov 28, 2018 22:23 Messages: 41 Offline
[Post New]
Quote I've had a lot of PD issues of various forms when switching between AMD and Nvidia GPU's or vice versa. Using DDU to remove all of either before switch has been very beneficial for migration from one to the other.

Since it worked for 1080, you might try turning off NVDEC (hardware decoding) in the pref > Hardware Acceleration and see if that is a benefit for your source video.

Jeff


You know what's weird? I disabled hardware acceleration and it did nothing... re-enabled it and the green box went away!

I have my fingers crossed but maybe something in PD's settings needed a reset somewhere.

Hopefully it stays this way but I'm still wary lol. Thanks for the suggestion!
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 5233 Offline
[Post New]
Quote You know what's weird? I disabled hardware acceleration and it did nothing... re-enabled it and the green box went away!

Sometimes it appears changing these pref > Hardware Acceleration settings does not take effect until close/open of PD again, or sometimes playing from the media library may help. I always validate with a hardware monitor that my setting reflects actual hardware usage and intent.

Jeff
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team