CyberLink Community Forum
where the experts meet
| Advanced Search >
Mac OS Compatibility with PhD/365
Reply to this topic
kjankabar [Avatar]
Newbie Private Message Joined: Feb 10, 2019 19:49 Messages: 2 Offline
[Post New]
Just updated my Mac to Monterey (v12.0.1) and PhD 10 is no longer compatible. Before I upgrade to PhD 13/365, can anyone tell me if it will be compatible with Monterey?

Thanks,
Reply
[Post New]
Hello kjankabar,

Welcome to the PhotoDirector forum laughing

According to the PhD Specifications page PhD is compatible with MacOS 10.14/10.15, which does not include Monterey (MacOS 12). It may be that the information hasn't been updated (?).

I personally don't know, & would suggest checking with CyberLink Customer Service or Technical Support.

PIX PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team