CyberLink Community Forum
where the experts meet
| Advanced Search >
Ragged Text with Title Designer
Reply to this topic
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
I'm working on an animation of a River cruise, i made last year. I'm wondering why the animated text made with Title Designer doesn't look sharp but ragged. Font used is Segoe UI at size 5. Attached screenshot is directly from preview, after rendering the text looks even worse.
[Thumb - SnapShot.png]
 Filename
SnapShot.png
[Disk]
 Description
screenshot
 Filesize
2280 Kbytes
 Downloaded:
10 time(s)
Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro18+Vegasaur/VegasMovieStudio17/PowerDirector365
Hardware: i7 4770, 16GB, GTX650ti, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
StevenG [Avatar]
Contributor Private Message Joined: Jan 14, 2014 14:04 Messages: 325 Offline
[Post New]
Are you judging the sharpness of the text in the Preview window or in your final output?
Reply
[Post New]
I even checked here using your image as a background, same thing.
I think that using this size 5 you should get a better result on a 4K monitor and “maybe” you need to change the preview resolution to Ultra HD as well.
I don't have a 4K monitor to confirm. AMD-FX 8350 / 16GB DDR3
SSD SUV400S37240G / 2-HD WD 1TB
Radeon RX 570 / Philips 272V8
Windows 10-64Pro / PD19/365
Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote Are you judging the sharpness of the text in the Preview window or in your final output?

Hi Steve, the screenshot I made, is a snapshot taken from the preview (at FHD). The final output looks even a little worse. Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro18+Vegasaur/VegasMovieStudio17/PowerDirector365
Hardware: i7 4770, 16GB, GTX650ti, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote I even checked here using your image as a background, same thing.
I think that using this size 5 you should get a better result on a 4K monitor and “maybe” you need to change the preview resolution to Ultra HD as well.
I don't have a 4K monitor to confirm.

I'm glad you could confirm my issue. I also don't have a 4k monitor.
Actually my FHD project (1080p50) is setup with 4k footage (2160p50 from Osmo Pocket).
Never saw such ragged text before, didn't check if it's just the Font, it's size or PD365. Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro18+Vegasaur/VegasMovieStudio17/PowerDirector365
Hardware: i7 4770, 16GB, GTX650ti, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote

I'm glad you could confirm my issue. I also don't have a 4k monitor.
Actually my FHD project (1080p50) is setup with 4k footage (2160p50 from Osmo Pocket).
Never saw such ragged text before, didn't check if it's just the Font, it's size or PD365.


Must be a quality bug in PD365, when I do the same in PD18 I get a crisp text. Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro18+Vegasaur/VegasMovieStudio17/PowerDirector365
Hardware: i7 4770, 16GB, GTX650ti, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote


Must be a quality bug in PD365, when I do the same in PD18 I get a crisp text.


Annoying bug, I'm still not able to get a crisp and sharp text in PD365.
To show the difference I made a short project with text in PD18 and made a snapshot of it with PD18.
Then I opened this project in PD365 and made again a snapshot.
Compare the difference! I hope this bug will soon solved because it's really annoying.
[Thumb - pd19.png]
 Filename
pd19.png
[Disk]
 Description
snapshot pd365
 Filesize
3013 Kbytes
 Downloaded:
7 time(s)
[Thumb - pd18.png]
 Filename
pd18.png
[Disk]
 Description
snapshot pd18
 Filesize
3014 Kbytes
 Downloaded:
7 time(s)
Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.
Software: Vegaspro18+Vegasaur/VegasMovieStudio17/PowerDirector365
Hardware: i7 4770, 16GB, GTX650ti, 1920x1200 display
Playware: Samsung Qled QE65Q6FN, Philips 55PFL7108
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6212 Offline
[Post New]
Have you tried using a different font? PD sometimes has difficulty with OpenType fonts, and you may need to reinstall that font as TrueType rather than OpenType.

You also need to report the issue before anything can be done about it. CL doesn't typically monitor the forum so you should submit a support request here to make sure the right people are aware of the issue.
Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote Have you tried using a different font? PD sometimes has difficulty with OpenType fonts, and you may need to reinstall that font as TrueType rather than OpenType.

You also need to report the issue before anything can be done about it. CL doesn't typically monitor the forum so you should submit a support request here to make sure the right people are aware of the issue.


I tried it also with Font Arial, same issue.
My observations, it works as expected in PD18 but not in in PD19. The only visable difference between PD18 and PD19 is that PD18 has a separate Title track and PD19 uses a Video track for this purpose!

I discovered a small workaround for my issue. I'm making a text animation with a static background image of a map (1920x1080). There are two ways to achieve this.

  1. Putting the background image on a upper track (track1) and the overlaying text on a lower track (track2), this option gives a raged text output.

  2. Putting a text on the upper track and import the background image directly into the Title designer, this option gives a crisp text result and needs only one track to achieve.

Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6212 Offline
[Post New]
Quote The only visable difference between PD18 and PD19 is that PD18 has a separate Title track and PD19 uses a Video track for this purpose!

I imagine that's the key. If so, then PD19/365 is treating the text like a video clip and is then displaying that at a lower resolution - possibly due to your preview quality setting. Does it improve if you set it to Ultra HD? (You don't need a 4K monitor to preview at that setting).

Also, can you check if placing 5pt text on a video track looks the same as on the title track in PD18?

This message was edited 1 time. Last update was at Jan 15. 2021 15:37

Reply
3POINT [Avatar]
Member Private Message Location: Germany Joined: Oct 01, 2015 03:52 Messages: 83 Offline
[Post New]
Quote

I imagine that's the key. If so, then PD19/365 is treating the text like a video clip and is then displaying that at a lower resolution - possibly due to your preview quality setting. Does it improve if you set it to Ultra HD? (You don't need a 4K monitor to preview at that setting).

Also, can you check if placing 5pt text on a video track looks the same as on the title track in PD18?


No it has nothing to do with Title track or Video Track. In PD18 I get the same results (no difference) when placing a 5pt text on the Title track or on the Video track.

But I found the reason for the difference in quality in PD19. It seems that adjusting the Font Face Blur from 0 to 1 solves the issue.
I made a total screenshot of 3 different options in PD19 and made a FHD snapshot of each option to compare the difference (result is zoomed in to see the differences better).

  1. This is what I get when I put the text size 5 on a track and the background on another track, result ragged text.

  2. This is what I get when setting Font Face Blur to 1, result good.

  3. This is what I get when I put the background not in a separate track but directly in the Title Designer, result good.



When doing 1 in PD18 I get the same result as shown in 2 and 3, no need to blur the font face.
[Thumb - Untitled.png]
 Filename
Untitled.png
[Disk]
 Description
difference of quality
 Filesize
2083 Kbytes
 Downloaded:
6 time(s)
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6212 Offline
[Post New]
You certainly spent some time digging into this and I'm glad your effort paid off!
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team