CyberLink Community Forum
where the experts meet
| Advanced Search >
Photodirector 365: search verry slow.
Reply to this topic
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Hello,

I'm considering switching from Lightroom to Photodirector. First I imported all of my photos, about 15,000. Now when I search for tags in PhotoDirector, it takes 30-60 seconds! Under lightroom 1 second. How can you speed it up the search?

Markus
Reply
[Post New]
Hello Markus,

Welcome to the PhotoDirector forum laughing

I wasn't abale to respond immediately to your post becasue I'd never done any direct comparison between PhD & Lr, with respect to speed of searching photos via keywords/tags.

What I've observed over the last few days of testing is there is no significant difference on two of my PCs.

My initial comparison used a random set of 2085 photos with a simple tag structure (i.e. photos had no more than two tags assigned). Both PhD & Lr yielded search results at good speed (almost instant). The same results were observed on PC2 using the same photos.

Next I used a set of 5000+ photos, with a more complex tag "hierarchical tree structure". Some photos had up to 5 tag levels. Again, search results were reasonably quick (~2-3secs) with both PhD & Lr on each PC.

There may well be an observable difference with 15000 photos, but I couldn't predict that from my observations thus far.

PIX

This message was edited 1 time. Last update was at Oct 26. 2020 04:44

PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Hi Pix,

thx for yor answer. When I use the "Tags" in the left Window for sarching, all is fine. All foung <1 Second. But when I use the "search" box (right lower corner in the PhotoDirector window) it is verry solw. I entred "giitti" for searching. Then is nothing, no hourglass, nothing. About 30-35 seconds later Photodirector shows 25 pictures.

When I click on the tag "Gitti", PD immediately shows the pictures, fine!

When I create a smart collection with text "Gitti", PD immediately shows the pictures, fine!

When I use the search box in the right lower corner I have to wait 30 seconds or more before PD shows me any respond, bad!


The search field located on top of the browser panel.


BR
Markus

This message was edited 2 times. Last update was at Oct 26. 2020 13:20

Reply
[Post New]
Hello again Markus,

I have no doubt that what you've observed is completely true, but I still haven't seen that extreme difference here.

What I have seen is that speed of search is dependent on:


  • Number of photos in collection

  • Number of photos with particular tag

  • Complexity of tag structure



To get more accurate timing, I screen captured the process of searching the same group of 5670 tagged photos in both PhD & Lr. In each case I timed from the moment I hit "Enter" after typing the tag name to the moment the last thumbnail was displayed.

You can see in the screen capture that the difference wasn't as pronounced as you've reported.



During repeated testing, results varied slightly from those in the screen capture.



PIX

This message was edited 1 time. Last update was at Oct 29. 2020 14:21

PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Hi!

the tag search works fine, there ist not the problem, the problem is the search box, see attachment. When you use the searchbox, you have still wait for 30-60 seconds.
[Thumb - Searchbox.jpg]
 Filename
Searchbox.jpg
[Disk]
 Description
SearchBox
 Filesize
39 Kbytes
 Downloaded:
4 time(s)

This message was edited 1 time. Last update was at Oct 29. 2020 14:53

Reply
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Quote Hi!

the tag search works fine, there ist not the problem, the problem is the search box, see attachment. When you use the searchbox, you have still wait for 30-60 seconds.



I added a video to show you the problem: https://youtu.be/KPpqgEfe61Q
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5938 Offline
[Post New]
satMAX, you and PIX are on different page views which changes where the Search box is located. See if changing the view to Photo Browser Only (like PIX has tested) speeds up Search:

Reply
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Quote satMAX, you and PIX are on different page views which changes where the Search box is located. See if changing the view to Photo Browser Only (like PIX has tested) speeds up Search:




Exact the same problem. When I use the search box, it is verry slow.

If I use the Tag Structur on the left, all is fine. If I create a "smart collection" with the sample keyword "gina" in any text it is fast. Only the search box is verry slow.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5938 Offline
[Post New]
Can you open Task Manager, then click on the Open Resource Monitor link and see how hard your CPU is working when it's searching in PhD12:

Reply
SatMAX [Avatar]
Newbie Private Message Joined: Mar 23, 2018 13:28 Messages: 7 Offline
[Post New]
Quote Can you open Task Manager, then click on the Open Resource Monitor link and see how hard your CPU is working when it's searching in PhD12:



Between 11-12%
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5938 Offline
[Post New]
Thanks. I'm not sure that PIX or I will be able to do much else to help, so I'd suggest opening a support request with Cyberlink. You can contact them here.

Please post back if they're able to fix the issue for you or confirm that it's a bug.
Reply
[Post New]
Hello Markus & optodata,

Thank you for your patience with this issue, & your efforts to resolve it. I have something to report, which will also be lodged with the team at CL.

It perplexed me that Markus was having an issue with tag searching but I wasn't able to replicate. My initial comparisons showed PhD & Lr functioning with comparative efficiency.

To more accurately test the issue, I prepared a project in PhD containing 20 000 photos. The photos were all tagged and exported to a separate folder, then I ran the same comparison test shown in the previous screen capture.

I can report that, with a library of 20 000 photos the speed of searching by keywords/tags is markedly different between the two applications! surprised (just as Markus reported).

I suspect, though I haven't confirmed, that the different ways PhD & Lr import or access photos might be a factor.


I prepared an unlisted (& not very interesting) screen capture for CL's reference, but won't post it here. I'm happy to share the link if requested by PM.

So, the issue occurs when one has (what I'd call) an oversized project library of ~15 000+. Personally, I've never had a photo project going anywhere close to those numbers. The projects used in thios testing had to be "fabricated". Of course, different users have different needs.

Markus, if the speed of searching a massive library of photos is an important factor for you it appears you have a choice. Either stick with Lr use PhD with smaller sized projects.

PIX

This message was edited 1 time. Last update was at Nov 03. 2020 06:09

PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
RonO2015 [Avatar]
Newbie Private Message Joined: Aug 25, 2012 11:20 Messages: 8 Offline
[Post New]
SatMAX FYI I just upgraded to PD365 and I'm able to duplicate your same issue with the search function.


RonO
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team