CyberLink Community Forum
where the experts meet
| Advanced Search >
Рroxy files are colored blue below
Reply to this topic
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
When I turn on "shadow files" in the settings, after processing the 4k video file in the library turns green. If you put it on a track and start watching it in the player, in some places at the bottom of the video there is a color in blue, purple, even after output to the final file.
Maybe someone knows and met this problem, how to fix it?
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4560 Offline
[Post New]
Quote When I turn on "shadow files" in the settings, after processing the 4k video file in the library turns green. If you put it on a track and start watching it in the player, in some places at the bottom of the video there is a color in blue, purple, even after output to the final file.
Maybe someone knows and met this problem, how to fix it?

Turning off hardware decoding in pref > Hardware Acceleration can often help. If it does, I'd verify your graphic drivers are current for your hardware.

Jeff
Reply
Davidk101
Member Private Message Location: Brisbane Australia Joined: Jun 24, 2020 02:38 Messages: 122 Offline
[Post New]
I had this issue with an FHD clip on another editor, recorded if memory serves on a Sony 2500. It was eventually tracked down to the data rate exceeding the nominal for that spec by a fair amount; eg, on an FHD clip, the data rate was about 200K instead of something more normal like 50k, and the colour at the bottom of the window came about because the preview player was running into the normal vertical flyback zone for the data rate involved. Reduce the data rate to something normal for the spec and issue goes away.
Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Sorry, I do not quite understand how to reduce the data transfer rate and where in the PD 18 settings can this be done?
Reply
Davidk101
Member Private Message Location: Brisbane Australia Joined: Jun 24, 2020 02:38 Messages: 122 Offline
[Post New]
If this bit rate suggestion is the cause of your problem . . no way to tell without some experimenting.

Firstly, you haven't stated just what your shadow resolution settings are. Make sure they are enabled for the project. And the easiest way to check the impact on your clip is to change them down to a lower resolution, in steps, to see if or when the colours go away. A point about shadow files is they are provided to make editing smoother to do, not show the final hi-res result. So a shadow file for a 4k clip can be any resolution that's good for your PC, but that is really dependant on the power of your cpu (fast clock and lots of RAM helps). However the default shadow res of 720x480 should be good enough for any clip when it's only used in edit. The larger the clip size (4K?) then longer it will take to create the shadow file. Please note that the 720x480 size is an NTSC number, which despite my location being in a PAL country is the default/lowest number on display in properties. If it were correctly adjusted for PAL, that resolution would be 720x576 which is just not included in the list. But 720x480 is workable, since the shadow is only used for edit and the rendered result is your edit actions applied to your original 4k clip.

In another editor, a project can be specified to have particular properties: so as a start, change the properties there. Even if you load a clip with different properties, it's processed at the project specified rate. Later, in rendering, quality can be reduced by reducing the bit rate specified in the render, to enable the result to fit onto a disk.
But we aren't there, so I spent a bit of time reviewing the comparisons/options for PD18.

1. During edit.
I note that you said ' .. insert a shadow files to the timeline . . ' so presumably it is occurring during edit, and then only in particular clips. Clearly the 4K shadow for those files showing colour at the bottom of the preview window still have a high bit rate even at the shadow resolution.
So one option is to pre-process the clips to reduce the bit rate using a program like Handbrake - most often used to stabilise a variable frame rate, but there are facilites to change the bit rate as well.
This method changes the actual source file, so you might not want to take this approach. In which case, use the lowest shadow file resolution available and if the colours are still there then live with it during the edit phase (see footnote).

2. During Render/produce
During produce there are options for each target media type (eg MPEG-2 or H264 aka mp4) in a list box to choose the bit rate (Mbps) you want in the result. Pick one you think suits - experiment - and render it. Play the result to see if that colour bar is still there on the clips in question.

Footnote.
My prior experience with this effect was with a specific type of camera. And most camcorder users use the default settings in the device, which are the manufacturers version of "optimal". However, the output settings of the camera could also be adjusted in terms of format, frame rate and resolution (bit rate per frame). So adjusting this setting in your camera is also worth investigating.
Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Thank you David, on your advice I checked three proxy options - 720x480, 1280x720, 1920x1080. Unfortunately, all three are timeline colored.
But something else is curious - all of them and even the original 4k do not have coloring when viewed from the library.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 5961 Offline
[Post New]
Try setting PD's preview color space to RGB instead of YUV like this:

Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Quote

Turning off hardware decoding in pref > Hardware Acceleration can often help. If it does, I'd verify your graphic drivers are current for your hardware.

Jeff


Thanks, Jeff.
Disabled hardware encoding - still blue. AMD 7850 video card, Crimson driver 17.7.1. The camera shoots in 3GPP HEVC format, transcoding to mp4 4k or full hd eliminates the defect.
Interestingly, there is no such defect in Premiere at all, but I don't like working in this editor.
Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Quote Try setting PD's preview color space to RGB instead of YUV like this:



Unfortunately, it doesn't help ...
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4560 Offline
[Post New]
Quote Thanks, Jeff.
Disabled hardware encoding - still blue. AMD 7850 video card, Crimson driver 17.7.1. The camera shoots in 3GPP HEVC format, transcoding to mp4 4k or full hd eliminates the defect.
Interestingly, there is no such defect in Premiere at all, but I don't like working in this editor.

You might share a small clip, 3GPP not really a supported format and could be the display issue. You may simply have to convert them with HandBrake or such.

Jeff
Reply
Davidk101
Member Private Message Location: Brisbane Australia Joined: Jun 24, 2020 02:38 Messages: 122 Offline
[Post New]
Opto's comment about changing the display colour settings caught my attention.
When I migrated to windows 10, the display colour setting was and is the display spec of 8bit RGB. It works fine and I've no cause for complaint about it. In that format, the number of colours available is (according to the windows geeks I asked) 2^8(Red)x2^8(green)x2^8(blue), or about 16 million colours per resolution cell.
And I've confirmed opto's result of YUV as the display default colour presentation in power director18.

So, why does PD use YUV as a default when the OS and hardware system spec is RGB? Is PD not adaptive to the hardware platform, or is there a specific reason for the colour choice in the program?

This message was edited 1 time. Last update was at Oct 18. 2020 20:50

Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Quote

You might share a small clip, 3GPP not really a supported format and could be the display issue. You may simply have to convert them with HandBrake or such.

Jeff


https://drive.google.com/file/d/1HnrToXCs4ZieGjB87KOHIlJJXQSM3Fol/view?usp=sharing
Please comment ...
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4560 Offline
[Post New]
Quote Please comment ...

Salva70, my comment is a file compatibility issue. I tried your file as is in PD14, PD18, and PD19, all display issues in some place at the bottom of the video where a color line or tearing in blue, purple exists. Nvidia decoding appeared to help, but not the resolution. I don't think your AMD 7850 supports HEVC decoding, hence maybe no change for you.

The file is also variable framerate which can cause PD other issues too, so, I think your best option is to transcode with HandBrake to a constant framerate, H.265 file of the same frame resolution and bitrate as the source and use that file in PD18 for editing.

Jeff
Reply
Salva70 [Avatar]
Newbie Private Message Joined: Oct 16, 2020 12:15 Messages: 7 Offline
[Post New]
Thanks a lot Jeff.
If I understand correctly, replacing the video card solves the issue?
What video card was used in your hardware?
Reply
JL_JL [Avatar]
Senior Contributor Private Message Location: Arizona, USA Joined: Oct 01, 2006 20:01 Messages: 4560 Offline
[Post New]
Quote Thanks a lot Jeff.
If I understand correctly, replacing the video card solves the issue?
What video card was used in your hardware?

No, the GPU decoding helps but is not a resolution to the issue as I mentioned. Your best option in my opinion is to transcode the file to something PD is happy editing.

Jeff
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team