CyberLink Community Forum
where the experts meet
| Advanced Search >
PowerDirector 365 will not run after update
Reply to this topic
paul1030 [Avatar]
Newbie Private Message Joined: Aug 02, 2020 12:52 Messages: 2 Offline
[Post New]
Hello everyone.

I just installed the update thru the CyberLink Application Manager (August 2, 2020). After the update my desktop icons have disappeared. And when I click on links to PDS files I have created, Windows comes up and says there is no application attached to this extension.

I searched my C drive and found the PDR exe file for version 18, but when I double-click on it nothing happens. I checked Windows app manager and it does not show PDR running.

PD365 worked fine before this update and now it doesn't work at all!

I submitted a support ticket but I hope someone here can help too.

Thanks in advance,

Paul

P.S. If it matters, I cannot find my serial number or activation key :/
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6359 Offline
[Post New]
First of all, reboot to make sure nothing from the installation is still pending.

After the restart, can you still launch the App Manager? If so, do you still see PD listed under My Programs? Does it say Launch or Install at the right of the window?

If Launch is shown, does clicking on that work? If not, right-click on PD and choose Uninstall:



If the App Manager doesn't start, use Windows uninstall tool (right-click on Start, then Apps and Features) to remove it and PD 365, then follow the steps here to start over with a new installation.

Since you're a subscriber, you just need to log in to the App Manager with the same email and password you use for your Cyberlink account. No serial # or activation codes are needed.
Reply
paul1030 [Avatar]
Newbie Private Message Joined: Aug 02, 2020 12:52 Messages: 2 Offline
[Post New]
Quote First of all, reboot to make sure nothing from the installation is still pending.

After the restart, can you still launch the App Manager? If so, do you still see PD listed under My Programs? Does it say Launch or Install at the right of the window?

If Launch is shown, does clicking on that work? If not, right-click on PD and choose Uninstall:



If the App Manager doesn't start, use Windows uninstall tool (right-click on Start, then Apps and Features) to remove it and PD 365, then follow the steps here to start over with a new installation.

Since you're a subscriber, you just need to log in to the App Manager with the same email and password you use for your Cyberlink account. No serial # or activation codes are needed.


Yes, I had done a hard reboot but it did not help. App Manager did run but the PD button said "Install." There was no launch option. So I clicked 'Install' and it ran for about 10 seconds. Then I tried to launch and, again, nothing happened.

Then I posted this question. When you answered I did another hard reboot and tried again. This time, the App Manager button said 'Install' again. I ran it and the button then said "Launch" and it DID launch! Now everything is working OK now; my links are back and the projects I've been working on load fine

Thanks sooo much! Glad I didn't wait for tech support (it's Sunday).

Paul
Reply
cyber fans [Avatar]
Newbie Private Message Joined: Sep 02, 2020 23:06 Messages: 1 Offline
[Post New]
Mine stopped working, just showing"Multi task not supported". The 365 cracked and down after updated yesterday. It is annoying!
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 6359 Offline
[Post New]
Your issue is different. All you need to do is reboot and you should be able to launch PD normally. If you have any other problems, try uninstalling and reinstalling PD from the App Manager.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team