CyberLink Community Forum
where the experts meet
| Advanced Search >
P2GO won't open
Reply to this topic
boongsong [Avatar]
Contributor Private Message Location: Arvin, CA Joined: May 18, 2010 14:48 Messages: 455 Offline
[Post New]
Need some help. Looking here rather than Support.
I have Power2Go 11. Just tried to open it but got the message shown in the atch.
So, went to my acct, clikced on the update link for P2G0. It downloaded and installed.
Tried to open after that and still get the same message - not activated.
When I click on OK, it closes. No way to activate it.
Next, I opened my support tickets and found I had the same problem shortly after I purchased/installed it. I was given download links for P2G and its content pack, along with a user ID and password. It all worked back then. But today, when I tried the link and ID/pw, it doesn't work. I get a small window shown in 2nd atch.
Any ideas on what I have to do to get it to work?
Thanks
[Thumb - p2go.JPG]
 Filename
p2go.JPG
[Disk]
 Description
 Filesize
22 Kbytes
 Downloaded:
5 time(s)
[Thumb - p2g2.JPG]
 Filename
p2g2.JPG
[Disk]
 Description
 Filesize
30 Kbytes
 Downloaded:
3 time(s)

This message was edited 1 time. Last update was at May 27. 2020 20:14

Jack
PD 14.0.2302.0 HP h8-1280t, Intel Core i7-3820, CPU 3.60Hzm 64-bit, 10GB mem, 1 TB hard drive
Reply
[Post New]
Not sure why you are asking us, not support if they fixed it for you last time. There is definitely something wrong with your key or build, and the downloads expire after 30 days. That is common knowledge.

Dave
Reply
boongsong [Avatar]
Contributor Private Message Location: Arvin, CA Joined: May 18, 2010 14:48 Messages: 455 Offline
[Post New]
Just didn't feel like dealing with support. Also, not everybody knows download links expire after 30 days - I sure didn't know that. Takes such a long time. I've always gotten my answers on the forums here and have learned a lot from all those who have taken the time to help.
At any rate, I found the answer so I will mark this post as solved.
Thank you. Jack
PD 14.0.2302.0 HP h8-1280t, Intel Core i7-3820, CPU 3.60Hzm 64-bit, 10GB mem, 1 TB hard drive
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4663 Offline
[Post New]
What was the answer -- for others to learn ? Don't feel embarrashed if it was a simple error. .
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
boongsong [Avatar]
Contributor Private Message Location: Arvin, CA Joined: May 18, 2010 14:48 Messages: 455 Offline
[Post New]
Good morning stevek.
Sorry for not mentioning my solution.
I do not know exactly what the problem was, and, I suppose I should have pursued the solution via support.
But I got to rummaging through my papers and found the CD that I ordered with the download and used that.
I apologize to everyone for not pursuing it through support but needed to use it as soon as possible and support
is not the quickest car in the race.
Again, I apologize for not doing what was necessary. Rest assured, if it happens again, I will do the right thing. Jack
PD 14.0.2302.0 HP h8-1280t, Intel Core i7-3820, CPU 3.60Hzm 64-bit, 10GB mem, 1 TB hard drive
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team