CyberLink Community Forum
where the experts meet
| Advanced Search >
Application manager not working
Reply to this topic
Rembrandt [Avatar]
Newbie Private Message Joined: Aug 14, 2019 04:43 Messages: 2 Offline
[Post New]
Today I subscribed for one year Powerdirector17 and downloaded the Cyberlink Application Manager.
On startup all it seems to be doing for the last hour is to display the message "Updating Cyberlink Application Manager".
Not very inspiring to look at and it seems to be a perfectly good waste of money so far.

It is not blocked by my firewall -I checked- and I run it as an administrator.
Also the trial version was deleted from my PC.
A ticket was submitted but an answer "might take several days" wich is a good indicator that apparently people are being kept busy at Cyberlink but does not help me in the short run.

Is there a software ayatollah on this forum who can help me out?
Thanks in advance.
Reply
PowerDirector Moderator
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 747 Offline
[Post New]
Hello,

Can you please try uninstalling the CyberLink Application Manager (CAM) and then downloading and installing it again from this link:

https://membership.cyberlink.com/prog/member/service/manage-subscription.do?lang=ENU&affid=2581_0_712

Let us know if that helps.

Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
Rembrandt [Avatar]
Newbie Private Message Joined: Aug 14, 2019 04:43 Messages: 2 Offline
[Post New]
Fantastic!
Thank you, ayatollah, this did the trick.
Running smooth now.
Reply
Wojciech2020 [Avatar]
Newbie Private Message Joined: Dec 19, 2019 12:23 Messages: 1 Offline
[Post New]
Quote Hello,

Can you please try uninstalling the CyberLink Application Manager (CAM) and then downloading and installing it again from this link:

https://membership.cyberlink.com/prog/member/service/manage-subscription.do?lang=ENU&affid=2581_0_712

Let us know if that helps.

Cheers
PowerDirector Moderator


I made it, but i can`t sign in. I checked 10 times. E-mail and password are correct.

What else can I do?

I have a computer with Power Director 18 installed. I made a movie. I want to delete a watermark. That's why I bought PowerDirector 365 today.

This message was edited 1 time. Last update was at Dec 19. 2019 12:49

Reply
PowerDirector Moderator
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 747 Offline
[Post New]
Quote


I made it, but i can`t sign in. I checked 10 times. E-mail and password are correct.

What else can I do?

I have a computer with Power Director 18 installed. I made a movie. I want to delete a watermark. That's why I bought PowerDirector 365 today.


Hello,
If re-downloading and re-installing CAM does not fix the issues, then please contact CyberLink Customer Service.
Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team