CyberLink Community Forum
where the experts meet
| Advanced Search >
4k disc starts to load and stops when it's about to play
Reply to this topic
Ymustuknow [Avatar]
Newbie Private Message Joined: Aug 02, 2019 06:10 Messages: 2 Offline
[Post New]
Hello all,
I recently built my computer and can't seem to get a 4k movie to play on it. It's a Intel i5 9th gen with on board graphics and a Asus Z390-A mother board. I have updated the Bios, which in turn updated Intel ME, and my SGX says it's the most current (I searched within device manager for an update and also looked around for an update file that and it still says current, version 25.20.100.6374). I am using PowerDVD 15 Pro, it sees the disc, offers to play it, spins it up, starts a loading bar and when it gets to 100% it stops and gives me the option to resume or restart the movie.

Cyberlink Advisor shows this for results, see attachments.

Any ideas would be appericated.
Thanks!
[Thumb - Capture.PNG]
 Filename
Capture.PNG
[Disk]
 Description
 Filesize
57 Kbytes
 Downloaded:
3 time(s)
Reply
Ymustuknow [Avatar]
Newbie Private Message Joined: Aug 02, 2019 06:10 Messages: 2 Offline
[Post New]
Do you mean PowerDVD? Power Director is video editing software. I just want to play my store bought 4k movies.

This message was edited 1 time. Last update was at Aug 03. 2019 23:02

Reply
[Post New]
Dear All,

The post with the link was a spam post, so it was removed by deleting the post and removing the quoted reply. Please run a anti-virus scan if you clicked on the links.

Cheers
PowerDVD Moderator

This message was edited 2 times. Last update was at Aug 03. 2019 23:08

Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team