CyberLink Community Forum
where the experts meet
| Advanced Search >
Does PD 17 hang and crash more ???
Reply to this topic
[Post New]
I have PD 17 365 or whatever it's called. It simply hangs quite often. Or hangs then crashes.

This happens so much that I have much difficulty finishing any project.

What do I do ? I'd prefer going back to an earlier version but I'd have to start several projects from scratch since there is no backwards compability.
Reply
[Post New]
It depends on what's causing the hangs and crashes.

It's certainly not something most of us are experiencing. So it could be an instability or a buggy driver on your system.

It could also be related to the media you're editing. Unless it's hanging and crashing even when you open a new project, before you add any media to it.

What model of camcorder is your video coming from? What is the video's resolution and format?
Reply
[Post New]
Quote It depends on what's causing the hangs and crashes.

It's certainly not something most of us are experiencing. So it could be an instability or a buggy driver on your system.

It could also be related to the media you're editing. Unless it's hanging and crashing even when you open a new project, before you add any media to it.

What model of camcorder is your video coming from? What is the video's resolution and format?



I've had PD14, 15, 16, and now 17. I've created many, many videos with few problems, an occasional crash probably.

I am doing nothing basically different now. Most of my original videos were captured with my iPhone 7+. Some are from stock videos and photos, but I've always done that.

It takes "forever" to accomplish a small task, like putting keyframes on a video section.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 2565 Online
[Post New]
Quote I've had PD14, 15, 16, and now 17. I've created many, many videos with few problems, an occasional crash probably.

I am doing nothing basically different now. Most of my original videos were captured with my iPhone 7+. Some are from stock videos and photos, but I've always done that.

It takes "forever" to accomplish a small task, like putting keyframes on a video section.

There do seem to be some simple things that PD17 struggles with more than previous versions, like titles on my very powerful new PC. However, it's also possible that older drivers (or even newer ones) are behind the slow performance on your system,. Maybe even an unexpected system configuration or setting could be the cause.

You can certainly try uninstalling and reinstalling PD, and also make sure you're updated to the latest version. For more assistance, please follow the steps in the Read Me Before Posting thread at the top of the PD17 forum index page, and post the requested details.
youtube/optodata


Director Suite 365 | Win10 Pro | 8 Core/16 Thread i9-9900K (4.8GHz) | RTX 2070 | nVidia 417.71 | ASUS PRIME Z390-A | 6.2TB SSDs | 4TB HDD | 32GB RAM | (12GB RAMDrive)
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team