CyberLink Community Forum
where the experts meet
| Advanced Search >
SGX still not satisfied - why?
Reply to this topic
[Post New]
Hi all,

I have been reading a lot in this forum already because I want to build a HTPC capable of UHD Blu-ray playback.
Now my first thread because last week the time has come and based on the recommendations in the forum I purchased

Fatal1ty Z370 Gaming-ITX/ac board and
i3-8100 CPU

Note: I have not yet a UHD Blu-ray capable drive, 4k cable and 4k screen.
However I have PSU, RAM, M.2_SSD and HDTV but probably this is not relevant to my problem.

I assembled my HTPC, installed Win10 x64, installed latest BIOS (enabled SGX) and drivers from Asrock homepage (incl. Intel ME), installed PDVD17 (incl. latest patch) and the latest Blu-ray advisor.

According the advisor one of the not satisfied points is the SGX. Two more points are not satisfied, due to missing UHD display and drive.

The latter two not satisfied points are clear for me according my note above.
But why the SGX is not satisfied?
What did I miss?
I want to solve the SGX issue at first before spending more money.

Thanks a lot for any hint and shared experience.
Reply
QC2.0 [Avatar]
Contributor Private Message Joined: Apr 27, 2016 04:02 Messages: 342 Offline
[Post New]
If you have confirmed your hardware is OK to enable Intel SGX, the Intel Managment Engine driver must be installed using full version installer (SetupME.exe), but not the basic Intel MEI installer (The MEI installer size is relatviely small, and less than 20 MB).

If it still failed, check the FAQ cyberlink provided:
https://www.cyberlink.com/support/faq-content.do?id=21676

This message was edited 1 time. Last update was at Jul 05. 2018 03:11

Reply
[Post New]
Quote If you have confirmed your hardware is OK to enable Intel SGX, the Intel Managment Engine driver must be installed using full version installer (SetupME.exe), but not the basic Intel MEI installer (The MEI installer size is relatviely small, and less than 20 MB).

If it still failed, check the FAQ cyberlink provided:
https://www.cyberlink.com/support/faq-content.do?id=21676



Thanks for your reply!
Just back home and whithout any modification I run the advisor again, and the SGX problem is cleared! smile

Btw, before my previous post I have already installed the Intel ME from Asrock hp, which is around 80MB big. I can see the Intel ME driver and also SGX driver in the device manager.

Hope the advisor result for SGX remains stable. For solving the other two issues I need to invest some money first... cool
Reply
[Post New]
Quote

Hope the advisor result for SGX remains stable.



During the last weeks the result of advisor sometimes turned to "SGX not available". A simple reboot solved this.

Since yesterday however the advisor result remains "SGX not available"...
I installed the latest BIOS (3.10) from Asrock homepage, SGX activated, re-installed Intel ME from Asrock homepage, re-boot, but no success....frown

Does anoeone have a hint please ?? My HW is of course still the same as in my 1st post.
Reply
[Post New]
Would really apreciate any suggestions.
I build my PC according the recommendations in this forum, SGX confirmed by the adisor for a while, but then never again...
Reply
andymcn [Avatar]
Newbie Private Message Joined: Apr 01, 2014 10:42 Messages: 1 Offline
[Post New]
Quote Would really apreciate any suggestions.
I build my PC according the recommendations in this forum, SGX confirmed by the adisor for a while, but then never again...

I would recommend contacting the manu of the motherboard. Seems like there is a issue there. I had the same issue before and after doing the same thing you did had no issues going forward. Just never got around to getting a 4k UDH player for the computer. I do however have a xbox that can play them now.
Reply
Duggyhow656 [Avatar]
Newbie Private Message Joined: Mar 18, 2017 03:51 Messages: 30 Offline
[Post New]
Quote Would really apreciate any suggestions.
I build my PC according the recommendations in this forum, SGX confirmed by the adisor for a while, but then never again...


Hi, try doing a clean install of Windows 1709 and then updating to 1803. For some reason, the latest SGX version doesn’t seem to be compatible with commercial UHD Blu-ray playback. Anyway, this is what I had to, I did all kinds of installing/reinstalling and it did no good. When I finally got SGX to working, HDCP 2.2 wasn’t available after I did a BIOS update. So, I did all the reinstalling/uninstalling again, no good. I then, did a BIOS downgrade along with a CMOS reset from the back of the pc. There is a button on Asrock mothierboards that allow you to reset the CMOS. I pushed it while pc was off and it reset the BIOS in more defined way than just saying load default values. Well, now it’s all green on uhd CyberLink advisor. I’m very thankful to all the help I received on here and other forums cause it was rough not getting to see my uhd Blu-Rays for almost 2 months I think.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team