CyberLink Community Forum
where the experts meet
| Advanced Search >
NewBlue Video Essentials II Plugin
Reply to this topic
JocelynL [Avatar]
Newbie Private Message Joined: Jan 10, 2018 18:36 Messages: 17 Offline
[Post New]
Hi,

I am a new user of PowerDirector, bought a new license today. I am testing it.

I would like to add a good plugin to PD16. The series Video Essentiels seems interesting... Compatibility question:

Is NewBlue Video Essentials II compatible with PowerDirector 16?

No trial version?

https://www.cyberlink.com/products/partner-plug-ins/partner-newblue-ve2_en_CA.html

Regards
Reply
ynotfish
Senior Contributor Private Message Location: N.S.W. Australia Joined: May 08, 2009 02:06 Messages: 9919 Offline
[Post New]
Hi Jocelyn -

Yes - absolutely compatible. I have it installed from a previous version of PDR.

I don't think there's a trial version, though if you can find it on the NewBlue site they typically have trial versions.

Cheers - Tony
Visit PDtoots. PowerDirector Tutorials, tips, free resources & more. Subscribe!
Full linked Tutorial Catalog
PDtoots happily supports fellow PowerDirector users!
Reply
JocelynL [Avatar]
Newbie Private Message Joined: Jan 10, 2018 18:36 Messages: 17 Offline
[Post New]
Hi ynotfish,

I bought the plugin yesterday.

It's working on my fresh PDP16 but the interface is in German language. I can't read German so I opened a ticket at NewBlueFx.

Regards
Reply
JocelynL [Avatar]
Newbie Private Message Joined: Jan 10, 2018 18:36 Messages: 17 Offline
[Post New]
OK, the issue is fixed. The interface is in my own language now.
Installed, activated and working!

(for infomation, I bought the plugin directly at NewBlueFx, it's 70% off)
Reply
JocelynL [Avatar]
Newbie Private Message Joined: Jan 10, 2018 18:36 Messages: 17 Offline
[Post New]
@ ynotfish, the trial versions are at : https://newbluefx.zendesk.com/hc/en-us/articles/115000796746-All-Legacy-Products For Cyberlink Powerdirector, you have to choose Consumer version

To buy and get the serial number for a trial version: https://www.newbluefx.com/newbluefx-vault/

Video Essentials II and III, installed, activated and working fine on my fresh PowerDirector 16 install + the patch 2313 installed.

This message was edited 4 times. Last update was at Jan 12. 2018 18:17

Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team