CyberLink Community Forum
where the experts meet
| Advanced Search >
when using high definition audio passthrough audio format does not display correctly on my receiver
Reply to this topic
The Red Devil [Avatar]
Newbie Private Message Joined: Sep 25, 2017 05:07 Messages: 5 Offline
[Post New]
Hi CyberLink Community Forum,

A question concerning the high definition audio passthrough audio in PowerDVD.

I tried setting the passthrough of high definition audio on my PC to my receiver through PowerDVD. I am playing a movie with DTS HDMA 7.1 and in the past the display of my receiver indicated the correct output format. Now it just displays PCM. I am using the latest Insider build of Windows 10 (build 16296).

Besides my PC I also have two tablets. On both tablets the passthrough works correctly when connected via HDMI to my receiver. The receiver correctly recognises and displays the correct audio format.

I also connected the tablets and the PC through HDMI to my receiver. The tablets have the same PowerDVD version and Windows Insider Windows 10 build as on my PC.

The only difference is that under the PowerDVD Audio options under the Miscellaneous tab there are extra DSD audio options on my PC. The tablets don't show these DSD audio options. Whichever DSD audio option I choose on my PC my receiver just displays PCM as the audio format. It doesn't seem to recognise the correct audio format. I tried different audio driver versions but to no avail. I even completely reinstalled windows 10 to rule that out.

I currently have run out of ideas. I would greatly appreciate any suggestions. Thanks in advance!

This message was edited 1 time. Last update was at Sep 25. 2017 07:23

Reply
The Red Devil [Avatar]
Newbie Private Message Joined: Sep 25, 2017 05:07 Messages: 5 Offline
[Post New]
Quote Hi CyberLink Community Forum,

A question concerning the high definition audio passthrough audio in PowerDVD.

I tried setting the passthrough of high definition audio on my PC to my receiver through PowerDVD. I am playing a movie with DTS HDMA 7.1 and in the past the display of my receiver indicated the correct output format. Now it just displays PCM. I am using the latest Insider build of Windows 10 (build 16296).

Besides my PC I also have two tablets. On both tablets the passthrough works correctly when connected via HDMI to my receiver. The receiver correctly recognises and displays the correct audio format.

I also connected the tablets and the PC through HDMI to my receiver. The tablets have the same PowerDVD version and Windows Insider Windows 10 build as on my PC.

The only difference is that under the PowerDVD Audio options under the Miscellaneous tab there are extra DSD audio options on my PC. The tablets don't show these DSD audio options. Whichever DSD audio option I choose on my PC my receiver just displays PCM as the audio format. It doesn't seem to recognise the correct audio format. I tried different audio driver versions but to no avail. I even completely reinstalled windows 10 to rule that out.

I currently have run out of ideas. I would greatly appreciate any suggestions. Thanks in advance!

Update: The problem has been solved by installing a older version of the intel display driver.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team