CyberLink Community Forum
where the experts meet
| Advanced Search >
Face tag editor button not working in PhotoDirector 7
Reply to this topic
HPG [Avatar]
Newbie Private Message Joined: Oct 06, 2012 22:45 Messages: 20 Offline
[Post New]
I've seen a bit of discussion about this concerning earlier versions of PhotoDirector, but if it's been discussed concerning 7, I've missed it. I'm finding face tagging a bit unreliable: PD doesn't appear to search all selected photos when tagging. And when I select one photo and click on the face tag editor button below the picture (in the row of tools that include rotate, mark as flagged/rejected, etc), nothing happens: it doesn't open the face tag editor. Does anyone have any suggestions for how to get into the editor?
Reply
[Post New]
Hello HPG,

Welcome to the PhotoDirector forum laughing

The Face Tag editor doesn't appear by default. You must activate it as shown in the screenshot below.

Once those extra tools are available, you can add face tags to selected photos.



It's true that PhD will sometimes miss faces or interpret other objects, like elbows or pockets, as faces. The only way around that is to edit the tags manually.

PIX PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
HPG [Avatar]
Newbie Private Message Joined: Oct 06, 2012 22:45 Messages: 20 Offline
[Post New]
Thanks for the welcome -- good to be here. I obviously didn't explain the problem clearly. The face tag icon is visible as you show it above -- I activated it as shown. It's just that nothing happens when I click on it, and the "Add face tag" to its immediate right stays greyed out. Is there another setting that I've missed?
Reply
[Post New]
Hello HPG,

It doesn't sound like you're missing anything.

I assume this is happening with all the photos you've tried, rather than particular ones. If it occurs only with certain photos, could you please upload one as an attachment?


  1. Select photo

  2. Click "Enter face tag editor" > processing. Typically PhD inserts face tags "untitled"

  3. Click "Add Face tag" and set manually


""""

N.B. Here, there are times when PhD misses obvious faces, but the Add Face Tag button is always active.

PIX

This message was edited 1 time. Last update was at Jul 03. 2016 13:20

PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
HPG [Avatar]
Newbie Private Message Joined: Oct 06, 2012 22:45 Messages: 20 Offline
[Post New]
Thanks for all your help. Your assumption is correct: this happens with every photo I try. If I follow your instructions, when I try step 2, nothing happens. The UI is recognizing the click, because the background of the Enter Face Tag Editor button changes to a slightly darker shade during the button-down event. But the Add Face Tag button does not activate; it's perpetually grayed out and inactive.

If I then click on the "Tag faces in the selected photos" icon in the row below, and it's a photo that hasn't been tagged before, it will recognize faces in the photo, so the automatic tagging seems to be working.
Reply
HPG [Avatar]
Newbie Private Message Joined: Oct 06, 2012 22:45 Messages: 20 Offline
[Post New]
Mystery solved. I hadn't noticed that the "Show multiple" view was active. As soon as I clicked on "Show one", the face tag editor began working as it should. Makes you wonder why they don't have a pop-up warning telling you that it doesn't work in "Show multiple", doesn't it, because the display is pretty much indistinguishable if you've only selected one photo in the "show multiple" view.

Thanks again for all your help.

This message was edited 1 time. Last update was at Jul 03. 2016 16:56

Reply
[Post New]
Well spotted HPG! laughing

So blindingly obvious, I missed it myself even though I've come across it previously.

PIX PhD CDR ADR DZ MVL PP Forum Moderator
PIX YouTube channel
Reply
HPG [Avatar]
Newbie Private Message Joined: Oct 06, 2012 22:45 Messages: 20 Offline
[Post New]
Ain't that always the way? I wish I had a penny for every time I've missed the blindingly obvious

HPG
Reply
KeithG1945 [Avatar]
Newbie Private Message Joined: Sep 17, 2012 04:29 Messages: 1 Offline
[Post New]
Thanks - and now in 2021 this worked for me too in PD v11. laughingWish I'd searched sooner . undecided
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team