Announcement: Our new CyberLink Feedback Forum has arrived! Please transfer to our new forum to provide your feedback or to start a new discussion. The content on this CyberLink Community forum is now read only, but will continue to be available as a user resource. Thanks!
CyberLink Community Forum
where the experts meet
| Advanced Search >
Incompatible elements in PD9 projects
rbowser [Avatar]
Contributor Joined: Aug 08, 2011 16:48 Messages: 515 Offline
[Post New]
I finally upgraded to PD11 because I couldn't stand not being able to keep my NVIDIA drivers up to date, since PD9 wasn't compatible with them.

Before upgrading, I tried to find info on how PD9 project files would open in PD11, couldn't find any posts, so bit the bullet and went for it.

I've opened a PD9 project in PD11, and now know that not everything is compatible. If only Cyberlink would do what every other software company whose products I use do, and allow more than one version of the program to be on a computer. For instance, I must have 10 versions of Cakewalk Sonar happily co-existing. Why PD11's installer had to automatically uninstall PD9 is beyond me. But, since that's the way Cyberlink has things, I'm now stuck with project files that are partially broken.

Hopefully some experienced PD11 users can help me out:

--When I was opening the old PD9 project, an error message came up saying two image files couldn't be found - "SKY2.png" and "bk1.png." I don't recognize what the "sky" image would be, but now I've found "bk1.png" in
Documents>Cyberlink>PowerDirector>9>MyPinPs>Particle_002. It's just a black background. Not sure where it was used in the project. When I opened the project, I'm not sure I could see where these would be missing, but I did have problems with the PiPs, more below--

--At first, an automated fade to white on a clip didn't work. I had used keyframes to automate the Brightness control under Fix/Enhance, until it was 100% at the end of the clip. The automation was still moving the Brightness control, but wasn't producing any change in playback. After poking around at the controls under Keyframes for awhile, it just suddenly started working. Have no idea what that was about.

--I had used Bubbles over one clip, but they come out now as small red squares. After looking around, I can see that the "05_Bubble" image, which is still the label on the PiP clip, is on the computer in Program FilesX86 Content Pack Essential\Particle\pdrv9_particle-05 Object\object5." So the location path has been broken. It looks like the only way to get back the effect I had is to re-construct the whole effect, this time of course using the new location.--- Any ideas on how I could do that more efficiently?

--Same thing with another clip where I'd superimposed 01_Star - It also comes up as that place holder small red square, because the path for the image has been changed. -- Dang - why'd they have to do this? Using Sonar as an example again, new versions of the program will have a lot of the same content as older versions, but they don't MOVE those elements for goodness sake, they use the established, common path, so all versions of the program will always be in sync. It's just dumb programming to arbitrarily move data like that. The result is exactly like what I'm seeing now - old project files that have invalid paths to elements. Really dumb.

--The masks on the clips where I'd masked edges of the screen don't work anymore. Are these masks now in a new location too I suppose? I tried to start editing the masks, re-doing the automation and everything, - but the PiP Designer froze every time, no way to edit.-- ?

Under the Produce tab - ALL CUSTOM PROFILES are gone! omg--I had a big collection of custom profile edits that I relied on, and arrived at after much time consuming trial and error. Why are these gone?--- Are they here somewhere on the computer and I can re-direct PD11 to them?

--SOUND issue - I use an ASIO audio interface. Now, the sound during playback in PD11 will randomly cut out, and sometimes come out with an incredibly loud burst of white noise. I've heard that behavior before when programs are struggling with ASIO drivers - but I had things in PD9 so nothing of this sort happened. Any ASIO users with tips?

Basically, the biggest problem is broken paths to elements. If only Cyberlink would be like ALL companies I'm aware of, and simply let us have two versions side by side on a computer. I could happily work away on my old projects in PD9 and finish them, and use PD11 for new things. As it is - this upgrade has just added an enormous amount of work for me, days and days of re-doing what I've already done. Bad programming.

Any tips or suggestions?

Thanks.

rbowser
ynotfish
Senior Contributor Location: N.S.W. Australia Joined: May 08, 2009 02:06 Messages: 9977 Offline
[Post New]
Hi rbowser -

Whoa! This will take some time to work through. I'm sure other members will join in to help get your projects functioning again.

Your issue(s), I think, partly arise out of purchasing the upgrade version. On one of my PCs, I have PD9, 10 & 11 cohabiting (full versions - not upgrades).

You said "Under the Produce tab - ALL CUSTOM PROFILES are gone!" These are probably retrievable. If they were MPEG-4, MOV, AVC H.264, you'll find them in C:\Users\xxxx\AppData\Roaming\CyberLink\PowerDirector\9.0 in the Profile.ini

All you need to do is
1. open the Profile.ini in Notepad
2. select all & copy
3. go to the corresponding Profile.ini at C:\Users\xxxx\AppData\Roaming\CyberLink\PowerDirector\11.0
4. open that document - put the cursor after the last &
5. paste, save & close.

If they were WMV profiles, they were probably uninstalled. There's a collection of WMV profiles attached that belong in C:\Program Files (x86)\CyberLink\PowerDirector11\Language\enu\Profiles or in the corresponding Program Files folder.

That should help with about 5% of your question.

Cheers - Tony
 Filename
Profiles_WMV.zip
[Disk]
 Description
 Filesize
55 Kbytes
 Downloaded:
234 time(s)

Visit PDtoots. PowerDirector Tutorials, tips, free resources & more. Subscribe!
Full linked Tutorial Catalog
PDtoots happily supports fellow PowerDirector users!
rbowser [Avatar]
Contributor Joined: Aug 08, 2011 16:48 Messages: 515 Offline
[Post New]
Quote: ...Your issue(s), I think, partly arise out of purchasing the upgrade version. On one of my PCs, I have PD9, 10 & 11 cohabiting (full versions - not upgrades).

You said "Under the Produce tab - ALL CUSTOM PROFILES are gone!" These are probably retrievable...

That should help with about 5% of your question.

Cheers - Tony

Hi, Tony! Thanks for the reply - Hey, helping with 5% is at least a start! But actually you've probably answered much of what I've asked.

---I decided to update, I bought the program - I had NO idea there was a difference in an "upgrade version" and a "full version"--What?? I've never heard of such a thing. I wanted PD11, I used the only option I could see - I can't believe it. I would have given ANYTHING to not lose my PD9. This really bums me out. I had not a clue regarding any of it - That I had a choice of versions to buy???? and that if I'd somehow found a different way to buy it, I could have had both versions. OK - now I'm more than bummed - I'm POd.

I'm betting that the issues of data, like the PiP elements being moved like that has to do with buying this version too.

---This sounds great about finding the profiles - I'll follow your instructions.

Hey - maybe I can uninstall PD11, re-install PD9, since I still have the .exe file - and then figure out how in the heck to buy this other version you're talking about.

grrrrrrrr - But thanks, I appreciate the reply.

rbowser
Powered by JForum 2.1.8 © JForum Team