CyberLink Community Forum
where the experts meet
| Advanced Search >
PowerDVD 17 doesn't run
Reply to this topic
Dee-Dee [Avatar]
Newbie Private Message Joined: Dec 31, 2017 11:16 Messages: 2 Offline
[Post New]
My factory installed Cyberlink 12 Software for toshiba laptop stopped working and so I assumed updating to the latest Cyberlink Software would solve the problem, and I was wrong it did not solve the problem.

I purchased the latest update to Power DVD and had nothing but troubles operating the software: in fact software just would not work. I tried everything. I installed patches, I made changes to settings, and nothing worked.

I have a Toshiba Satellite Laptop on Windows 10. Cyberlink software was factory installed and software is a version made for my Toshiba Laptop.

In the end after opening two support tickets with Cyberlink and followed all their instructions of which none fixed the problem. I had no choice but to ask for a refund, and the refund was issued very quickly.

However, I was still faced with the problem that the original factory Cyberlink installed DVD player did not work.

I resorted to some very drastic action: and have fixed the problem.

First of all what I did was I completely uninstalled the new Cyberlink Software. I mean completely uninstalled all of it. I shut my computer down completely and did a fresh restart. I also performed disk clean ups, did a defragment, and I ran thorough scans using McAfee and C-Cleaner Software to clean cache, and fix registry errors etc and I also ran Click & Clean to clear cache for Internet Explorer, Google Chrome etc and other browsers. I made certain all updates for Windows was current and installed. This process was very worthwhile as my PC start-up was fast, and operating at optimum speed.

Neither Toshiba Manufacturer or Cyberlink could answer my question about the orignal Cyberlink factory install software, that if I deleted this software, would it reinstall, and would I need to purchase a new license. The fact I could not receive any guarantee helped me find a solution.

I wanted to avoid doing a fresh install of windows, or completely wipe and reformat , or do a system restore, as I felt all these suggestions were drastic measures.

So what I felt the best thing to do, was look on my C-Drive and find where on the Program files the Cyberlink 12 software was stored, and I found the Installation icon to re-install software. I clicked it and the entire Cyberlink 12 software reinstalled. I restarted my pc, and then opened the software, and for the first time in 6 months Cyberlink Power DVD Player worked.

Rather than reinstall the software by obtaining a fresh copy look for where the original software is stored on your computer, look for the icon that will launch a fresh install of the original software. Installation Wizard will take care of a fresh install, when screens popped up with the wizard asking for permission to remove old or existingversion before reinstalling fresh copy/version I clicked yes, and this resolved all the problems and Cyberlink Version12 is now working. I have not attempted to install the latest new version of Cyberlink Software: I just don't want to take the risk. Although Cyberlink Version 12 software is not as good as the latest version, I am just relieved original software is now operating correctly.

Please be aware, the steps I have taken worked for me: it does not guarantee the same remedy will be successful on other people's computer. I hope by sharing my experience and my remedy that somehow it might give ideas to others on steps they could take to fix problem they have with Cyberlink software.
Reply
USMC0311
Newbie Private Message Location: South Padre Island TX Joined: Nov 11, 2017 05:00 Messages: 11 Offline
[Post New]
Quote


There have been several install program problems with the latest Windows 10 Fall Update. Did you install it?

If so, roll back to the previous version of Windows 10.

For instance (link)


Well sir let me tell you this program PDR17 is the worst one I have had the displeasure of using. I have had every version since 2010 and had PDR16 working ok on my 2010 HP pavilion then after hearing that I needed to update my laptop to enjoy a smoother experience with cyberlink software I bought a $1,200 Super gaming model desighned for gamers and for video creators I purchased an MSI GL73 8RC 128 GB SSD , 1 TB HDD 16 GB ram, NVIDIA 1050 graphics card with intel graphics. Intel 8th generation I7 processors counting 6 yes six cores to handle what ever i can throw at it and it still makes no digfference. I too have tech support tickets pending and tonight my Contenet UNAWARE feature crashed again as did the TRim option . I am so sick of this purpetual techsupport loop over the past several years i could just kick my own ass for continuing to upgrade this stuff. I have my DXDIAG, I have all my current drivers I have ......and ...... and.... that is reqiuird when requesting tech support. And hell my PDR17 as 16 did has the fancy send an OOPs re[pport ASAP to the manufactirer to improve the product. It has crashed 13 times and generateed 13 reports and guess what tonight it crashed when I was trying to give myy detailed reapeatable scenerio to cyberlink yes the reporting software crashed again!

I kmow my soellimng is trashed right now because i am beating my keyboard and don't give one crap if it looks messy and mentally challemnged I lost another 6 hours of work tonight. You think they are gonna care if my softearw sucks? no they wat what they paid for ads and family legacy and wedding videos [roduced with my over 900 custom comtributions to the DirectorZOMNE!!! I hope you at least get yours to work but once you do don't be surprised if it makes you nuts too. Sorry for the aggravated reply to your questions but just wanted everyoe to know you are not alone. And if the moderators Gone Fishin or thomas assault me with backlash so be it they already kicked me off the powerdirector users group for daring to ask a question rekated to a specific request for my videos was sent to me ia sked a question and that was the end of my participatin I found a hidden feature in the 360 softwre that allows you to use still photos to create panoramic tours and none of them knew about it and told me it could not be done. So watch me get launched from here too for being so frustrated with is system and progrom Honor, Country and Corps
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team