CyberLink Community Forum
where the experts meet
| Advanced Search >
Problems updating PD16
Reply to this topic
patrickyoung [Avatar]
Newbie Private Message Joined: May 19, 2019 03:45 Messages: 13 Offline
[Post New]
I've just managed to reinstall PD16 onto my desktop but can't get it to update for the PD16 patch. When I run the downloader I get a message saying Cyberlink Downloader could not complete the download process. I've made sure that Power Director is listed in my allowed apps on Windows Firewall but its still not connecting. The only thing I can think of is that my Power Director is installed on my E drive (an external drive with lots of space) rather than my C Drive (which has very little space left). Could this be the problem? Is there any way I can get the patch without using the downloader or is there some way I can get the downloader to work? Without the patch, every time I try to edit a clip I get a Media Source Error Code 2 warning.
Reply
PowerDirector Moderator [Avatar]
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 1863 Offline
[Post New]
Quote I've just managed to reinstall PD16 onto my desktop but can't get it to update for the PD16 patch. When I run the downloader I get a message saying Cyberlink Downloader could not complete the download process. I've made sure that Power Director is listed in my allowed apps on Windows Firewall but its still not connecting. The only thing I can think of is that my Power Director is installed on my E drive (an external drive with lots of space) rather than my C Drive (which has very little space left). Could this be the problem? Is there any way I can get the patch without using the downloader or is there some way I can get the downloader to work? Without the patch, every time I try to edit a clip I get a Media Source Error Code 2 warning.


Hi,
Given your configuration, you might be better to raise a ticket with support [link in the signature below] to get an opinion from them whether your setup is affecting the download process.

Not sure if any members will be able to duplicate/troubleshoot this directly but someone might suggest a workaround to try?

Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
patrickyoung [Avatar]
Newbie Private Message Joined: May 19, 2019 03:45 Messages: 13 Offline
[Post New]
Quote


Hi,
Given your configuration, you might be better to raise a ticket with support [link in the signature below] to get an opinion from them whether your setup is affecting the download process.

Not sure if any members will be able to duplicate/troubleshoot this directly but someone might suggest a workaround to try?

Cheers
PowerDirector Moderator


Brilliant. Thanks. I appreciate your help with this.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team