CyberLink Community Forum
where the experts meet
| Advanced Search >
Cant connect to youtube
Reply to this topic
will_s [Avatar]
Member Private Message Joined: Oct 18, 2015 05:43 Messages: 65 Offline
[Post New]
Well, Cyberlink can't connect to upload my video. This happened after the latest update which I installed.

But youtube is working fine, I can open and see videos and play videos but cyberlink wont connect
Reply
PowerDirector Moderator [Avatar]
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 1869 Offline
[Post New]
Hello,

We got info from CyberLink that it is a YouTube server issue and they are working on it. YouTube updates its API constantly, so most likely that.

As a workaround produce your video first in PowerDirector, and then upload the produced video via a browser (e.g. Google Chrome, Edge).

Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
Elite2996 [Avatar]
Newbie Private Message Joined: Oct 16, 2021 13:04 Messages: 1 Offline
[Post New]
I'm having the same issue and it's been going on for about a week now. Whenever I go to produce it saids "can't connect to YouTube server" or something like that. I tried uploading my videos from the YouTube website by selecting a file but it ends up saying "invalid file format". This has to be on cyberlink because everyone else is able to upload videos. Idk what's going on but I hope its fixed soon.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 8074 Offline
[Post New]
I also get an error message when tyring to produce to YouTube, but I'm not impacted at all since I never use that method. All of my channel's 1000+ videos have been manually uploaded.

What format did you produce to? On the Produce page, use the Standard 2D tab then click on Profile Analyzer and pick one of the suggested options there.

Typical formats these days are H.264/AVC and H.26h/HEVC with an M2TS or MP4 extension, and YouTube will easily handle both.

FWIW, The only one of the 4 online choices that doesn't eventually time out with an error message is Vimeo.

This message was edited 3 times. Last update was at May 25. 2022 18:48

Reply
Thag Simmons [Avatar]
Newbie Private Message Joined: Jan 22, 2023 15:04 Messages: 2 Offline
[Post New]
I updated my version of PowerDirector this week. I'm using version 21.1.2401.0 version type 365.
On the produce file screen, I selected YouTube for the output option filled in all the available boxes, and clicked Start. I get a pop up window with the title "Sign in to YouTube" and the window content text is: "Sign in to your YouTube account and grant PowerDirector permission to upload video." The Sign in button is enabled, but when I click it nothing happens. No windows open, the (barely visible) "next" button at the bottom of the pop up window is not enabled or changed in any way, and there is no way for me to progress further.
I'm running this on a windows 11 pro laptop with 32gb of ram and an I9 CPU.
I've checked the windows application log and can't see any errors.
I'm able to access youtube without issue in any browser.
I have attached an image of the pop up window showing the button that doesn't do anything.
[Thumb - Youtube Popup.png]
 Filename
Youtube Popup.png
[Disk]
 Description
 Filesize
33 Kbytes
 Downloaded:
2 time(s)
Reply
PowerDirector Moderator [Avatar]
Senior Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 1869 Offline
[Post New]
Quote I updated my version of PowerDirector this week. I'm using version 21.1.2401.0 version type 365.
On the produce file screen, I selected YouTube for the output option filled in all the available boxes, and clicked Start. I get a pop up window with the title "Sign in to YouTube" and the window content text is: "Sign in to your YouTube account and grant PowerDirector permission to upload video." The Sign in button is enabled, but when I click it nothing happens. No windows open, the (barely visible) "next" button at the bottom of the pop up window is not enabled or changed in any way, and there is no way for me to progress further.
I'm running this on a windows 11 pro laptop with 32gb of ram and an I9 CPU.
I've checked the windows application log and can't see any errors.
I'm able to access youtube without issue in any browser.
I have attached an image of the pop up window showing the button that doesn't do anything.


Hi,

I rarely use the direct PDR upload. I can't recollect doing so on this current desktop system - so I thought I'd test it out in response to your issue.

On the "Sign in to YouTube" window, when I selected the "Sign in to your YouTube account and grant PowerDirector permission to upload video." a Sign in with Google access page was opened on my 2nd monitor, giving me a choice of accounts etc.
I selected the required account, which gave me a "CyberLink PowerDirector wants to access your Google Account" which I allowed.
I got an "Authentication successful, back to the program to proceed" and the "Sign in to YouTube" dialogue gave a green "Authentication successful......"message and the Next button became active.

Is there a "hidden" window opening on the laptop that requires an input as above?

Perhaps other members can shed light from their experiences.

Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
Thag Simmons [Avatar]
Newbie Private Message Joined: Jan 22, 2023 15:04 Messages: 2 Offline
[Post New]
Quote


Hi,

I rarely use the direct PDR upload. I can't recollect doing so on this current desktop system - so I thought I'd test it out in response to your issue.

On the "Sign in to YouTube" window, when I selected the "Sign in to your YouTube account and grant PowerDirector permission to upload video." a Sign in with Google access page was opened on my 2nd monitor, giving me a choice of accounts etc.
I selected the required account, which gave me a "CyberLink PowerDirector wants to access your Google Account" which I allowed.
I got an "Authentication successful, back to the program to proceed" and the "Sign in to YouTube" dialogue gave a green "Authentication successful......"message and the Next button became active.

Is there a "hidden" window opening on the laptop that requires an input as above?

Perhaps other members can shed light from their experiences.

Cheers
PowerDirector Moderator


Thanks for looking into that for me! On a Sunday too. It's greatly appreciated.

Unfortunately, there are no hidden windows. I've tried to Alt Tab throgh everyting that's running, and not seen any other windows pop up, I've also tried to disable my antivirus and firewall, in case that made a difference, but no luck unfortunately.
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 8074 Offline
[Post New]
As PDM said, you need to make choices in a browser window before producing directly to YT. Here's what they should look like:

If you have multiple google accounts, you'll need to choose one

Then/otherwise you need to grant the following permissions


At that point the webpage changes to this message


and PD should regain the focus with this confirmation screen



If you're not getting any browser action when you click on Sign In, maybe try uninstalling PD (right click on it in the CL App manager and choose Uninstall) and then reboot. Now install it again and see if that helps. If you still don't get a browser response, I think you should report the issue to CL tech support from the link in PDM's signature and see if they can assist you.

FWIW, I always produce my videos to my hard drive then use the Create | Upload Video tool on YT to publish it. The options for directly sharing the video from PD are limited - including not being able to make the video unlisted - whereas I have full control from the YT Studio page.

One last thing is there seems to be a display problem with overlapping options on my system that doesn't go away if I resize the window

Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team