CyberLink Community Forum
where the experts meet
| Advanced Search >
Updating Cyberlink Application manager (not working)
Reply to this topic
MrPadded [Avatar]
Newbie Private Message Joined: Feb 21, 2014 02:42 Messages: 41 Offline
[Post New]
Hi there,

I'm hoping for some help. I'm a 365 subscriber and having an issue with updating the application manager. I get a message that I'm missing out on a smoother experience and press update but then it just sits on "updating cyberlink application manager..."

Very strange and I've never had this problem before. I've got pretty good internet so that's not the issue, it just doesn't seem to be doing anything?


Thanks for the help in advance.
Reply
KCwho [Avatar]
Administrator Private Message Joined: May 02, 2014 03:14 Messages: 11 Offline
[Post New]
Try download the Application Manager from CL website directly and reinstall it.

https://www.cyberlink.com/downloads/application-manager/download_en_US.html

This message was edited 1 time. Last update was at Jan 06. 2020 01:45

Reply
BernardFiat [Avatar]
Newbie Private Message Joined: Jan 06, 2020 14:30 Messages: 1 Offline
[Post New]
Yes it's OK
Reply
Phoenix Elvis Nicholson [Avatar]
Member Private Message Location: Madison, Alabama USA Joined: May 29, 2020 14:46 Messages: 86 Offline
[Post New]
Just recently purchased PD 19
Downloaded and installed Application Manager within the last hour
It does not recognize that I have PD 19 installed.

The message I get is:
You haven't installed any of your programs yet, or they are currently hidden.

OD 18 is up and running as it displays this message.

This message was edited 1 time. Last update was at Feb 08. 2021 08:00

.
.
Intel i5-9400F / B 360M MB (MS-7B19) 2.9 Ghz / 32 GB DDR4 / Radeon RX580
Personal website https://www.PENwords.net
.
.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team