CyberLink Community Forum
where the experts meet
| Advanced Search >
Why doesn't a Cyberlink Tech answer my post?
dc8flyer [Avatar]
Newbie Private Message Joined: May 03, 2011 19:34 Messages: 33 Offline
[Post New]
It has been about three weeks now and I still have not been able to recover my PDVD 12 Ultra after Cyberlink turned my product into a trial version.

All attempts to download their fix have failed. The latest support message from Cyberlink was disappointing. First they tell me I am not following their directions and then tell me everyone else has had no problem fixing their error.

Well, sorry, but it isn't working for me. Then they send me this zip file to clean out the registry. It didn't matter that I have already explained to them I have accomplished this but I do it any way. Then I'm told to download the file from their link again but the link has expired.

This is beyond any intelligent rationalization. I have asked specific questions concerning the download from their link and not once will they answer. It is a very simple question and all it is is what size is the download file for PDVD 12 Ultra suppose to be. When I download it it only shows 113 mb, but the updates are bigger than that. Yet No One in support will address my question.

They ask for specific information and I send it to them in the attachments and they act like they don't see it.

Why are the techs from Cyberlink on this forum ingnoring my posts as well?

I have asked that if their fix doesn't work to refund me for my purchases. From PVD 8 upto PDVD 12 Ultra. I have been a loyal customer for years and this is how they end up treating you.

I would like to speak to someone but their coorporate office number is useless and I don't see any point in paying for phone support when this issue was not of my making.

So far I have been ignored on this forum twice before concerning this issue. The first request was addressed but since then Cyberlink refuses to address my issue.

Will anyone from Cyberlink help this time?

Anonymous [Avatar]
[Post New]
Not sure if this will help, but I found that sometimes downloads fail with no error if there is already a previous download with the same name in your local\temp directory. The previous download may be incomplete and the downloading manager (or whatever) may not be able to delete the previous download. For windows 7x64 downloads occur in


using the Dos prompt, change to the AppData\local directory and issue the following command

rmdir /s temp

If the temp directory is actually deleted (very rare this actually happens) be sure to re-create it with

mkdir temp

Deleting all files in your temp directory will clear out any old downloads that might be interfering with your update.

The above worked for me with an upgrade to Nero and on another occasion an upgrade to Acronis that had failed to occur because a bad download was stuck and could not be deleted.


That temp directory is used to unpack and assemble installation modules. Some vendors puts downloads into username\downloads but many use that temp directory first and that is where the problem can occur.

This message was edited 1 time. Last update was at May 26. 2012 08:34

dc8flyer [Avatar]
Newbie Private Message Joined: May 03, 2011 19:34 Messages: 33 Offline
[Post New]
Thanks for the help.

I tried cleaning out all files etc, even went into the reedit and clean out all cyberlink entries. Still not working.

As usual, cyber link replied without answering my direct questions. Seems they are either incompetent or can't respond to anything else but their canned response, since I get the same post from them each time without them addressing the technical issue.

I did notice that the latest build update was suppose to correct the issue I am having. The program will download but the region code drops out and you can't reset it. I suspect this is the cause of my repeated failures but the brains at cyber link never address the specific issue. They just keep sendidng me the same download.

You may also have noticed that no tech from cyber ever answers this issue on the forum. Makes me wonder what this forum is for.

Time to punt this company for one that has a working program and support that when they scew up doesn't ell you to buy phone support if you want to talk to them.

Really piss poor. Service from cyberlink.
peleus [Avatar]
Member Private Message Joined: May 10, 2012 11:53 Messages: 58 Offline
[Post New]
Hi dc8flyer, what build number are you using right now? I just need to verify this just to get it out of the equation.
dc8flyer [Avatar]
Newbie Private Message Joined: May 03, 2011 19:34 Messages: 33 Offline
[Post New]
I was running Ultra 12 build 1514.54. I then download the update that turned my product into a trial version. It had build 1618c.54

I had repeatedly tried to reinstall from the link Cyber provided and it would download but never run Blurays. I would get two errors saying it could not access the drive and another saying it was a anti-virus protection problem. These two errors were not the problem.

After installing the software. preferences became the issue. On the Settings tab "Blu-ray Disc, I could not adjust and Country code and the region code was frozen as well and grayed out somewhat. The "Changes remaining" always showed zero as well.

This was the technical issue I tried repeatedly to get tech support to address but they just never seemed interested, Instead I was told no else was having this problem.

I have since given up hoping Cyberlink would help so I did what I had hoped to avoid.

I reinstalled my old HDD back into my computer, updated three weeks of files etc... and then reformatted my SSD. The HDD had a working Cyberlink Ultra 12 on it.

No thanks to Cyberlink and more than two weeks of useless canned responses, I broke down and spent a whole night having to reinstall my SSD.

While I think the product is a good one and have been with Cyberlink for years, I can't tell you how poorly their tech support worked this isse. From not even saying they were sorry for what hey had caused (until I mentioned to them that they should) to telling me "no one else is having this problem" I can't tell you how disappointed and irritated Cyberlink has made me. Their incompetence cost me weeks of time that I really didn't have time for.

Powered by JForum 2.1.8 © JForum Team