CyberLink Community Forum
where the experts meet
| Advanced Search >
DisplayPort works; HDMI doesn't
Reply to this topic
PhilTheDoc [Avatar]
Newbie Private Message Joined: Nov 17, 2019 07:49 Messages: 3 Offline
[Post New]
I can play 4K UHD Blu-rays on my PC as long as the PC and monitor are connected using the onboard DisplayPort interface. if I change the connection to HDMI, I can't. Weird!

With a DisplayPort connection, Cyberlink Advisor passes everything. Switch to HDMI, everything passes except that HDCP 2.2 and HDR are reported as "not available".

This matters because I want to move the PC to the lounge to connect to my Samsung TV to watch 4K UHD Blu-rays in comfort - and I can't because the TV only has HDMI inputs. I've reied - no joy.

All drivers and software are up to date, and I've reinstalled the graphics driver and the Intel Management Engine. SGX is working OK. I've tried different HDMI cables - but I don't think that should make any difference. What's going on? Thanks!

Asrock Z390 Phantom Gaming ITX/ac
Core i7 9700K
Pioneer BDR-211EBK
Benq PD2700U monitor
PowerDVD 17
Reply
QC2.0 [Avatar]
Contributor Private Message Joined: Apr 27, 2016 04:02 Messages: 439 Offline
[Post New]
The best guess is that the Intel graphics or the motherboard cannot operate HDCP 2.2 authentication on the HDMI port specifically.

Update your Intel GPU driver from ASRock page (but not Intel page) to the latest version.
Update your BIOS from motherboard vendor's page (you should be very careful and know what your are doing because it might compromise the normal functionalities if anything goes wrong)

All above methods failed, contact ASRock for help.
Reply
PhilTheDoc [Avatar]
Newbie Private Message Joined: Nov 17, 2019 07:49 Messages: 3 Offline
[Post New]
Quote The best guess is that the Intel graphics or the motherboard cannot operate HDCP 2.2 authentication on the HDMI port specifically.

Update your Intel GPU driver from ASRock page (but not Intel page) to the latest version.
Update your BIOS from motherboard vendor's page (you should be very careful and know what your are doing because it might compromise the normal functionalities if anything goes wrong)

All above methods failed, contact ASRock for help.


Thanks - all good suggestions. I've sent a request to ASRock for advice already, but I'll make sure everything else is up to date as per ASRock and I'll report back.
Reply
PhilTheDoc [Avatar]
Newbie Private Message Joined: Nov 17, 2019 07:49 Messages: 3 Offline
[Post New]
I've made sure the graphics driver is the latest on the ASRock website, and the BIOS is the latest as well. No joy. Still no HDCP 2.2 or HDR on the HDMI output. The DisplayPort works fine. No reply from ASRock support. There are a multitude of settings in the BIOS that I don't understand, but nothing that seems to have an impact on the HDMI output particularly. I'm now completely stuck.
Reply
keiragramp [Avatar]
Newbie Private Message Joined: Dec 31, 2019 01:32 Messages: 1 Offline
[Post New]
For the record the Display Port signal is not compatible with HDMI. If the DisplayPort output is a Dual mode DisplayPort then it has the ability to recognize and adjust the signal to HDMI when a passive adapter cable is connected.
Reply
Steve Simonis [Avatar]
Newbie Private Message Joined: Feb 04, 2020 06:47 Messages: 1 Offline
[Post New]
I have the exact same problem. Same motherboard. Asrock Z390 Phantom Gaming itx/ac

Really been down lot's of rabbit holes with this. Ever find a solution? I'm ready to RMA this thing if Asrock Support ever responds.

S

Asrock Z390 Phantom Gaming itx/ac
serial# 9CM0XB179033
BIOS Ver. 4.4
ntel I-5 9400
16GB Corsair Vengeance LPX 2666 DDR4 CL16 (2x8GB)
WD 500 GB Black Nvme M.2
Silverstone 850w Strider Platinum Power supply
Noctura NH=L9I fan
No GPU. Using Intel Graphics UHD 630 on CPU

Windows 10pro - 64 bit
Intel Graphics Driver Ver. 26.20.100/7755
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team